Panel turns black when maximizing terminal with nvidia graphics driver

Bug #777606 reported by Alexander Weinert on 2011-05-05
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xfce4-terminal
Unknown
Unknown
nvidia-graphics-drivers (Ubuntu)
Medium
Unassigned
vte (Ubuntu)
Low
Unassigned
xfce4-terminal (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xfce4-panel

I am using Xubuntu 11.04 with the 2.6.38-8-generic-Kernel. The Panel has the version 4.8.3-0ubuntu1, the terminal is in version 0.4.7-0ubuntu1.

When I maximize a xfce4-terminal by hitting Alt+F10 or clicking the maximize-button in the upper right corner, the window maximizes correctly, but the panel turns pitch black. Only when I hover over the icons they are redrawn, however, the rest of the panel still remains black.

Xfce4-panel --restart solves the problem until I maximize the terminal again.

Addition: This only occurs with the proprietary Nvidia-Graphics-driver. If I deactivate that the panel works fine

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xfce4-panel 4.8.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu May 5 08:19:19 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/zsh
SourcePackage: xfce4-panel
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
tags: added: driver nvidia
Joseph Coffland (jcoffland) wrote :

I have this same problem in 11.04 Ubuntu using gnome with the xfce-terminal. I also have a number of other related screen problems when xfce-terminal is on the screen.

  1) Resizing the terminal draws a black box on the top of the screen.
  2) Changing themes causes xfce-terminal to redraw and create a black box at the top of the screen and/or screen garbage.
  3) gnome-panel, when not in autohide, goes black when xfce-terminal is maximized.

All of these are related to redrawing the xfce-terminal in 11.04.

I'm also using the Nvidia driver.

I think this is a xfce-terminal bug not a panel bug.

affects: xfce4-panel (Ubuntu) → xfce4-terminal (Ubuntu)
Dei Graleitur (aglinthas) wrote :

I have the same problem. It took me awhile to figure out what was going on. Also, I've seen other weirdness in other windows, where text is 'blacked out', which could be related. WTF? (All was fine before going from 10.4-> 10.10-> 11.04 xubuntu)

Dei Graleitur (aglinthas) wrote :

Addition: I installed the Lubuntu desktop (wow... it's awesome), and this issue still exists, so it's not contained to Xubuntu. It also happens with LxTerm. If I move the panel from the top to the left, it blacks out just the same. I'm also using Nvidia driver (270.x.x) and using (a custom build) of 2.6.38.6 (stock kernel, not with Ubuntu mods).

Lars Volker (lv) wrote :

Same problem here. Enabling the compositor removes the resizing-issue.

Dei Graleitur (aglinthas) wrote :

Verified enabling compositor works around Nvidia's bug. Thanks Lars!

Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. Unfortunately, the developers must have more information before beginning to work on this bug. Is everyone experiencing this issue using the NVidia proprietary drivers?

Please tell us which driver is in use. I am unable to reproduce this issue with the NVidia Current driver.

Changed in xfce4-terminal (Ubuntu):
status: New → Incomplete
Lars Volker (lv) wrote :

nvidia-current 270.41.06-0ubuntu1

Dei Graleitur (aglinthas) wrote :

uname: Linux (host) 2.6.38.6- #2 SMP Thu May 12 19:37:38 MDT 2011 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu 11.04

Nvidia Driver: 270.41.06 (Mon Apr 18 15:10:15 PDT 2011)

Card:
[ 22.791] (II) NVIDIA(0): NVIDIA GPU GeForce 6200 LE (NV44) at PCI:2:0:0 (GPU-0)
[ 22.791] (--) NVIDIA(0): Memory: 524288 kBytes
[ 22.791] (--) NVIDIA(0): VideoBIOS: 05.44.02.45.07

klo (klo-2k) wrote :

Dell XPS M1530
Xubuntu 11.04 on 2.6.38-8-generic - upgraded from 10.10
nvidia driver 270.41.06 on GeForce 8600M GT, driving 2 1920x1200 screen - 2nd monitor hooked up via HDMI
X server: 1.10.1
Compositor off - turning it on resolves the issue

The attached screenshot was taken after maximising xfce4-terminal on 2nd monitor, then dragging the vnstat window around on the 1st monitor.

Matthias Menzel (mm1234) wrote :

I can confirm it to occur on a freshly installed xubuntu natty.

nvidia-current=270.41.19-0ubuntu1~xup~natty

Card: VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)

Forest (foresto) wrote :

I see the problem when using nvidia-current 270.41.06-0ubuntu1.

In addition to black / not-repainted areas on screen when I resize xfce4-terminal, they sometimes appear when I switch between workspaces (aka virtual desktops). The problem is hidden if I enable compositing in the window manager, which makes sense for a problem related to repainting.

I think it's safe to say at this point that we're all using the proprietary nvidia drive 270.41, so I'm going to remove the "incomplete" status on this bug.

Changed in xfce4-terminal (Ubuntu):
status: Incomplete → New
summary: - Panel turns black when maximizing terminal
+ Panel turns black when maximizing terminal with nvidia graphics driver
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in xfce4-terminal (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
bugbot (bugbot) on 2011-06-28
tags: added: xubuntu
Pedro Villavicencio (pedro) wrote :

someone having the issue needs to send it to bugzilla.gnome.org (for the vte bug)

Changed in vte (Ubuntu):
importance: Undecided → Low
Changed in vte (Ubuntu):
status: New → Confirmed
Lars Volker (lv) wrote :
Bryce Harrington (bryce) wrote :

Hey alexander-weinert,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
Lars Volker (lv) wrote :

For me the issue has not occurred since I upgraded to oneiric. As I do not run other natty systems, we can close the bug. What about the others?

Upstream doesn't seem willing to take on this one.

Bryce Harrington (bryce) on 2012-02-04
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Fix Released

Changing the status to invalid as per xfce4-terminal upstream report.

Changed in xfce4-terminal (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.