alt + backspace; alt+d etc. don't work anymore

Bug #619754 reported by Alexander Sack on 2010-08-18
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Fix Released
Wishlist
vte (Ubuntu)
High
Robert Ancell

Bug Description

Binary package hint: gnome-terminal

since recent update alt key isnt useful in gnome-terminal anymore. this is major regression for my way of typing. Please fix. ask for more info on IRC. thanks!

Tobias Wolf (towolf) wrote :

Can confirm.

This is the Gnome bug whose fix broke it:
https://bugzilla.gnome.org/show_bug.cgi?id=601926

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Tobias Wolf (towolf) wrote :

I think that’s vte, not g-t.

affects: gnome-terminal (Ubuntu) → vte (Ubuntu)
Anmar Oueja (anmar) wrote :

I used to be able to do alt+a with Weechat to see the rooms I had activities in and that stopped working. I have to use Esc+a instead. It used to work just fine. I have Maverick with the latest updates as of Aug 18 - 13:20 UTC.

Mingming Ren (portis25) wrote :

Downgrade vte to 0.24.3 fixed the problem.

Changed in vte (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in vte (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-10.10-beta
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-potential
Changed in vte (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Robert Ancell (robert-ancell)
Anders Kaseorg (andersk) wrote :

I can confirm that reverting http://git.gnome.org/browse/vte/commit/?id=b73782a28894e25ed146271f9d6c6775a6836199 fixes the problem. Here is a debdiff that does that.

Robert Ancell (robert-ancell) wrote :

Confirmed fix, thanks Anders!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.25.90-0ubuntu3

---------------
vte (1:0.25.90-0ubuntu3) maverick; urgency=low

  [ Anders Kaseorg ]
  * debian/patches/fix-alt-modifier.patch:
    - Revert upstream commit b73782a, which broke the Alt modifier.
      (LP: #619754)
 -- Robert Ancell <email address hidden> Thu, 19 Aug 2010 12:49:37 +1000

Changed in vte (Ubuntu):
status: Triaged → Fix Released
Changed in vte:
status: Unknown → Fix Released
Anmar Oueja (anmar) wrote :

works for me too

tags: added: patch
Changed in vte:
status: Fix Released → Confirmed
Changed in vte:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

this was fixed properly in the upstream bug now, could we get an update with that patch? thanks.

Anders Kaseorg (andersk) wrote :

Yeah, here. I tested it in my PPA.

Changed in vte:
importance: Unknown → Wishlist
fbraun (fbraun) wrote :

Still affected in upstream :(
Too bad it didn't make it into maverick. Any chance of going for upstream soon?

Kevin Otte (nivex) wrote :

I've had to use Konsole to continue using Alt keys, which I use heavily in irssi. Upgrading to Natty is not really a consideration at this time. Will there be a fix for this pushed to Maverick? If not, does someone have a PPA with the fixed package?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.