gdebi don´t work - invalid file descriptor

Bug #438266 reported by aloctavodia on 2009-09-28
188
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Fix Released
Medium
vte (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gdebi

I double click on the package in order to install it; gdebi starts, ask for the password, install all the required dependencies, try to install the package and then stops. It gives a message similar to "dpkg invalid file descriptor".
I can install the packages using "dpkg -i package.deb"

ProblemType: Bug
Architecture: amd64
Date: Mon Sep 28 12:54:04 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gdebi-gtk
InterpreterPath: /usr/bin/python2.6
Package: gdebi 0.5.9
PackageArchitecture: all
ProcEnviron:
 LANG=es_AR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: gdebi
Uname: Linux 2.6.31-11-generic x86_64

aloctavodia (aloctavodia) wrote :
Yunkwan (chanyunkwan0217) wrote :

I have a very similar issue. I double clicked the deb package, and clicked install. I entered the correct password to give it root privilege.
1. If all the dependencies are satisfied, it will fail to install the package.
     It says : "dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor"
2. If the dependencies are not satisfied, it will help you automatically install the required packages. (Here works correctly), but after installing the required packages, Gdebi still can't install this deb package.

I can install the packages by using "dpkg -i package.deb"

Karmic 9.10 (updated to the latest) 32-bit version
Kernel: Linux 2.6.31-11-generic
Gdebi version: 0.5.9

Michael Vogt (mvo) on 2009-09-29
Changed in gdebi (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-9.10
affects: gdebi (Ubuntu) → vte (Ubuntu)
Michael Vogt (mvo) wrote :

This is fixed, but its not accepted for beta so it will go in right after beta

Changed in vte (Ubuntu):
status: Triaged → In Progress
Dylan Taylor (dylanmtaylor) wrote :

The upstream bug tracker says that the issue is fixed.

Changed in vte (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Dylan Taylor (dylanmtaylor) wrote :

Should be fix released. Not yet applied in Karmic.

Michael Rooney (mrooney) wrote :

If the fix is committed upstream, then that is the appropriate status for the upstream task, not Ubuntu, as per https://wiki.ubuntu.com/Bugs/Status . I will mark this as Triaged against the upstream task, which should be updating automatically but perhaps is not.

Changed in vte (Ubuntu):
status: Fix Released → Triaged
Anders Kaseorg (andersk) wrote :

Never mark a bug’s Ubuntu task as “Fix Released” unless the fix is actually in Ubuntu. That might cause the Ubuntu maintainer to forget that they still need to upload the fix!

When the fix is uploaded to Ubuntu, that will cause this bug to automatically be marked “Fix Released”.

(The upstream status—next to “Gnome Virtual Terminal Emulator”, not “vte (Ubuntu)”—is maintained separately by a bot that fetches the status from the upstream bug tracker. It is currently “Unknown” because the bot has not yet processed this bug.)

Changed in vte (Ubuntu):
status: Triaged → In Progress
aloctavodia (aloctavodia) wrote :

thank you everybody!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.22.2-0ubuntu2

---------------
vte (1:0.22.2-0ubuntu2) karmic; urgency=low

  * debian/patches/10_fix_pyenv.patch:
    - fix environment passing in python to fork_command(), see
      https://bugzilla.gnome.org/show_bug.cgi?id=587894
    - This fixes gdebi-gtk and it can install packages again
      (LP: #438266)

 -- Michael Vogt <email address hidden> Tue, 29 Sep 2009 10:29:11 +0200

Changed in vte (Ubuntu):
status: In Progress → Fix Released
gnufreex (gnufreex) wrote :

That package should be included in Karmic Beta, right? Well I just did a clean install of Beta, and I still get "bad filedescriptor" with just about any .deb

So appears it is not fixed.

Juan Manuel (lukather35) wrote :

In Beta already corrected the problem. In a system I did a clean install, and two others, simply download the updates and in all cases this problem no longer exists. I installed Google Chrome and Opera, in the 32 and 64 bits, and I repeat, all right.

neuromancer (neuromancer) wrote :

@mickie.kext
Update your beta installation with last upgraded package and the bug will be resolved. ;)

Victor Mello (victormmello) wrote :

i still having this problem in beta1

Changed in vte (Ubuntu):
status: Fix Released → Confirmed
Anders Kaseorg (andersk) wrote :

As previously mentioned, the fix is not in beta 1. Run the update manager and install all available updates; the problem will go away.

Changed in vte (Ubuntu):
status: Confirmed → Fix Released
John M (jwmwalrus) wrote :

I still get this error, after I use the "sudo" command on files related to APT. I noticed that the behavior of sudo in karmic always defaults to access o-rwx ---and that defeats the purpose of installing system-wide software using sudo, among other things.

*For example, running the following line in the terminal

   sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list --output-document=/etc/apt/sources.list.d/medibuntu.list

causes the medibuntu.list to be saved with access mode 640. If I then run the command "sudo apt-get update", gdebi-gtk cannot be used after that ---and the update-manager complains that it cannot access either /etc/apt/sources.list.d/medibuntu.list or /var/lib/synaptic/preferences.

*Also, the command "sudo update-mime-packages /usr/share/mime" changes the access modes for the mime-types lists, and after that nautilus assigns text/plain to all the files shown.

...$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

...$ uname -srvmo
Linux 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

...$ apt-cache policy gdebi sudo
gdebi:
  Installed: 0.5.9
  Candidate: 0.5.9
  Version table:
 *** 0.5.9 0
        500 http://ubuntu.cs.utah.edu karmic/main Packages
        100 /var/lib/dpkg/status
sudo:
  Installed: 1.7.0-1ubuntu2
  Candidate: 1.7.0-1ubuntu2
  Version table:
 *** 1.7.0-1ubuntu2 0
        500 http://ubuntu.cs.utah.edu karmic/main Packages
        100 /var/lib/dpkg/status

Anders Kaseorg (andersk) wrote :

John M: It sounds like you have a different bug, or perhaps many different bugs. This bug was specifically about the error “invalid file descriptor” from dpkg run in gdebi. Unless that is exactly the problem you are seeing, please report separate bugs against the appropriate package (after checking that they have not been reported already).

John M (jwmwalrus) wrote :

All that happened with a fresh install of the release candidate... So hopefully it's not "many" different bugs.

While trying to install libstdc++5*.deb (which I still need), I got the "invalid file descriptor" dialog; the same thing happened trying to install the deb package of Opera. But it all goes away after I change the file permissions in the /etc/apt and /var/lib/synaptic directories... and it comes back after "sudo apt-get update" (and in general, sudo-related operations seem to screw things up in my machine).

I seem to be the only person having this problem, so I'm not sure to which package it belongs. Thanks.

στις 26/10/2009 12:27 πμ, O/H Anders Kaseorg έγραψε:
> John M: It sounds like you have a different bug, or perhaps many
> different bugs. This bug was specifically about the error “invalid file
> descriptor” from dpkg run in gdebi. Unless that is exactly the problem
> you are seeing, please report separate bugs against the appropriate
> package (after checking that they have not been reported already).
>
>
I reinstalled ubuntu and .deb packages can be installed successfully now

JK (m0d) wrote :

> I reinstalled ubuntu and .deb packages can be installed successfully now

Hey, isn't the "fix-by-reinstalling" method patented by microsoft?

neuromancer (neuromancer) wrote :

Absolutely.
Give credits where credits is due :)

lafleche.jonathan (arrow-69) wrote :

I've had this exact bug resurface in Maverick beta, trying to install Google Chrome 6. gdebi gave the invalid file descriptor error while dpkg -i executed succesfully. Is this a regression or an individual problem with google's .deb file?

Anders Kaseorg (andersk) wrote :

Confirmed. The problem goes away after downgrading to vte 0.24.3-1ubuntu1, and comes back after upgrading to vte 0.25.90-0ubuntu4.

dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

Changed in vte (Ubuntu):
status: Fix Released → Confirmed
Anders Kaseorg (andersk) wrote :

Looks like someone already opened bug 620297 for the new issue.

Changed in vte (Ubuntu):
status: Confirmed → Fix Released
Changed in vte:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.