gnome-terminal crashed with SIGSEGV after hiting ctrl+o

Bug #408745 reported by Grzegorz Sterniczuk on 2009-08-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Fix Released
Critical
vte (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

After hiting ctrl+o gnome-terminal dies.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Tue Aug 4 10:09:42 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.26.3.1-0ubuntu1
ProcCmdline: gnome-terminal
ProcEnviron:
 LANGUAGE=pl_PL.UTF-8
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
SegvAnalysis:
 Segfault happened at: 0xd65a1e: mov %edx,0x4(%esi)
 PC (0x00d65a1e) ok
 source "%edx" ok
 destination "0x4(%esi)" (0x00000004) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-terminal
StacktraceTop:
 ?? () from /usr/lib/libvte.so.9
 ?? () from /usr/lib/libvte.so.9
 ?? () from /usr/lib/libvte.so.9
 ?? () from /usr/lib/libvte.so.9
 ?? () from /usr/lib/libvte.so.9
Title: gnome-terminal crashed with SIGSEGV
Uname: Linux 2.6.31-4-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv plugdev vboxusers video

Grzegorz Sterniczuk (dzikus) wrote :

StacktraceTop:_vte_terminal_cleanup_tab_fragments_at_cursor (
vte_sequence_handler_cursor_character_absolute (
_vte_terminal_handle_sequence (terminal=0x9fc5fe0,
vte_terminal_process_incoming (terminal=0x203001)
time_process_incoming (terminal=0x9fc5fe0)

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Thanks for the report, it looks like a vte issue, will send upstream, thanks for reporting.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Confirmed
affects: gnome-terminal (Ubuntu) → vte (Ubuntu)
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=590824 ; Thanks for reporting.

Changed in vte (Ubuntu):
status: Confirmed → Triaged
summary: - gnome-terminal crashed with SIGSEGV after hiting ctrl+o (save in
- nano!!!)
+ gnome-terminal crashed with SIGSEGV after hiting ctrl+o
visibility: private → public
Changed in vte:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

This has been fixed upstream now, Thanks for reporting.

Changed in vte (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.21.5-0ubuntu1

---------------
vte (1:0.21.5-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #419808)
    - Finish ring rewrite. Scrollback buffer consumes ten times less
      memory now, and better, doesn't allocate from the heap, so closing
      tabs actually releases memory.
    - Remove another stale assert()
    - Oops, use the right map decoding function is iso2022 code
    - Really fix the ring this time
    - Enable g_assert(). May trigger some bogus ones now. Please report.
    - gnome terminal crashes with glibc detected
    - Redesigning the vte buffer ring is going on. Please report any misbehavior
    - gnome-terminal crashed with SIGSEGV after hiting ctrl+o (LP: #408745)
    - text mode program rendering is strange in cjk locale.
    - bashisms in shell scripts
  * Update DEB_DH_MAKESHLIBS_ARGS_ALL in debian/rules
  * debian/patches:
    - remove 01_bashisms.patch: taken upstream
    - refresh 90_autoreconf.patch

 -- Didier Roche <email address hidden> Tue, 22 Sep 2009 10:32:48 +0200

Changed in vte (Ubuntu):
status: Fix Committed → Fix Released
Changed in vte:
importance: Unknown → Critical
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.