Please sponsor vte 0.20.0 (main) into Jaunty

Bug #344049 reported by Pedro Fragoso on 2009-03-17
2
Affects Status Importance Assigned to Milestone
vte (Ubuntu)
Undecided
Michael Vogt

Bug Description

vte (1:0.20.0-0ubuntu1) jaunty; urgency=low

  * New upstream release
    - Support using a real bold font instead of pseudo-bolding
    - Respond to fontconfig configuration changes
    - Bugs fixed in this release:
    - Bug 54926 – Should try bold version of font before
      pseudo-bolding
    - Bug 570208 – vte fails to build outside source tree
    - Bug 548272 – Fix output of CSI 13,14, 18-21 (LP: #208837)
    - Bug 565688 – [gnome-pty-helper] using openpty in a bad way
    - Bug 566795 – VTE fails to build in trunk
    - Bug 524170 – Support initc terminfo capability and
      change-cursor-color
    - Bug 566730 – vte_terminal_set_color_cursor() calls invalidate_all but
      it doesn't have to
    - Bug 565679 – alloca is discouraged
    - Bug 565675 – typo in configure.in cause ncurses checking fail
    - Bug 565663 – compile failure because use static function in another .h
      file
    - Bug 575398 – configure warns about term.h under OpenSolaris
    - Bug 574616 – "real" transparency not working from python bindings
    - Bug 574025 – Crash in _vte_terminal_insert_char
  * debian/patches/92_pangocairo_full_bold_fonts.patch:
    - Dropped, merged upstream
  * debian/patches/90_autoreconf.patch:
    - Refreshed for the new release
  * debian/patches/94_hardcode_gtkdoc_rebase.patch:
    - Temp workaround to prevent FTBFS

Related branches

Changed in vte:
status: New → Confirmed
Michael Vogt (mvo) on 2009-03-17
Changed in vte (Ubuntu):
assignee: nobody → mvo
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :
Download full text (3.3 KiB)

I get the following error during build:

...
Making install in doc
make[2]: Entering directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc'
Making install in reference
make[3]: Entering directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc/reference'
make[4]: Entering directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc/reference'
make[4]: Nothing to be done for `install-exec-am'.
installfiles=`echo /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/*`; \
 if test "$installfiles" = '/home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/*'; \
 then echo '-- Nothing to install' ; \
 else \
   if test -n ""; then \
     installdir="/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/tmp/main/usr/share/gtk-doc/html/vte-"; \
   else \
     installdir="/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/tmp/main/usr/share/gtk-doc/html/vte"; \
   fi; \
   /bin/sh /home/egon/warthogs/vte/build-area/vte-0.20.0/./mkinstalldirs ${installdir} ; \
   for i in $installfiles; do \
     echo '-- Installing '$i ; \
     /usr/bin/install -c -m 644 $i ${installdir}; \
   done; \
   if test -n ""; then \
     mv -f ${installdir}/vte.devhelp2 \
       ${installdir}/vte-.devhelp2; \
     mv -f ${installdir}/vte.devhelp \
       ${installdir}/vte-.devhelp; \
   fi; \
    --relative --dest-dir=/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/tmp/main --html-dir=${installdir}; \
 fi
mkdir -p -- /home/egon/warthogs/vte/build-area/vte-0.20.0/debian/tmp/main/usr/share/gtk-doc/html/vte
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/ch01.html
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/home.png
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/index.html
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/index.sgml
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/left.png
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/right.png
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/style.css
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/up.png
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/vte.devhelp
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/vte.devhelp2
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/VteTerminalAccessible.html
-- Installing /home/egon/warthogs/vte/build-area/vte-0.20.0/./doc/reference/html/VteTerminal.html
/bin/sh: line 20: --relative: command not found
make[4]: *** [install-data-local] Error 127
make[4]: Leaving directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc/reference'
make[3]: *** [install-am] Error 2
make[3]: Leaving directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc/reference'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/home/egon/warthogs/vte/build-area/vte-0.20.0/debian/build/main/doc'
make[1]: **...

Read more...

Changed in vte (Ubuntu):
status: In Progress → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.20.0-0ubuntu1

---------------
vte (1:0.20.0-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #344049)
    - Support using a real bold font instead of pseudo-bolding
    - Respond to fontconfig configuration changes
    - Bugs fixed in this release:
    - Bug 54926 – Should try bold version of font before
      pseudo-bolding
    - Bug 570208 – vte fails to build outside source tree
    - Bug 548272 – Fix output of CSI 13,14, 18-21 (LP: #208837)
    - Bug 565688 – [gnome-pty-helper] using openpty in a bad way
    - Bug 566795 – VTE fails to build in trunk
    - Bug 524170 – Support initc terminfo capability and
      change-cursor-color
    - Bug 566730 – vte_terminal_set_color_cursor() calls invalidate_all but
      it doesn't have to
    - Bug 565679 – alloca is discouraged
    - Bug 565675 – typo in configure.in cause ncurses checking fail
    - Bug 565663 – compile failure because use static function in another .h
      file
    - Bug 575398 – configure warns about term.h under OpenSolaris
    - Bug 574616 – "real" transparency not working from python bindings
    - Bug 574025 – Crash in _vte_terminal_insert_char
  * debian/patches/92_pangocairo_full_bold_fonts.patch:
    - Dropped, merged upstream
  * debian/patches/90_autoreconf.patch:
    - Refreshed for the new release
  * debian/patches/94_hardcode_gtkdoc_rebase.patch:
    - Temp workaround to prevent FTBFS

 -- Pedro Fragoso <email address hidden> Mon, 16 Mar 2009 15:21:59 +0000

Changed in vte:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers