"Esc [ 1 8 t" Response doesn't match xterm.

Bug #208837 reported by Ralph Corderoy on 2008-03-29
2
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Fix Released
Medium
vte (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Ubuntu 7.10. The escape sequence "Esc [ 1 8 t" is meant to make the terminal reply with the height and width of the current window characters. It's handled in vte-0.16.9/src/vteseq.c, line 3865. The output on gnome-terminal is different to the xterm from xterm-229-1.

Here's the correct, xterm, behaviour.

    $ echo -n '^[[18t'; sleep 1; echo
    ^[[8;24;80t
    $

And the gnome-terminal:

    $ echo -n '^[[18t' ; sleep 1; echo
    ^[[24;80t
    $

There should be an "8;" before the height of 24. This in theory allows the string to be echoed back to the terminal to restore this size in the future.

As well as xterm providing different behaviour, I've found various references on the Internet, e.g. http://invisible-island.net/xterm/ctlseqs/ctlseqs.html, which also suggest vte is wrong.

Related branches

Sufficient detail provided that it can go straight to confirmed. Hope that's OK.

Changed in vte:
status: New → Confirmed

There are other similar faults where the response is incorrect in that same function.

    ^[[13t response should be ^[[3;x;yt but is ^[[x;yt.
    ^[[14t response should be ^[[4;h;wt but is ^[[h;wt.
    ^[[19t response should be ^[[9;h;wt but is ^[[h;wt.

On a similar note, although ^[[20t is handled correctly in responding with the icon's label, the response to ^[[21t also outputs an `L' when it should be using a lowercase `l'. The above URL and xterm confirm lowercase `l' for 21 is the correct behaviour.

Pedro Villavicencio (pedro) wrote :

please don't confirm your own reports.

Changed in vte:
status: Confirmed → New
Pedro Villavicencio (pedro) wrote :

thansk for the report, with the examples you provided in your description what i get in intrepid with xterm and vte is: ^[[18t ; are you still seeing this with intrepid? vte changed a lot during the 2.23 cycle, can you test with it and report back? thanks in advance.

Changed in vte:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

Hi Pedro, sorry, I wasn't clear. The ^[ seen in the single quotes in my
examples is a literal escape character typed as `Ctrl-V Escape'. If
xterm is giving `^[[18t' back then that suggests a circumflex and open
bracket have been given. Try

    echo -n '@[18t' | tr @ \\033; sleep 1; echo

instead which can be cut-and-pasted. This uses tr(1) to turn the `@'
into an ASCII ESC.

Pedro Villavicencio (pedro) wrote :

Ok now I've got it with intrepid also, thanks for the last example. I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=548272 ; thanks in advance.

Changed in vte:
status: Incomplete → Triaged
Changed in vte:
status: Unknown → New
Changed in vte:
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

this as been fixed upstream, thanks for reporting.

Changed in vte:
status: Triaged → Fix Committed
Changed in vte:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.20.0-0ubuntu1

---------------
vte (1:0.20.0-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #344049)
    - Support using a real bold font instead of pseudo-bolding
    - Respond to fontconfig configuration changes
    - Bugs fixed in this release:
    - Bug 54926 – Should try bold version of font before
      pseudo-bolding
    - Bug 570208 – vte fails to build outside source tree
    - Bug 548272 – Fix output of CSI 13,14, 18-21 (LP: #208837)
    - Bug 565688 – [gnome-pty-helper] using openpty in a bad way
    - Bug 566795 – VTE fails to build in trunk
    - Bug 524170 – Support initc terminfo capability and
      change-cursor-color
    - Bug 566730 – vte_terminal_set_color_cursor() calls invalidate_all but
      it doesn't have to
    - Bug 565679 – alloca is discouraged
    - Bug 565675 – typo in configure.in cause ncurses checking fail
    - Bug 565663 – compile failure because use static function in another .h
      file
    - Bug 575398 – configure warns about term.h under OpenSolaris
    - Bug 574616 – "real" transparency not working from python bindings
    - Bug 574025 – Crash in _vte_terminal_insert_char
  * debian/patches/92_pangocairo_full_bold_fonts.patch:
    - Dropped, merged upstream
  * debian/patches/90_autoreconf.patch:
    - Refreshed for the new release
  * debian/patches/94_hardcode_gtkdoc_rebase.patch:
    - Temp workaround to prevent FTBFS

 -- Pedro Fragoso <email address hidden> Mon, 16 Mar 2009 15:21:59 +0000

Changed in vte:
status: Fix Committed → Fix Released
Changed in vte:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.