Please replace current alternate screen scroll patch with the new one, making this scroll permanent

Bug #1340687 reported by Vlad Orlov on 2014-07-11
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
vte (Ubuntu)
High
Unassigned

Bug Description

Dear maintainers,

Please remove 93_add_alt_screen_scroll_toggle.patch and replace it with the new patch from the attachment.

This patch adds support for DEC 1007 escape sequence, thus making the alternate screen scroll work always. After applying it, the corresponding patches with the calls to vte_terminal_set_alternate_screen_scroll function can be safely dropped from the terminal applications using GTK2-based vte (e.g. xfce4-terminal).

The patch has been adapted from the upstream commit in VTE3 [1].

[1] https://git.gnome.org/browse/vte/commit/?id=9f8c1b88dcd880c2d9e78c93521ee755560a9275

Vlad Orlov (monsta) wrote :
summary: - Please peplace current alternate screen scroll patch with the new one,
+ Please replace current alternate screen scroll patch with the new one,
making this scroll permanent
Vlad Orlov (monsta) on 2014-07-11
description: updated
description: updated

The attachment "This patch adds support for DEC 1007 to set the alternate screen scroll mode. Adapted from the corresponding VTE3 commit." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Vlad Orlov (monsta) wrote :

Additional note: the patched vte has been tested in mate-terminal, roxterm-gtk2, lxterminal. Alternate screen scroll is now working in all these apps.

Vlad Orlov (monsta) wrote :

Any progress on this?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vte (Ubuntu):
status: New → Confirmed
Changed in vte:
importance: Unknown → Medium
status: Unknown → New
no longer affects: vte
Vlad Orlov (monsta) on 2015-02-15
tags: added: trusty utopic vivid
Changed in vte (Ubuntu):
importance: Undecided → High
Vlad Orlov (monsta) on 2015-06-04
tags: added: precise
Vlad Orlov (monsta) wrote :
Vlad Orlov (monsta) wrote :
Vlad Orlov (monsta) wrote :
Vlad Orlov (monsta) wrote :
Vlad Orlov (monsta) wrote :

[Impact]

The current alternate scroll patch is flawed because the terminal apps using GTK+2 version of VTE library should also be patched in order for the alternate scroll to work. This means that mate-terminal, roxterm-gtk2, lxterminal (and other terminal apps that aren't patched in all Ubuntu releases) don't have the alternate scroll enabled.

The proposed new patch that's contained in the debdiffs makes alternate scroll work always, so no patching will be required for any terminal apps.

So, the old patch should be replaced with the new one in all current stable releases of Ubuntu.

[Test Case]

Steps to reproduce:
1. Run mate-terminal or any other non-patched terminal app using GTK+2 version of VTE library.
2. Run "man apt-get" (any other manpage will work too of course).
3. See that scrolling with mouse wheel doesn't work on the manpage.

[Regression Potential]

After almost a year of testing the patch in various stable releases of Ubuntu, I found no regressions.
I consider the regression risk to be very low here.

Vlad Orlov (monsta) on 2015-06-08
tags: added: wily
Oliver Joos (oliver-joos) wrote :

I confirm that this patch works in Ubuntu 14.04 LTS and in in Mint 17 MATE.

I follow this bug since more than 2 years. A big thank you to Monsta and everybody involved in a final fix!

This bugs hall of fame:
https://github.com/mate-desktop/mate-terminal/issues/2
https://bugzilla.gnome.org/show_bug.cgi?id=709060
https://launchpad.net/bugs/1337195
https://launchpad.net/bugs/947892
https://launchpad.net/bugs/358796

Martin Pitt (pitti) wrote :

This doesn't look like SRU material, especially if that needs corresponding changes in other applications (drop patches in them for the old patch in vte). But I uploaded this to wily now, thanks!

Changed in vte (Ubuntu):
status: Confirmed → Fix Committed
Vlad Orlov (monsta) wrote :

Hi Martin,

This patch does not require changes in other applications. You can leave all GTK+2 terminal apps as is - they will still work as they should even with their corresponding alt.scroll patches enabled. This patch only enables alt.scroll in the temrinal apps that haven't been patched yet, that's all.

Actually, the only GTK+2 terminal app that is patched is xfce4-terminal. Other apps like mate-terminal, roxterm-gtk2, lxterminal are not patched.

Is there something else needed for SRU here? Let me know, I'll make corrections.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.28.2-5ubuntu2

---------------
vte (1:0.28.2-5ubuntu2) wily; urgency=medium

  * debian/patches/93_add_alt_screen_scroll_toggle.patch:
    Dropped, it only worked when vte-based terminal apps were also
    patched.
  * debian/patches/permanent-altscreen-scroll.patch:
    New patch. Makes the alternate screen scroll work always, thus
    removing the need to additionally patch vte-based terminal apps.
    (LP: #1340687)

 -- Vlad Orlov <email address hidden> Thu, 04 Jun 2015 15:53:18 +0300

Changed in vte (Ubuntu):
status: Fix Committed → Fix Released
Vlad Orlov (monsta) on 2015-06-27
tags: removed: wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.