Xorg 100% CPU during scrolling gnome-terminal

Bug #125396 reported by Bob Joneson on 2007-07-12
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
vte (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Fiesty x86 on IBM Thinkcentre (P4 2.8 / 1GB RAM)

Running Xinerama dual head
Screen 1-> Intel 82865G (i810 driver)
Screen 2-> Rendition Verite (rendition driver)
Both screens @ 1280x1024

To reproduce:

1) Open a gnome-terminal (Full Screen)
2) Run a command with rapid multi-lined output (i.e. an scp of several thousand very small files)
3) Check top - Xorg running at near 100% CPU

The size of the window is directly proportional to CPU utilization (shrinking it down, reduces the impact). Minimizing has no effect.

unggnu (unggnu) wrote :

Could you please recheck it with Gutsy Final Live CD? In Gutsy i810 driver is deprecated and intel driver is used instead.
Xinerama doesn't work anymore with new Intel driver since xrandr is used instead.

Changed in xorg:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

No reply, closing the bug.

Changed in xserver-xorg-video-i810:
status: Incomplete → Invalid
Daniel van Vugt (vanvugt) wrote :

Confirmed using Ubuntu 8.04 desktop i386 and the intel Xorg driver.

Changed in xserver-xorg-video-intel:
status: Invalid → Confirmed
Bryce Harrington (bryce) wrote :

Daniel, simply confirming the symptom when using -intel is insufficient for troubleshooting this. You must attach your Xorg.0.log and xorg.conf when reporting X bugs. You must also indicate what steps you used to reproduce the issue - for instance, were you also trying to use Xinerama, and the rendition driver? Were you using compiz or not? Is your hardware identical to the original reporter (an IBM Thinkcenter)? If not, you must indicate what your hardware is as well. etc. See http://wiki.ubuntu.com/X/Reporting for directions on how to report X bugs.

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Unfortunately I have since got rid of that hardware. However even with my new hardware (Nvidia NVS290), the issue is trivial to reproduce; with and without compiz. Compile the below C program and watch the CPU usage of Xorg. It's totally unacceptable to anyone with programming and graphics knowledge...

#include <stdio.h>
#define LINES_PER_SEC 100
int
main(int argc, char *argv[])
{
        int n;
        for (n=0; n < 10000; n++)
        {
                usleep(1000000/LINES_PER_SEC);
                printf("Hello world %d\n", n);
        }
        return 0;
}

Changed in xserver-xorg-video-intel:
status: Invalid → New
Daniel van Vugt (vanvugt) wrote :

Changed component to Xorg since this bottleneck is obviously not just intel. I haven't attached any other details because I now believe the resolver has ample information to reproduce the issue.

Timo Aaltonen (tjaalton) wrote :

sounds more like a problem in the vte engine gnome-terminal uses.

Pedro Villavicencio (pedro) wrote :

May someone having hte issue forward this upstream to bugzilla.gnome.org? for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until that, thanks.

Changed in vte:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

any news about this?

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty? the bug should be sent to bugzilla.gnome.org by somebody having the issue

Dan Quade (danquade) wrote :

Confirming for Jaunty. Scrolling is still horribly CPU intensive (in ALL apps, not just gnome-terminal).

Thank you for taking the time to report this bug and helping to make Ubuntu better. I noticed that the package version your bugging is updated in Maverick. Please update via www.ubuntu.com repost a detailed error report, and update the bug status. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers