vnc4server fails to start; Xvnc4 no longer recognizes -extension argument

Bug #556147 reported by Steve Beattie on 2010-04-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vnc4 (Ubuntu)
High
Unassigned

Bug Description

Trying to start vnc4server via "vnc4server -geometry 1400x990 :1" fails always; the .vnc/$HOST:1.log leads off with

  Unrecognized option: -extension

Doing an strace on the vnc4server binary shows that it's trying to execute Xvnc4 like so:

  Xvnc4 :1 -desktop "denisovich:1 (steve)" -auth /home/steve/.Xauthority -geometry "1400x990" -depth 16 -rfbwait 30000 -rfbauth /home/steve/.vnc/passwd -rfbport 5901 -pn -extension XFIXES -fp "/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,/usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/" -co /etc/X11/rgb

but that Xvnc4 no longer recognizes the -extension argument. This was working with vnc4 4.1.1+xorg1.0.2-0ubuntu7 in lucid.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: vnc4server 4.1.1+xorg4.3.0-37ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-server 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-server x86_64
Architecture: amd64
Date: Mon Apr 5 17:43:02 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=bash
SourcePackage: vnc4

Related branches

Steve Beattie (sbeattie) wrote :
Steve Beattie (sbeattie) wrote :

Backing out the change in http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/lucid/vnc4/lucid/revision/12, the only remaining (code) dependency fixes it so that Xvnc4 will start. And it is capable of launching a full gnome-session, as that's what I have my .vnc/xstartup configured to do.

Eduard Iten (eiten) wrote :

The fix is rather easy: just replace
$cmd .= " -extension XFIXES";
by
#$cmd .= " -extension XFIXES";
around line 263 in /usr/bin/vnc4server

Steve Beattie (sbeattie) wrote :

Eduard: yes, that's what the patch in the attached bzr branch does. It's also available in package form from my ppa at https://launchpad.net/~sbeattie/+archive/ppa/ . It causes vnc to start; however, the vnc server is acting like the Super key is pressed all the time, which is making it less useful.

Changed in vnc4 (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Eduard Iten (eiten) wrote :

Steve: oh, thanks.
True, I can confirm that the SUPER key is always pressed. On my lucid test system, I was only viewing so I did not recognize.

Dave Walker (davewalker) wrote :

@Eduard & @sbeattie: Can you try changing the line from:
$cmd .= " -extension XFIXES";

to the following combinations, and see if one of them resolves the issue. It would be good to get this fixes prior to the next upload:
$cmd .= " -clear_keys";
$cmd .= " -repeat";
$cmd .= " -repeat -clear_keys";

Thanks

Eduard Iten (eiten) wrote :

@Dave
Both of these options are unknown to my Vnc4 version ( 4.1.1+xorg4.3.0-37ubuntu1). Both result in an unknown option error when trying to launch via vnc4server.
Regards, Edi

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vnc4 - 4.1.1+xorg4.3.0-37ubuntu2

---------------
vnc4 (4.1.1+xorg4.3.0-37ubuntu2) lucid; urgency=low

  * unix/vncserver: revert "-extension XFIXES" as it is no longer
    needed (LP: #556147)
  * Remaining Ubuntu changes:
    - None
 -- Steve Beattie <email address hidden> Mon, 05 Apr 2010 18:31:57 -0700

Changed in vnc4 (Ubuntu):
status: Fix Committed → Fix Released
Julien Antille (xxenon2) wrote :

I confirm the "Super key" being like always pressed.
Should I open a new bug ?

On Fri, Apr 23, 2010 at 05:50:10PM -0000, Julien Antille wrote:
> I confirm the "Super key" being like always pressed.
> Should I open a new bug ?

Yes, please do (and report back here). Thanks.

--
Steve Beattie
<email address hidden>
http://NxNW.org/~steve/

Steve Beattie (sbeattie) wrote :

Ah, it turns out the Super key issue ended up being bug 568401, which was an issue in the indicator-applet itself. Fortunately, this was addressed in a Stable Release Update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers