FTBFS in latest archive rebuild test

Bug #184225 reported by Adam Conrad
6
Affects Status Importance Assigned to Milestone
vnc4 (Debian)
Fix Released
Unknown
vnc4 (Gentoo Linux)
Fix Released
Medium
vnc4 (Ubuntu)
High
Unassigned
Hardy
High
Unassigned

Bug Description

This package failed to build from source in a recent archive rebuild
test. The logs for the rebuild test can be found at:

https://lists.ubuntu.com/archives/ubuntu-autotest/2007-December/thread.html

Related branches

Revision history for this message
In , jcat (jcat-l-deactivatedaccount) wrote :

When performing an emerge update, net-misc/vnc-4.1.2-r4 pulls in xorg-server-1.3.0.0, and hence tries to downgrade xorg-server from 1.4-r1. net-misc/vnc-4.1.2-r4 works fine with xorg-server-1.4-r1, so can we get the ebuild updated please?

Cheers,
jcat

Reproducible: Always

Revision history for this message
In , Raúl Porcel (armin76) wrote :

Does the vnc module work fine with xorg-server-1.4?

Revision history for this message
In , jcat (jcat-l-deactivatedaccount) wrote :

Ah. Do you mean the actual vnc module for "real" xorg vt diplay?

Revision history for this message
In , Raúl Porcel (armin76) wrote :

Yeah. vnc fails to build with xorg-1.4 sources, so that's why there's no ebuild yet.

Use a modified ebuild in your local overlay removing the xorg dep :)

Revision history for this message
In , jcat (jcat-l-deactivatedaccount) wrote :

Oops. I emerge vnc after xorg-server using a package for speed :p

So, confirmed here, vnc dosen't actually build with xorg-server-1.4-r1 :)

Shall I change th bug status to resolved or leave it pending a new version of vnc that works with xorg-server-1.4?

Revision history for this message
In , Lavajoe (lavajoe) wrote :

I tried patching to enable for xorg 1.4, but I get a failed patch:

 * Failed Patch: 17_all_vnc-server-modular-xorg.patch !
 * (/var/tmp/portage/net-misc/vnc-4.1.2-r5/work/patch/17_all_vnc-server-modular-xorg.patch)

Revision history for this message
In , 9-jakub-3 (9-jakub-3) wrote :

*** Bug 193198 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

http://forums.gentoo.org/viewtopic-t-585806.html

Check out this link. It resolves the issue. and ues VNC works with the newer version of Xorg with no problem. Running it now.

Sorry about the duplicate bug report.

Revision history for this message
In , Fmccor (fmccor) wrote :

*** Bug 193199 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Lavajoe (lavajoe) wrote :

How did you get the r4 patch set to correctly patch the xorg-server part? The xorg-server code has changed enough that the patches (specifically 17, 21, and 29) fail. I am working on fixing them now. But I do not see how anyone could get it to work without fixing these.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

Joe,

If you look at the posted at http://forums.gentoo.org/viewtopic-t-585806.html

You will see how I did the work around for the ebuild but you have to edit the ebuild for VNC every time you do a sync.

This worked for me with no problem as the ebuild for vnc was looking for xorg 1.3.0.0 to be installed, if it was not installed then it would want to merge this package. I edited the ebuild and changed the 1.3.0.0 to 1.4 and resolved the issue.

Revision history for this message
In , Lavajoe (lavajoe) wrote :

Hi David,

I did the same (1.3.0.0 -> 1.4), but then it crashed during patching. Do you have the "server" USE flag set? If not, this could explain why it is working for you, since the problem only occurs during the server patches.

Revision history for this message
In , Raúl Porcel (armin76) wrote :

(In reply to comment #11)
> Hi David,
>
> I did the same (1.3.0.0 -> 1.4), but then it crashed during patching. Do you
> have the "server" USE flag set? If not, this could explain why it is working
> for you, since the problem only occurs during the server patches.
>

Because what he fixed is the need of downgrading, but not the patch failure. If you remove the depend line of xorg-server, you'll get the same fix.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

well I did the following and it seemed to work for me.

USE=server emerge vnc

That worked for me with no problem.

This is a fresh build though with the 2007.0 cd. I have not had any issues on the 2006.x cd as that box is running with no problems, It preforms a sync and an emerge -uDv world every night. Both boxes do this.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

just so you know. I also had xorg 1.4 installed when I merge VNC with the use=server flag set.

Revision history for this message
In , Lavajoe (lavajoe) wrote :

Hmm, curious.

Also, do you have pixman installed? If so, where is pixman.h? Mine is in /usr/include/pixman-1/pixman.h. I had to make a new patch to correct the #includes in xorg-x11-server-sources (the 1.4 version). Testing now.

I really don't see how you got past the patching issue (and also the pixman.h thing).

And Raúl, why would it be "OK" to remove the dependency on xorg-server?

Revision history for this message
In , Raúl Porcel (armin76) wrote :

(In reply to comment #15)
>
> And Raúl, why would it be "OK" to remove the dependency on xorg-server?
>

It wouldn't be okay. I'm just saying that if someone isn't using the xorg module, and wants to use vnc and not having any dep issue, he can copy the ebuild into his local overlay and remove the depend line.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

looks like it is installed. Here is the list and locations.
hope it helps you out.

/usr/share/doc/pixman-0.9.5
/usr/lib/libpixman-1.so.0
/usr/lib/libpixman-1.la
/usr/lib/libpixman-1.a
/usr/lib/libpixman-1.so
/usr/lib/libpixman-1.so.0.9.5
/usr/lib/pkgconfig/pixman-1.pc
/usr/include/pixman-1
/usr/include/pixman-1/pixman.h

Revision history for this message
In , Lavajoe (lavajoe) wrote :

David, still not sure how you were able to build with USE=server. Did the vncserver work OK?

In any case, after spending too many hours trying to patch the patches to work with xorg 1.4, I got into some knarly compile issues that indicate to me that this is too much of a hackish path to follow. Raul, is a newer patch set available?

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

I honestly think it does. I used xrdp which requires the vnc server. I used windows remote desktop to connect to my xorg gui, so i am guessing it works with no problem.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

do you all think you can at least patch the ebuild for vnc to reference xorg 1.4?

Revision history for this message
In , Lavajoe (lavajoe) wrote :

David, before just changing it to 1.4, I really think we need to get to the bottom of why you can build the server, but Raul and I cannot. I can build without the server USE flag, and it does indeed work, so it would be worthwhile getting it working on xorg-1.4 for that, but even better would be to get the patch set updated so the whole things works.

Raul, what is your opinion? I personally found it to be incredibly non-trivial to get the old patches re-worked. I got them so the patches succeeded, but then I started down a path of various compile problems that required even more patching, to the extent that I started to feel uncomfortable. For example, some of the calls in the 1.3 server code are now gone (like miRegisterPointerDevice()), and I was starting to have to guess at how to use the calls in a new way...

But David, I still really do not understand how you could have gotten server to compile. This is a really strange mystery.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

What would you like from me that may give you some insight on how I got it to work with no problem. like I said this is from the latest cd build of 2007.0

Revision history for this message
In , Lavajoe (lavajoe) wrote :

Can you check you vnc log and look for this: "Underlying X server release 70200000, The X.Org Foundation" - see what version you see...

Also, verify that the only change you made to the ebuild is the XSERVER_VERSION="1.3.0.0" line, right?

It should then pick up xorg-server-${XSERVER_VERSION}.tar.bz2, and this is the code that the vnc-4.1.2-r4-patches-0.1 file will try to patch. These two seem incompatible entirely... See if, while emerging, you see these exact files being unpacked, etc.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

Vnc log information:

Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10300000, The X.Org Foundation

As far as the modification to the ebuild yes that was the only change I made.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

Created attachment 132122
emerge log

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

Created attachment 132128
the emerge information for vnc with the use=server

Here is the info you requested for the emerge info.

Revision history for this message
In , Lavajoe (lavajoe) wrote :

(In reply to comment #26)
> Created an attachment (id=132128) [edit]
> the emerge information for vnc with the use=server
>
> Here is the info you requested for the emerge info.

David, you are not building the server. If you look in your log, it's getting USE="-server", and there is a message telling you to change your USE flags if you need the server. Try: USE="server" emerge -1av vnc

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :
Download full text (5.4 KiB)

okay.. for the first time I get the following now. However when I first did it I had to do the USE="server emerge vnc in order to get my xrdp package to install because xrdp requires vnc with the use=server option. So not sure what gives now.

WILCNF40310Q1 ~ # USE="server" emerge -Dv vnc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] net-misc/vnc-4.1.2-r4 USE="server*" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) net-misc/vnc-4.1.2-r4 to /
 * vnc-4.1.2-r4-patches-0.1.tar.bz2 MD5 ;-) ... [ ok ]
 * vnc-4.1.2-r4-patches-0.1.tar.bz2 RMD160 ;-) ... [ ok ]
 * vnc-4.1.2-r4-patches-0.1.tar.bz2 SHA1 ;-) ... [ ok ]
 * vnc-4.1.2-r4-patches-0.1.tar.bz2 SHA256 ;-) ... [ ok ]
 * vnc-4.1.2-r4-patches-0.1.tar.bz2 size ;-) ... [ ok ]
 * xorg-server-1.4.tar.bz2 MD5 ;-) ... [ ok ]
 * xorg-server-1.4.tar.bz2 RMD160 ;-) ... [ ok ]
 * xorg-server-1.4.tar.bz2 SHA1 ;-) ... [ ok ]
 * xorg-server-1.4.tar.bz2 SHA256 ;-) ... [ ok ]
 * xorg-server-1.4.tar.bz2 size ;-) ... [ ok ]
 * vnc-4_1_2-unixsrc.tar.gz MD5 ;-) ... [ ok ]
 * vnc-4_1_2-unixsrc.tar.gz RMD160 ;-) ... [ ok ]
 * vnc-4_1_2-unixsrc.tar.gz SHA1 ;-) ... [ ok ]
 * vnc-4_1_2-unixsrc.tar.gz SHA256 ;-) ... [ ok ]
 * vnc-4_1_2-unixsrc.tar.gz size ;-) ... [ ok ]
 * checking ebuild checksums ;-) ... [ ok ]
 * checking auxfile checksums ;-) ... [ ok ]
 * checking miscfile checksums ;-) ... [ ok ]
 * checking vnc-4_1_2-unixsrc.tar.gz ;-) ... [ ok ]
 * checking vnc-4.1.2-r4-patches-0.1.tar.bz2 ;-) ... [ ok ]
 * checking xorg-server-1.4.tar.bz2 ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking vnc-4_1_2-unixsrc.tar.gz to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
>>> Unpacking vnc-4.1.2-r4-patches-0.1.tar.bz2 to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
>>> Unpacking xorg-server-1.4.tar.bz2 to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
 * Applying various patches (bugfixes/updates) ...
 * 01_all_vnc-cookie.patch ... [ ok ]
 * 03_all_vnc-gcc4.patch ... [ ok ]
 * 05_all_vnc-use-fb.patch ... [ ok ]
 * 07_all_vnc-xclients.patch ... [ ok ]
 * 09_all_vnc-idle.patch ... [ ok ]
 * 11_all_vnc-via.patch ... [ ok ]
 * 13_all_vnc-restart.patch ... [ ok ]
 * 15...

Read more...

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

I think I figured out what happend... When doing the fresh install I think I did infact install vnc with xorg 1.3.0.0 after it was done I preformed the emerge -uDv world and got the errors about the Xorg server version. Modified the ebuild to reference xorg 1.4 and it went on is merry way..

if vnc is installed before the ugprade to 1.4 then it is all fine and dandy for the world updates but when trying to install vnc for the frist time or after is when it gives the errors.. I will keep working on it when I can and let you all know what I come up with.

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

just checked on realvnc.com and there is a newer version of vnc 4.3. can someone check and see if they can get this to work ?

Revision history for this message
In , Nuitari (nuitari) wrote :

VNC Free Edition is only at 4.1.2

Revision history for this message
In , Eric-bosch (eric-bosch) wrote :

I have done some work on updating the patchset for xorg-server-1.4, and got everything to work up to the point of applying patch 44_all_vnc-server-autotools.patch, where it is trying to patch unix/xorg-x11-server-source/hw/vnc/Makefile.am, which is missing. Did I miss something in one of the previous patches?

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

Well after running in to the problem now with the box I been trying to update. came up with this work around and it seems to work but it is really yucky fix in my book.

first you have to mask the following packages and if they are installed uninstall them.

# =x11-base/xorg-server-1.4-r1
# =x11-drivers/xf86-video-mga-1.4.7
# =x11-proto/renderproto-0.9.3
# =x11-libs/libXrender-0.9.4

Then do the emerge vnc with the use=server. once that is done then update world and it will want do its thing. remove the blocked packages. Then do update world again. That was the yucky part, then you need to edit the vnc ebuild and change it from 1.3.0.0 to 1.4 and emerge world again and it should go though. This is a yucky work around but it works for now.

kinda sad that you have to downgrade to 1.3.0.0 then install vnc with the use=server option then do the updates then edit the ebuild, then do the updates some more. just a yucky work around.

Revision history for this message
In , Patrizio Bassi (patrizio-bassi) wrote :

no more updates on this issue? emerge continues tries to go up and down on xorg versions...

Revision history for this message
In , 0cooz (0cooz) wrote :

a month and a week later...

Revision history for this message
In , Nightshade2069 (nightshade2069) wrote :

(In reply to comment #35)
> a month and a week later...
>

Guys.. there is a lot of work they have to figure out. If you do the work around it should work with no problem after it is applied. I know it is an ugly work around but it has worked on all 3 of my systems.

Revision history for this message
In , Eric-bosch (eric-bosch) wrote :

What I have done to provide an acceptable workaround is to use TightVNC and X11vnc. Both of these applications work fine with the current version of xorg-server, and provide usable functionality until they can get the RealVNC application updated.

Adam Conrad (adconrad)
Changed in vnc4:
importance: Undecided → High
Revision history for this message
Caroline Ford (secretlondon) wrote :

https://lists.ubuntu.com/archives/ubuntu-autotest/2007-December/000092.html
Automatic build of vnc4_4.1.1+xorg1.0.2-0ubuntu6 on king by sbuild/amd64 1.170.5

In file included from /usr/include/X11/extensions/renderproto.h:30,
                 from glyphstr.h:29,
                 from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
/usr/include/X11/extensions/render.h:29: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Glyph'
/usr/include/X11/extensions/render.h:30: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'GlyphSet'
/usr/include/X11/extensions/render.h:31: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Picture'
/usr/include/X11/extensions/render.h:32: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'PictFormat'
In file included from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
glyphstr.h:119: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:122: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:125: error: expected declaration specifiers or '...' before 'Glyph'
In file included from renderedge.h:28,
                 from renderedge.c:29:
picturestr.h:472: error: expected ')' before 'pid'
picturestr.h:616: error: expected ')' before 'pid'
picturestr.h:621: error: expected ')' before 'pid'
picturestr.h:630: error: expected ')' before 'pid'
picturestr.h:641: error: expected ')' before 'pid'
make[2]: *** [renderedge.lo] Error 1
make[2]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2/render'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2'
make: *** [build-server-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Revision history for this message
Caroline Ford (secretlondon) wrote :

https://lists.ubuntu.com/archives/ubuntu-autotest/2007-December/000093.html
Automatic build of vnc4_4.1.1+xorg1.0.2-0ubuntu6 on terranova by sbuild/i386 1.170.5

In file included from /usr/include/X11/extensions/renderproto.h:30,
                 from glyphstr.h:29,
                 from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
/usr/include/X11/extensions/render.h:29: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Glyph'
/usr/include/X11/extensions/render.h:30: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'GlyphSet'
/usr/include/X11/extensions/render.h:31: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Picture'
/usr/include/X11/extensions/render.h:32: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'PictFormat'
In file included from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
glyphstr.h:119: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:122: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:125: error: expected declaration specifiers or '...' before 'Glyph'
In file included from renderedge.h:28,
                 from renderedge.c:29:
picturestr.h:472: error: expected ')' before 'pid'
picturestr.h:616: error: expected ')' before 'pid'
picturestr.h:621: error: expected ')' before 'pid'
picturestr.h:630: error: expected ')' before 'pid'
picturestr.h:641: error: expected ')' before 'pid'
make[2]: *** [renderedge.lo] Error 1
make[2]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2/render'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2'
make: *** [build-server-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Revision history for this message
Caroline Ford (secretlondon) wrote :

https://lists.ubuntu.com/archives/ubuntu-autotest/2007-December/000250.html

Automatic build of vnc4_4.1.1+xorg1.0.2-0ubuntu6 on royal by sbuild/powerpc 1.170.5

In file included from /usr/include/X11/extensions/renderproto.h:30,
                 from glyphstr.h:29,
                 from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
/usr/include/X11/extensions/render.h:29: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Glyph'
/usr/include/X11/extensions/render.h:30: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'GlyphSet'
/usr/include/X11/extensions/render.h:31: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Picture'
/usr/include/X11/extensions/render.h:32: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'PictFormat'
In file included from picturestr.h:29,
                 from renderedge.h:28,
                 from renderedge.c:29:
glyphstr.h:119: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:122: error: expected declaration specifiers or '...' before 'Glyph'
glyphstr.h:125: error: expected declaration specifiers or '...' before 'Glyph'
In file included from renderedge.h:28,
                 from renderedge.c:29:
picturestr.h:472: error: expected ')' before 'pid'
picturestr.h:616: error: expected ')' before 'pid'
picturestr.h:621: error: expected ')' before 'pid'
picturestr.h:630: error: expected ')' before 'pid'
picturestr.h:641: error: expected ')' before 'pid'
make[2]: *** [renderedge.lo] Error 1
make[2]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2/render'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/build/buildd/vnc4-4.1.1+xorg1.0.2/xorg-server-1.0.2'
make: *** [build-server-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

Revision history for this message
Caroline Ford (secretlondon) wrote :

new ->confirmed

Changed in vnc4:
status: New → Confirmed
Changed in vnc4:
status: Unknown → New
Changed in vnc4:
status: Unknown → Confirmed
Revision history for this message
Michael Milligan (milli) wrote :

Simple fix to get this one to compile, patch attached. Verified it builds now.

Still does NOT solve bug #180619. This package needs the xorg-server bits updated to match xserver-xorg-core package version (1.4.1 in Hardy) and some input refactoring done, per Debian bug 444697.

Changed in vnc4:
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

same patch as a debdiff. Subscribing motu-release for freeze clearance.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 184225] Re: FTBFS in latest archive rebuild test

Ack. Go for it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vnc4 - 4.1.1+xorg1.0.2-0ubuntu7

---------------
vnc4 (4.1.1+xorg1.0.2-0ubuntu7) hardy; urgency=low

  * Add missing X11/X.h include, to fix build with current xorg headers;
    thanks to Michael Milligan for the patch. LP: #184225

 -- Steve Langasek <email address hidden> Wed, 16 Apr 2008 07:34:09 +0000

Changed in vnc4:
status: Confirmed → Fix Released
Revision history for this message
In , Mkb-h (mkb-h) wrote :
Download full text (6.3 KiB)

I'm trying to follow the work around in comment #33 but vnc is still refusing to build.

>>> Emerging (1 of 1) net-misc/vnc-4.1.2-r4 to /
 * vnc-4_1_2-unixsrc.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
 * xorg-server-1.3.0.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
 * vnc-4.1.2-r4-patches-0.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
 * checking ebuild checksums ;-) ... [ ok ]
 * checking auxfile checksums ;-) ... [ ok ]
 * checking miscfile checksums ;-) ... [ ok ]
 * checking vnc-4_1_2-unixsrc.tar.gz ;-) ... [ ok ]
 * checking vnc-4.1.2-r4-patches-0.3.tar.bz2 ;-) ... [ ok ]
 * checking xorg-server-1.3.0.0.tar.bz2 ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking vnc-4_1_2-unixsrc.tar.gz to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
>>> Unpacking vnc-4.1.2-r4-patches-0.3.tar.bz2 to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
>>> Unpacking xorg-server-1.3.0.0.tar.bz2 to /var/tmp/portage/net-misc/vnc-4.1.2-r4/work
 * Applying various patches (bugfixes/updates) ...
 * 001_all_vnc-server-alpha-build-fix.patch ... [ ok ]
 * 003_all_vnc-gcc4.3.patch ... [ ok ]
 * 01_all_vnc-cookie.patch ... [ ok ]
 * 03_all_vnc-gcc4.patch ... [ ok ]
 * 05_all_vnc-use-fb.patch ... [ ok ]
 * 07_all_vnc-xclients.patch ... [ ok ]
 * 09_all_vnc-idle.patch ... [ ok ]
 * 11_all_vnc-via.patch ... [ ok ]
 * 13_all_vnc-restart.patch ... [ ok ]
 * 15_all_vnc-vncpasswd.patch ... [ ok ]
 * 17_all_vnc-server-modular-xorg.patch ... [ ok ]
 * 19_all_vnc-nohttpd.patch ... [ ok ]
 * 21_all_vnc-server-s390.patch ... [ ok ]
 * 23_all_vnc-viewer-reparent.patch ... [ ok ]
 * 25_all_vnc-64bit.patch ... [ ok ]
 * 27_all_vnc-select.patch ... [ ok ]
 * 29_all_vnc-server-ppc64.patch ... [ ok ]
 * 31_all_vnc-newfbsize.patch ... [ ok ]
 * 35_all_vnc-ipv6.patch ... [ ok ]
 * 37_all_vnc-password-stdin.patch ... [ ok ]
 * 39_all_vnc-config.patch ... [ ok ]
 * 41_all_vnc-render.patch ... [ ok ]
 * 43_all_vnc-autotools.patch ... [ ok ]
 * 44_all_vnc-server-autotools.patch ... [ ok ]
 * 45_all_vnc-autotools-compile.patch ... [ ok ]
 * 47_all_vnc-server-always-u...

Read more...

Revision history for this message
In , Patrizio Bassi (patrizio-bassi) wrote :

still no way?

Revision history for this message
In , Raúl Porcel (armin76) wrote :

-r5 now uses/needs 1.5.1

Changed in vnc4:
status: Confirmed → Fix Released
Changed in vnc4 (Gentoo Linux):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.