compiz / vnc screen updates with nVidia restricted

Bug #77442 reported by Sebastian Breier on 2006-12-29
274
This bug affects 49 people
Affects Status Importance Assigned to Milestone
vino
Fix Released
Unknown
compiz (Ubuntu)
High
Unassigned
Nominated for Gutsy by unggnu
Nominated for Jaunty by Rocko
Nominated for Karmic by Louis
vino (Ubuntu)
High
Unassigned
Nominated for Gutsy by unggnu
Nominated for Jaunty by Rocko
Nominated for Karmic by Louis
vnc (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by unggnu
Nominated for Jaunty by Rocko
Nominated for Karmic by Louis

Bug Description

When connecting to a VNC server (vino) on a machine using desktop-effects, the screen is never updated. Mouse/Keyboard commands still get sent but the effects are only shown after reconnecting. This is probably because of the way vnc detects changes.

This has been reported into beryl: http://bugs.beryl-project.org/trac/ticket/385
It is also known for x11vnc: http://www.dslinux.org/blogs/pepsiman/?p=73

If Ubuntu wants desktop-effects to be enabled by default, vnc will have to be updated.

Sebastien Bacher (seb128) wrote :

That's not clear if that's a vino, compiz or xorg bug

Emilio Pozuelo Monfort (pochu) wrote :

Are you using compiz or beryl when having this issue? If I've understood well your issue, this bug looks similar to Bug #82999 (compiz).

Is it the same problem?

Sebastian Breier (tomcat42) wrote :

It's a bit similar, but not really. I am using compiz.

In Bug #82999, it happens only to single windows, happened only on recent versions of compiz and I was able to work around it by changing my xorg.conf.

While this bug not only happens in compiz, but also in beryl and affects the whole screen, not only a couple of windows.

According to the Beryl people this is a more general problem with AIGLX & VNC.

I'll try VNC in feisty again though. Maybe it's fixed.

Sebastian Breier (tomcat42) wrote :

No, I'm afraid not. Problem persists in current feisty.

Emilio Pozuelo Monfort (pochu) wrote :

I close the desktop-effects bug, since this happen also with beryl, and desktop-effects has nothing with beryl.

Changed in desktop-effects:
status: Unconfirmed → Rejected
Jonh Wendell (wendell) wrote :

There is a bug opened in upstream. I'm linking to it until we discover if it's a vino bug or not.

Changed in vino:
status: Unknown → Unconfirmed
Changed in vino:
importance: Undecided → Low
Chris Moore (dooglus) wrote :

This bug isn't specific to vino - x11vnc suffers from exactly the same problem.

It seems that the VNC servers rely on the DAMAGE X server extension to know which parts of the display need sending to the client, and using Xgl stops this from working.

For x11vnc a workaround is to use the -noxdamage flag, which works, but is much slower; probably because the VNC server has to send the whole screen over and over, rather than just the 'damaged' parts.

For vino, a workaround is to use x11vnc -noxdamage instead...

stefab (bluefuture) wrote :

Please thake a look to this wikipedia article http://en.wikipedia.org/wiki/VirtualGL

unggnu (unggnu) wrote :

Could you please put this bug to High priority or at least normal? If this isn't fixed in Gutsy release which should enable Composite per default VNC access isn't possible anymore which would be very bad for support.

Changed in desktop-effects:
importance: Undecided → High
status: Invalid → New
Changed in vino:
importance: Low → High
status: New → Confirmed

Does this happen if you use xcompmgr too?

Changed in compiz:
status: New → Incomplete
Jeff Fortin Tam (kiddo) wrote :

it only happens with compiz, I just tried with xcompmgr and it worked fine (could even toggle it on/off while in remote desktop)

Changed in vnc:
status: New → Confirmed
Sergio Zanchetta (primes2h) wrote :

Same here. no refresh at all.

Michael Vogt (mvo) wrote :

It seems like the best workaround for this problem is to add a check to "Remote Desktop Preferences". If compiz is running a checkbox should come up that offers to disable desktop effects.

unggnu (unggnu) wrote :

This is a great idea but why not make it automatic? Everytime a client connects vnc checks if compiz is enabled. If it is, compiz is disabled for this vnc session and afterwards enabled again. Like removing the desktop background on some vnc clients.

Sebastian Breier (tomcat42) wrote :

It's not that easy. Removing the background can be done on the fly (right? I'm not 100% sure) while changing the wm would have to be done at least user-wide; So a local user would lose compiz functionality as well.

unggnu (unggnu) wrote :

This is the plan. The user looses the background for the session too and I think atm a user can live without compiz for a supporting session and it is of course only a workaround until the issue is fixed. But I don't know. It looks like I can enable and disable compiz on the fly under Desktop Effects so why this isn't possible for vino?

Jonh Wendell (wendell) wrote :

Fixed in 2.19.92

Changed in vino:
status: Confirmed → Fix Released
Changed in vino:
status: New → Fix Released
unggnu (unggnu) wrote :

I can confirm that it works fine with latest updates. Much more better than a work around. Thanks.

Jonh Wendell (wendell) wrote :

hehe. What i did was a workaround :)

Check upstream changelog:
zless /usr/share/doc/vino/changelog.gz

Changed in compiz:
status: Incomplete → Invalid
KraetziChriZ (christian.b) wrote :

Well, it's fixed!

Thank you :-)

Changed in vnc:
status: Confirmed → Fix Released
Changed in compiz:
status: Invalid → Fix Released
spiderpig (fredrik-tessem) wrote :

Please advice how to upgrade to 2.19 or 2.20 for us dummies! ;-)
It's not in feisty rep. after what I can find and can't make an upgrade by synaptic.

Jonh Wendell (wendell) wrote :

The update will be available in October, with next version of Ubuntu, Gutsy.

spiderpig (fredrik-tessem) wrote :

So it will not be upgraded in feisty? Is it posible to do this manualy with http://linux.softpedia.com/get/System/Networking/Vino-18305.shtml or anything like this? I realy want to run beryl, but need to remote control it.

thekip (thekip) wrote :

I get this bug again in Gutsy i386:

when I'm using compiz with xserver-xgl installed. My GPU is a 9700mobile Ati, when I connect to my vnc server it only works the first second or so. After a second the window stops updating while the events are still sent.

Is there any way to fix this? Especially as it's been fixed in an earlier version?

Travis Watkins (amaranth) wrote :

This is only fixed if you use vino for the vnc server.

thekip (thekip) wrote :

Are there any plans to fix this in x11vnc? x11vnc can be configured more specifically.

Travis Watkins (amaranth) wrote :

You need to run it with -noxdamage or some similar option.

ajonat (ajonat) wrote :

Please, can someone backport gusty's vino to feisty?

ajonat wrote:
> Please, can someone backport gusty's vino to feisty?

file a bug at launchpad.net/gutsy-backports

I searched the fix in the vino repositories and applied _ONLY_ the patch fixing this problem to feisty's vino (2.18.1-0ubuntu1) and it worked :)
Attached is a working package, just install it in feisty (with dpkg, gdebi, etc) and vino will work with beryl.
Have fun!

P.S. The package attached has the same name as the one in feity repositories, but this one works.

Chudilo (chudilo) wrote :

I am seeing the same bug in Hardy when i connect to a secondary viewport.
I have 2 monitors configured as 2 independent displays.
I am normally able to access them via vnc as hostname:0 and hostname:1 alternatively hostname:5900 and hostname:5901

If I enable visual effects, the second view port no longer updates within VNC exactly as described in this bug.
If I disable visual effect, everything goes back to normal.

Rocko (rockorequin) wrote :

I'm getting this in Jaunty on an amd64 machine with an nvidia card - after vnc'ing into this machine, the screen is only updated if compiz is turned off.

kernel 2.6.28-8-generic
xserver-xorg-core 2:1.5.99.902-0ubuntu7
vino 2.25.91-0ubuntu1
compiz 1:0.7.9+git20090211-0ubuntu4
nvidia 180.29-0ubuntu2

I too am hitting this problem in Jaunty. Could the changed in http://svn.gnome.org/viewvc/vino/trunk/server/vino-fb.c?r1=678&r2=1032 be the cause for this regression? The log says:

2008-12-23 Jonh Wendell <jwendell {at} gnome.org>

 * server/vino-fb.c (vino_fb_init_xdamage):
   Don't check if we are running at a composited screen and disable
   XDamage extension. This should work fine nowadays.

What is the hypothesis for "this should work fine nowadays" ?

AndreK (andre-k) wrote :

same problem still exists.
Using Jaunty + Nvidia 180 drivers.

Linus_W (linus-wolter) wrote :

I also have the same problem.
Using Jaunty amd64 + Nvidia 180 drivers.

thekip (thekip) wrote :

Are you still getting this problem when starting the vnc server with the noxdamage flag? Not that it is a very viable solution but it's worth testing (this solved it in my case a couple of months ago).

AndreK (andre-k) wrote :

like you say, noxdamage works, but is very close to useless (depending on the VPN/3G/GPRS speed)

like the other people mentioned: Jaunty still have this problem.

Tried to report via apport but lost the attachments somehow..

Still valid for Jaunty. Should we open an additional bug since this report has been closed by http://bugzilla.gnome.org/show_bug.cgi?id=383147

Changed in vnc:
status: Fix Released → Incomplete
Changed in compiz:
status: Fix Released → Incomplete
Changed in vino:
status: Fix Released → Incomplete
Hermes (PL) (hermes85pl) wrote :

This bug still affects Jaunty (now the newest BETA, with latest updates!) - how come it hasn't been resolved for that long? The regression mentioned by Philippe Gauthier doesn't give much hope that anything will change for us in the nearest future.

Shymata (shymata) wrote :

Problem with me too, 9.04 Beta. I've never had it before migrating to Jaunty.
Deactivating Desktop effects, "solve" the problem, for the moment, waiting it will be patched.

9.04 Beta - AthlonXP 2600+ Barton - 1GB DDR - nVidia GeForce 6200
nVidia driver 180.37 and X.org Version: 1:7.4~5ubuntu16

Sebastian Breier (tomcat42) wrote :

I have no way to test an NVidia desktop, but with Intel & Jaunty, this problem does not exist.
VNC works very well with desktop effects enabled.
Maybe the new Intel rendering method?

unggnu (unggnu) wrote :

Most likely it has something to do with the Nvidia rendering engine. They use instead of DRI their own implementation.

Serge (serge-kutiin) wrote :

The same problem for me on my 9.04 Beta. nVidia GeForce8xxx. I am not sure if it is tight to NVidia - OpenSolaris works just fine with the same 180.37 drivers and compiz effects enabled on the same machine.

mdalacu (mdalacu) wrote :

Same problem here... Jaunty Beta (updated) nVidia 180.37 drivers GeForce 7900GT Athlon 4600 X2. :-(

maaaatteo (maaaatteo) wrote :

x11vnc server (with -noxdamage option) works even with compiz enabled.

jecarterii (jecarterii) wrote :

Just upgraded to 9.04 full release from 8.10 .. used update man gui to upgrade.. have same issue.. have to disable all desktop effects for users to vnc my system (which has vino server).. since im using full release, im guessing this issue got thru beta? any chance its gonna get fixed?..
thanks...

Irvin (irvinfly) wrote :

I'd bump into this issue, 9.04 clean install with nvidia restrict driver (also happened to the driver 173 and 180 from nvidia sites). Not yet try to close the compiz.

Irvin (irvinfly) wrote :

Comfirmed that close compiz vnc would returned to normal. please help to fix it, thanks.

Trurl (trurl-online) wrote :

I have this problem too. Fresh installation of Jaunty. VNC only shows the inital picture. I updated nvidia to 180.55, but it changed nothing.

By the way: All keyboard and mouse operations are executed (I tested that: VNC from latop on Desktop PC) on the remote desktop, but the picture don't show changes.

manojav (manojav) wrote :

I can confirm this as well. 9.04 was upgraded from 8.10. Shame this made it through beta.

Neiro (neiro74) wrote :

Same for me, people. Jaunty 9.04 upgraded from 9.10. Though x11server with -noxdamage works it's not an option - too slow for me, even through lan.

I have a 100Mb connection from my XP PC to my switch and then gigabit to
the ubuntu box. Running at full colors, I can't watch video but for
normal screen operations it works really well for me (no delays at all).
Have not tried without the -noxdamage.

On Tue, 2009-04-28 at 07:47 +0000, Neiro wrote:

> s

XCan (xcan-) wrote :

I too can confirm this issue. Running 9.04, vnc client only displays initial screen. All consecutive actions are carried out (can be seen by restarting the vnc-client and logging in), but the screen on the client does not update!

Mattias (mattias-webben) wrote :

nvidia+9.04 here aswell, with the same issue...

The newest version of Vino from Jonh Wendell has solved my problem thx.

Chris Balcum (sherl0k) wrote :

Whether or not the fix is released, it is not in the repos. I'm getting the same problem. Could someone put the new version of vino in upstream so we can grab it?

Jeremy A (jtheoof) wrote :

I am also using Ubuntu Jaunty 9.04 and noticing this problem.

So far, the easiest fix I found was to run metacity --replace on the server machine.
This kills the compiz window manager and replaces it with metacity which enables vnc clients to run fine.

I am able to notice the changes at runtime, so changing window manager updates the clients as soons as the command is run.

I hope this helps anyone with this problem.

Shad Owen (owen-shad) wrote :

The metacity --replace fix worked for me! Thank you!

Craig Kelley (ink) wrote :

I've packaged the latest upstream for vino; it now has a gconf boolean to disable XDamage. It's slow as dirt, but it works:

http://www.xmission.com/~ink/vino/

See the README.txt for instructions.

jose (jose-cybergalvez) wrote :

There are a couple of workarounds for this, none very good. Does anyone know if this is going to be fixed in karmic? I see that the importance is "undecided". I think its very important because I use vnc all the time and since I upgraded to jaunty its been difficult to use

i've been frustrated with remote desktop since i upgraded to jaunty as
well. it has not yet been fixed in karmic. the issue lies with the x11
server and it has been fixed, but wont make it into karmic. most likely
karmic+1

On Tue, Aug 18, 2009 at 3:07 PM, jose <email address hidden> wrote:

> *** This bug is a duplicate of bug 353126 ***
> https://bugs.launchpad.net/bugs/353126
>
> There are a couple of workarounds for this, none very good. Does anyone
> know if this is going to be fixed in karmic? I see that the importance
> is "undecided". I think its very important because I use vnc all the
> time and since I upgraded to jaunty its been difficult to use
>
> --
> compiz / vnc screen updates with nVidia restricted
> https://bugs.launchpad.net/bugs/77442
> You received this bug notification because you are a direct subscriber
> of the bug (via bug 353126).
>
> Status in GNOME Remote Desktop: Fix Released
> Status in “compiz” package in Ubuntu: Incomplete
> Status in “vino” package in Ubuntu: Incomplete
> Status in “vnc” package in Ubuntu: Incomplete
>
> Bug description:
> When connecting to a VNC server (vino) on a machine using desktop-effects,
> the screen is never updated. Mouse/Keyboard commands still get sent but the
> effects are only shown after reconnecting. This is probably because of the
> way vnc detects changes.
>
> This has been reported into beryl:
> http://bugs.beryl-project.org/trac/ticket/385
> It is also known for x11vnc: http://www.dslinux.org/blogs/pepsiman/?p=73
>
> If Ubuntu wants desktop-effects to be enabled by default, vnc will have to
> be updated.
>

John Doe (gehkacken02) wrote :

Same issue here, using Ubuntu 9.04 x64 with Nvidia drivers and desktop effects running.

tpatru (tpatru) wrote :

Same problem; Ubuntu 9.04x64, Geforce 8600GT, newest Nvidia drivers, full desktop effects. I really hope it gets fixed; I use VNC on a regular basis.

AndreK (andre-k) wrote :

same on 9.10 Alfa - WTF ? - is this never gonna be fixed ?
RealVNC seems to work, if there only was a way to make it run even before logon...

Andrew (andrew-rw-robinson) wrote :

Has anyone considered making the gnome remote desktop implementation an alternative between vino and x11vnc? x11vnc works very well, the author is responsive and it works with desktop effects enabled also by disabling xdamage.

Gauthic (gauthic) wrote :

This is still broken in 10.04 alpha 3 as well....

TiansHUo (tianshuo) wrote :

Broken in karmic 9.10

Doug Morse (dm-dougmorse) wrote :

Broken in karmic 9.10 w. Nvidia 96 drivers... :(

Jason Butler (ubulaunch) wrote :

This (vino with nvidia & compiz) stopped working (stopped updating screen) after I upgraded from ubuntu 8.10 32bit to 9.04 32 bit and now 64bit many many moons ago.

Does not one of us have the time to fix the package (X?) that has introduced this haneous regression having sustained this long and continued poisoning of a wholesome chunk of GNU/Linux? Sadly, I know I don't.

Bueler?

fram (valkrsk) wrote :

The same problem in 10.04

Same issue here. This feature is a MUST have for me, and is an
absolute deal breaker at this point. Has not worked since 8.10! If
there is or was anything I could do, I would. I would go back to 8.10
if I could, but I really want some ofthe new features in 10.04. Now
that my iPhone is supported, this is the only feature I am missing
from my windows OS. so yes, you are correct, this does hurt a big part
of the GNU Linux community in a big way and restricts it's
advancement. Sad....

------------------------
Daniel Brady
<email address hidden>

On Apr 15, 2010, at 5:04 AM, Jason Butler <email address hidden>
wrote:

> *** This bug is a duplicate of bug 353126 ***
> https://bugs.launchpad.net/bugs/353126
>
> This (vino with nvidia & compiz) stopped working (stopped updating
> screen) after I upgraded from ubuntu 8.10 32bit to 9.04 32 bit and now
> 64bit many many moons ago.
>
> Does not one of us have the time to fix the package (X?) that has
> introduced this haneous regression having sustained this long and
> continued poisoning of a wholesome chunk of GNU/Linux? Sadly, I know I
> don't.
>
> Bueler?
>
> --
> compiz / vnc screen updates with nVidia restricted
> https://bugs.launchpad.net/bugs/77442
> You received this bug notification because you are a direct subscriber
> of the bug (via bug 353126).
>
> Status in GNOME Remote Desktop: Fix Released
> Status in “compiz” package in Ubuntu: Incomplete
> Status in “vino” package in Ubuntu: Incomplete
> Status in “vnc” package in Ubuntu: Incomplete
>
> Bug description:
> When connecting to a VNC server (vino) on a machine using desktop-
> effects, the screen is never updated. Mouse/Keyboard commands still
> get sent but the effects are only shown after reconnecting. This is
> probably because of the way vnc detects changes.
>
> This has been reported into beryl: http://bugs.beryl-project.org/trac/ticket/385
> It is also known for x11vnc: http://www.dslinux.org/blogs/pepsiman/?p=73
>
> If Ubuntu wants desktop-effects to be enabled by default, vnc will
> have to be updated.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/vino/+bug/77442/+subscribe

Johnnytk36 (jonathan-jkutz) wrote :

I could have swore someone said this would be fixed in 10.04, yet i just upgraded and to my surprise it wasn't.

Please fix this.

This was fixed, all you need to do is get the Nvidia drivers from VDPAU PPA

On Fri, May 28, 2010 at 6:00 AM, Johnnytk36 <email address hidden> wrote:

> *** This bug is a duplicate of bug 353126 ***
> https://bugs.launchpad.net/bugs/353126
>
> I could have swore someone said this would be fixed in 10.04, yet i just
> upgraded and to my surprise it wasn't.
>
> Please fix this.
>
> --
> compiz / vnc screen updates with nVidia restricted
> https://bugs.launchpad.net/bugs/77442
> You received this bug notification because you are a direct subscriber
> of the bug (via bug 353126).
>
> Status in GNOME Remote Desktop: Fix Released
> Status in “compiz” package in Ubuntu: Incomplete
> Status in “vino” package in Ubuntu: Incomplete
> Status in “vnc” package in Ubuntu: Incomplete
>
> Bug description:
> When connecting to a VNC server (vino) on a machine using desktop-effects,
> the screen is never updated. Mouse/Keyboard commands still get sent but the
> effects are only shown after reconnecting. This is probably because of the
> way vnc detects changes.
>
> This has been reported into beryl:
> http://bugs.beryl-project.org/trac/ticket/385
> It is also known for x11vnc: http://www.dslinux.org/blogs/pepsiman/?p=73
>
> If Ubuntu wants desktop-effects to be enabled by default, vnc will have to
> be updated.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/vino/+bug/77442/+subscribe
>

flexer (flexer) wrote :

Still present in Ubuntu 10.4, NVIDIA 8600

Tim Potter (musikgoat) wrote :

Check out this:

http://www.nvnews.net/vbulletin/showthread.php?p=2255561

Specifically:

# Fixed an interaction problem between Compiz and 'screen-scraping' VNC servers like x11vnc and vino that caused the screen to stop updating. Fixes Launchpad bug #353126.

Looks like this is the latest build (LInux 32bit):
http://www.nvidia.com/object/linux-display-ia32-256.44-driver.html

Snahrck (hansenclever) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.