Ubuntu

vmware-server: Package requests recursive update

Reported by Cliff Cunnington on 2007-11-07
42
Affects Status Importance Assigned to Milestone
Ubuntu
High
Fabio Massimo Di Nitto
vmware-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vmware-server

Since this morning (Nov7), this package is recursively requesting
upgrade to the same version number (1.0.3-1).

In my first "upgrade", 'apt-get dist-upgrade' reinstalled the apt-cached
version of this package version. That package was about two weeks old.

Before the second upgrade attempt, I deleted the apt-cached version of the
package to allow 'apt-get' to download and install the current repository
package[*], currently dated 6-Nov-2007.

    [*] http://archive.canonical.com/pool/partner/v/vmware-server/

The package installed successfully, but it is *still* requesting
upgrade via update-manager notification and 'apt-get dist-upgrade':

     # sudo apt-get dist-upgrade
     Reading package lists... Done
     Building dependency tree
     Reading state information... Done
     Calculating upgrade... Done
     The following packages will be upgraded:
       vmware-server
     1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
     Need to get 0B/79.4MB of archives.
     After unpacking 0B of additional disk space will be used.
     Do you want to continue [Y/n]? n
     Abort.

Regards,
Cliff Cunnington

-- System Information:
Debian Release: 4.0
  APT prefers feisty-updates
  APT policy: (500, 'feisty-updates'), (500, 'feisty-security'), (500, 'feisty-backports'), (500, 'fei
sty')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.20-16-generic
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

vmware-server recommends no packages.

-- debconf information:
  vmware-server/invalid-serial-number:
* vmware-server/serial-number: XXXXXXXXXXXXXXXXX
* vmware-server/eula-accepted: true
* vmware-server/eula:
* vmware-server/error-previous-installation:
* vmware-server/eula-error:

PaulPL (pawcio-s) wrote :

I'd like to confirm about this bug.

I tried delete all packages with dependences vmware but problem is still.

System information:
$ uname -a
Linux pc-desktop 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

ubuntu 7.04 with latest updates.

Best regards, PaulPL

Thomas Risberg (trisberg) wrote :

Just installed all updates using Update Manager and I'm seeing the same issue.

$ uname -a
Linux hawaii 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

gizzmo (fischbach-forum) wrote :

Same here
System: Kubuntu Feisty with 2.6.20-16-386 #2 Sun Sep 23 19:47:10 UTC 2007 i686 GNU/Linux Kernel.

Mike Sandman (n8behavior) wrote :

same here

$ uname -a
Linux freedom 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

Dan May (dmay) wrote :

I confirm this issue with two different machines, one here:
AHEXEC1 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux (Feisty)

and one at home running Gutsy (upgraded from Feisty).

Changed in vmware-server:
status: New → Confirmed
Nobuddy (whtb) wrote :

(K)Ubuntu Feisty 7.04, 2.6.20-16-generic
I have the same problem.

It would be recommendable to out take this package from the sources until there is a solution!

When is there a solution for the problem?

Cliff Cunnington (cc-ububug) wrote :

Bug assigned to the package maintainer (VMware Build Team).

Changed in vmware-server:
assignee: nobody → vmware-builds
John B. (jbuncher) wrote :

Ubuntu Feisty 7.04, 2.6.20-16-generic

I'd like to confirm this bug.

rfried (rfried) wrote :

Same here on Ubunut 7.04:

# cat /etc/apt/sources.list | grep -v ^# | grep -v ^$
deb http://at.archive.ubuntu.com/ubuntu/ feisty main restricted
deb-src http://at.archive.ubuntu.com/ubuntu/ feisty main restricted
deb http://at.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb-src http://at.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb http://at.archive.ubuntu.com/ubuntu/ feisty universe
deb-src http://at.archive.ubuntu.com/ubuntu/ feisty universe
deb http://at.archive.ubuntu.com/ubuntu/ feisty multiverse
deb-src http://at.archive.ubuntu.com/ubuntu/ feisty multiverse
deb http://security.ubuntu.com/ubuntu feisty-security main restricted
deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
deb http://security.ubuntu.com/ubuntu feisty-security universe
deb-src http://security.ubuntu.com/ubuntu feisty-security universe
deb http://security.ubuntu.com/ubuntu feisty-security multiverse
deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse

# apt-config dump
APT "";
APT::Architecture "i386";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "0";
APT::Install-Suggests "0";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^linux-image.*";
APT::NeverAutoRemove:: "^linux-restricted-modules.*";
APT::Install-Recommends-Section "metapackages";
APT::Never-MarkAuto-Section "metapackages";
APT::Periodic "";
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Archives "";
APT::Archives::MaxAge "30";
APT::Archives::MinAge "2";
APT::Archives::MaxSize "500";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::mirrors "mirrors/";
Dir::State::userstatus "status.user";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
Unattended-Upgrade "";
Unattended-Upgrade::Allowed-Origins "";
Unattended-Upgrade::Allowed-Origins:: "Ubuntu feisty-security";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi";

Very nasty :-O

Kind Regards,
 Roland

Martin Aulbach (martinaulbach) wrote :

 I would like to confirm the bug too. (Ubuntu Feisty 7.04)

Crakie (baloedebruinebeer) wrote :

I'll join in: same here.

Confirmed. Ping?

Sascha Herres (saschaherres) wrote :

I can (still) confirm this issue with all of my machines (all regular "Feisty").

It's special annoying, because that package is so big. You end up downloading another ~80 MB for nothing, whenever you forget to uncheck that package at regular update schedules. :(

If there is need for additional information, please contact me.

Cliff Cunnington (cc-ububug) wrote :

Workaround for Ubuntu bug #160683

The following procedure will get rid of this annoying little problem.

% mkdir -p vmw103/DEBIAN
% cd vmw103/
% dpkg-deb -x /var/cache/apt/archives/vmware-server_1.0.3-1_i386.deb .
% dpkg-deb -e /var/cache/apt/archives/vmware-server_1.0.3-1_i386.deb .
% $EDITOR control
In your editor, change the Version number from 1.0.3-1 to 1.0.3-2
% cp control DEBIAN/
% cd ../
% dpkg-deb --build vmw103
dpkg-deb: building package `vmware-server' in `vmw103.deb'.
% mv vmw103.deb vmware-server_1.0.3-2_i386.deb
% sudo dpkg -i vmware-server_1.0.3-2_i386.deb

Your Update-Manager notification icon should now switch off :-)

Kameleon (kameleon25) wrote :

Thanks Cliff. Worked like a charm.

Joseph Zargari (yzargari) wrote :

Thanks Cliff, it certainly did work.
A little question though; what if vmware server 1.0.3-2 actually does get released? Will we miss this update?

Thanks again.

Cliff Cunnington (cc-ububug) wrote :

> what if vmware server 1.0.3-2 actually does get released?

The Nov6 VMWare package release that triggered this bug should have been called 1.0.3-2, so we are really just giving it its proper version number.

If there is another 1.0.3 release (to close this bug!), hopefully the VMWare Build Team will be considerate enough to call it 1.0.3-3 so it will trigger a proper update for users with and without this workaround.

Kameleon (kameleon25) wrote :

And yet again. This mornings update to vmware-server to version 1.0.4-1feisty1 did fine the first time but now is doing the wonderful recursive request again. Any ideas? If needed I will submit another bug report.

Cliff Cunnington (cc-ububug) wrote :

The above workaround which I posted does not work. Although it fixes the recursive update issue -- it breaks the vmware gui. Which is not quite the point ... .

I can confirm that the 'recursive update' problem is also present in the latest 1.0.4 package.

Ioannis Ramfos (isr81) wrote :

Same here for the 1.0.4 package. Tried the patch and the update issue was solved, but vmware-server-console freezes after the selection to connect to the local host.

Martin Sander (forke) wrote :

confirmed, 1.0.4-1feisty1.
Really annoying. Consider deactivating the commercial repositories until this gets fixed...

This was a launchpad bug that has been fixed.

Fabio

Changed in vmware-server:
status: Confirmed → Invalid
Martin Aulbach (martinaulbach) wrote :

I can confirm the bug with 1.0.4-1feisty1 as well. And it's really quite annoying. Considering the great effort done by Canonical and the community to support VMware in Ubuntu, it should be a piece of cake to remove this tiny glitch, shouldn't it?

Cliff Cunnington (cc-ububug) wrote :

Fabio:
> This was a launchpad bug that has been fixed.

I just reinstated the commercial repo in sources.list, ran "apt-get update" again and the problem is still here. Or do you mean when the *next* vmware-server package is prepared, this bug will go away?

Please clarify.

To be an "invalid" bug, I have to say it's quite persistent... ;-)

Really, I wouldn't define it as invalid. Maybe it's another component bug (although it seems that is triggered by vmware -server alone). Could you please elaborate a bit more?

Mike Sandman (n8behavior) wrote :

ditto for me cliff. i still have the issue :(

Ioannis Ramfos (isr81) wrote :

Still exists for 1.0.4-1feisty2.

Cliff Cunnington (cc-ububug) wrote :

Fabio, seems you closed this bug too soon. As reported, 1.0.4-1feisty2 (dd. 16Nov) still triggers this bug. Even if it is a dependency bug (i.e. launchpad), it seems wise to leave the bug open until the installation of the vmware-server package no longer causes this bug.

If you want, reassign it to someone responsible for "launchpad" -- but this bug is not 'invalid' and it is not closed.

Workaround: remove 'commercial' from repositories and watch this space!

Changed in vmware-server:
status: Invalid → Confirmed
Sascha Herres (saschaherres) wrote :

I have just installed "1.0.4-1feisty2": The bug is still out there meaning that update-manager suggests to install the vmware-server package again and again ...

Removing the repository is not really an option for me.

Again: If there is need for additional information, please contact me.

Cliff Cunnington (cc-ububug) wrote :

Sascha:
Removing the repository from update-manager/sources.list doesn't affect the installation of vmware-server, which will stay installed. It just means that the commercial package lists will not be downloaded on a daily basis and this bug will not be triggered.

When this bug is eventually resolved, just add back 'commercial' and all will work again. But in the meantime you won't have this recursive update problem.

JThoennes (joerg-thoennes) wrote :

Package: vmware-server
Version: 1.0.4-1feisty2

Even "aptitude purge vmware-server" followed by "aptitude install vmware-server"
did not help.

Waiting for the bug to be fixed.

Cheers, Jörg

rfried (rfried) wrote :
Download full text (7.7 KiB)

Same here on # cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.04
DISTRIB_CODENAME=feisty
DISTRIB_DESCRIPTION="Ubuntu 7.04"

It's a mess since about two weeks :-|

root@titan:~# apt-get clean
root@titan:~# apt-get update
Hole:1 http://packages.medibuntu.org feisty Release.gpg [189B]
Hole:2 http://security.ubuntu.com feisty-security Release.gpg [191B]
Ign http://security.ubuntu.com feisty-security/main Translation-de
Ign http://security.ubuntu.com feisty-security/restricted Translation-de
Hole:3 http://opensync.gforge.punktart.de feisty Release.gpg [189B]
Ign http://opensync.gforge.punktart.de feisty/main Translation-de
Hole:4 http://at.archive.ubuntu.com feisty Release.gpg [191B]
OK http://at.archive.ubuntu.com feisty/main Translation-de
OK http://at.archive.ubuntu.com feisty/restricted Translation-de
Ign http://security.ubuntu.com feisty-security/universe Translation-de
Ign http://security.ubuntu.com feisty-security/multiverse Translation-de
OK http://security.ubuntu.com feisty-security Release
OK http://opensync.gforge.punktart.de feisty Release
OK http://at.archive.ubuntu.com feisty/universe Translation-de
OK http://at.archive.ubuntu.com feisty/multiverse Translation-de
Hole:5 http://at.archive.ubuntu.com feisty-updates Release.gpg [191B]
Ign http://at.archive.ubuntu.com feisty-updates/main Translation-de
Ign http://at.archive.ubuntu.com feisty-updates/restricted Translation-de
Hole:6 http://archive.canonical.com feisty-commercial Release.gpg [191B]
Ign http://archive.canonical.com feisty-commercial/main Translation-de
OK http://security.ubuntu.com feisty-security/main Packages
OK http://at.archive.ubuntu.com feisty Release
Ign http://opensync.gforge.punktart.de feisty/main Packages
OK http://archive.canonical.com feisty-commercial Rele...

Read more...

I just upgraded to 1.0.4-1feisty3: nothing changed.
Could we have an overview of the problem here? So maybe someone can suggest a solution...

nickp (pnick) wrote :

I've just updated to 1.0.4-1feisty3, when restarting Update Manager 1.0.4-1feisty3 is still in the list "From version 1.0.4-1feisty3 to 1.0.4-1feisty3 (Size: 75.0 MB)"

Cliff Cunnington (cc-ububug) wrote :

I've asked the package maintainer, Fabio Massimo Di Nitto, if he can indicate when the Launchpad fix will be rolled out and this bug closed:

https://answers.launchpad.net/ubuntu/+source/vmware-server/+question/18581

Changed in vmware-server:
assignee: vmware-builds → fabbione
Chris Miles (chrismil-cix) wrote :

It looks as if although Fabio uploaded vmware-server, VMware Build Team is the maintainer.

Changed in vmware-server:
assignee: fabbione → vmware-builds
Chris Miles (chrismil-cix) wrote :

I have changed the "assigned" back to Fabio having reviewed the history and seen that the VMware Build Team have had quite a time to resolve this problem. Hopefully they both know of the troubles we are experiencing.

Changed in vmware-server:
assignee: vmware-builds → fabbione
RB (zzze4fa) wrote :

For Feisty / 7.04, Gnome -- "Me too". As of Tuesday 27 November, 2007 at 04:36 PM PST, I'll be on my fourth day of this problem.

I have one little observation as follows:

In Synaptic, choose vmware-server, right-click, and select the Versions tab.

Synaptic reports the two version of VMware Server 1.0.4-1feisty3 as "(feisty-commercial)" and "(now)". I'm not sure how to interpret that but wonder if I have some sort of repositories "collision"...(?)

Cheers & hope this helps,
Ric
SFO

Guys, i have already explain that this is a soyuz bug (aka launchpad). Unfortunatly the first fix was rolled out but incomplete.

The problem is not in vmware-server and I can guarantee all of you that people are working as fast as they can to address it.

Fabio

Changed in vmware-server:
importance: Undecided → High
Haggai Eran (haggai-eran) wrote :

I've encountered this bug on gutsy. My machine never had this bug on feisty, and after the upgrade I left 1.0.3 installed. Today I saw the 1.0.4-1gutsy1 package for gutsy in the partner repository, and after upgrading to it, aptitude and update-notifier still want to upgrade it to the same verison.

same bug for me on gutsy with 1.0.4-1gutsy1

bug disappeared now with an update to 1.0.4-1gutsy2, thanks

Harald Koch (chk-pobox) wrote :

This problem has disappeared for me. I currently have 1.0.4-1feisty3 installed. Thanks!

Martin Aulbach (martinaulbach) wrote :

I can confirm that the bug has been resolved. (1.0.4-1feisty3) Many thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers