libhal1 0.5.7.1-0ubuntu8 with new dbus breaks vmware

Bug #59232 reported by lithorus on 2006-09-06
28
Affects Status Importance Assigned to Milestone
vmware-player (Ubuntu)
Undecided
Unassigned

Bug Description

Since the new libhal1 recompiled with the new 0.90 dbus vmware won't start. It has been suggested that the new libhal1 should be renamed as it's not compatible with the older libhal1 recompiled with the old dbus.

Threads about this issue :
http://www.vmware.com/community/thread.jspa?threadID=53507&messageID=470458

http://ubuntuforums.org/showthread.php?t=247350

lithorus (lithorus) wrote :

Just wanted to add that this affects the vmware workstation 5.5.2 but not the old vmware workstation 5.5.1 works (but needs a patch to compile the kernel modules against the newer kernel)

The "free" vmware server have the same issue as 5.5.2.

John Dong (jdong) wrote :

Confirmed for vmware-player in Edgy, vmware-server from vmware.com.

Apparently our recompile against newer dbus has broken libhal ABI compatibility, in which case we should really be bumping the soname.

Changed in hal:
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

Sebastian, instead of building two dbus APIs, maybe we can add a dbus patch which just provides the old API as a wrapper? It's only the dbus_connection_close() renaming, right?

Sebastian Dröge (slomo) wrote :

I don't see how libhal's ABI changed here... libhal should be exactly the same but linked against the new libdbus-1.

According to the vmware forum thread it's caused by having libdbus-1.so.2 and libdbus-1.so.3 on the same system at the same time. vmware loads the former, hal the second and things explode (for whatever reason). IMHO this is a vmware bug but unfortunately we can't fix anything there....
What exactly are you proposing? Reverting the dbus transition?

Another workaround mentioned there is
LD_PRELOAD=/usr/lib/libdbus-1.so.3 vmware

Maybe we should go with that until vmware is fixed...

Can we get our vmware-player package fixed to use the LD_PRELOAD hack?

Sebastian Dröge (slomo) wrote :

Btw, according to the vmware forum (or how I understand it) it won't be enough to just add the function back as a wrapper (it was one for ages anyway).

Luis Mondesi (lemsx1) wrote :

i'm glad there is at least a workaround for this. for the mean time i did:

sudo vim /usr/local/bin/vmware

...
# work around for bug:
# https://launchpad.net/distros/ubuntu/+source/hal/+bug/59232
LD_PRELOAD=/usr/lib/libdbus-1.so.3
export LD_PRELOAD
...

and saved the file.

Darik Horn (dajhorn) wrote :

The is kludge also works with VMware Server Console 1.0.1 for Linux. You can apply the same change to the /usr/bin/vmware-server-console file.

Gustavo Rahal (gustavo-grahal) wrote :

I had this same issue so I removed the older libdbus-1-2 (0.60-6) package and vmware worked without the hack.
Why the upgrade to edgy did not remove the older dbus? The only package that depended on it was nautilus-burn3 which was out-of-date anyway.

Martin Pitt (pitti) wrote :

The easiest and cleanest solution would be to have vmware-player Conflicts: libdbus-1-2.

This was fixed a while back using the solution in the last comment.

Changed in vmware-player:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers