--firstboot option broken in 0.12.2-0ubuntu3

Bug #536942 reported by l8gravely on 2010-03-10
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
VMBuilder
Medium
Unassigned
vm-builder (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Hi,

The --firstboot option is now broken in version 0.12.2-0ubuntu3 of python-vm-builder, as shown in the previously working example below:

> sudo vmbuilder kvm ubuntu --suite=karmic --flavour=virtual --arch=amd64 --mirror=http://192.168.1.3:9999/ubuntu --libvirt=qemu:///system --ip=192.168.1.54 --part=vmbuilder.partition --templates=mytemplates --user=john --name=john --pass=john --addpkg=vim-nox --addpkg=unattended-upgrades --addpkg=acpid --raw=/dev/virtmachs/vm4 --firstboot=boot.sh --mem=256 --hostname=vm4 --bridge=br0
Usage: vmbuilder hypervisor distro [options]

vmbuilder: error: no such option: --firstboot

Thanks,
John

Soren Hansen (soren) on 2010-03-14
Changed in vmbuilder:
milestone: none → 0.12.3
Chuck Short (zulcss) on 2010-03-15
Changed in vm-builder (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Randy Barlow (rbarlow) wrote :

Is this something that is likely to be fixed before Lucid goes stable? I ask mostly because if not, I'd like to change the way a series of my scripts work, and it'd be nice to know that ahead of time. Thanks!

Randy> Is this something that is likely to be fixed before Lucid goes
Randy> stable? I ask mostly because if not, I'd like to change the way
Randy> a series of my scripts work, and it'd be nice to know that
Randy> ahead of time. Thanks!

I'm clueless, but I'd love to know what's the workaround for the
--firstboot= flag you're thinking of using. It would be great if we
could document that somewhere.

John

Randy Barlow (rbarlow) wrote :

Hey John! I haven't made any workaround yet, but I was considering something that sounds more complicated than I like. You could make an init script that does the first boot work, removes itself from the default run level, and then removes itself. There isn't a builtin first boot functionality to Ubuntu that I've been able to find, but if anybody knows of something like that I'd love to know as well!

Paul Sladen (sladen) on 2010-03-29
Changed in vm-builder (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-10.04
Soren Hansen (soren) wrote :

I expect to fix this before Lucid releases.

Changed in vmbuilder:
milestone: 0.12.3 → none
status: New → Confirmed
importance: Undecided → Medium
Soren Hansen (soren) on 2010-03-30
Changed in vmbuilder:
milestone: none → 0.12.4
l8gravely (john-stoffel) wrote :

Soren> I expect to fix this before Lucid releases.

Do you have a repository I could pull from for testing? Or your own
PPA I could test against to give you quicker feedback?

John

Thierry Carrez (ttx) on 2010-04-09
Changed in vm-builder (Ubuntu Lucid):
milestone: ubuntu-10.04 → none
Florian Kruse (florian-kruse) wrote :

l8gravely> Soren> I expect to fix this before Lucid releases.

l8gravely> Do you have a repository I could pull from for testing? Or your own
l8gravely> PPA I could test against to give you quicker feedback?

That would be great. Five days before the official Lucid release, I could really use a working vm-builder.

.:. brainsik (brainsik) wrote :

Lucid is out, what is the status of this bug? Looking at the changelog it doesn't look like this was fixed before release.

Florian Kruse (florian-kruse) wrote :

I don't know Ubuntu's release policy, but does this mean that there will possibly be no vm-builder in Lucid with working --firstboot?

I'd hope not, since it more or less renders Lucid's entire headline cloud offering useless...

Soren Hansen (soren) wrote :

On Tue, May 04, 2010 at 12:51:25AM -0000, .:. brainsik wrote:
> Lucid is out, what is the status of this bug? Looking at the changelog
> it doesn't look like this was fixed before release.

That's correct. I meant to, but personal issues got in the way. I will
push out an update in a few days, probably.

--
Soren Hansen
Ubuntu Developer
http://www.ubuntu.com/

Brian Adams (wreality) wrote :

Attached is a patch that seems to fix the issue (and the same issue with --firstlogin).

I've tested the patch in building a vm and debug indicates everything goes fine, however I haven't had a chance to push a vm to VMWare and confirm that everything functions as expected on that end.

If the issue is truly only the option being recognized however, it seems this should work.

Hope this help!

-Brian

Soren Hansen (soren) wrote :

That patch is disturbingly close to what I had in my local branch here :) Thanks, though! I appreciate it. Sorry for not updating this bug saying that I had code already to fix it. :(

Changed in vmbuilder:
status: Confirmed → Fix Committed
Florian Kruse (florian-kruse) wrote :

Sorry for being so impatient, but will this fix be available as a software package in Lucid? If so, when?

Soren Hansen (soren) wrote :

Fixed in upstream 0.12.4.

Changed in vmbuilder:
status: Fix Committed → Fix Released
Soren Hansen (soren) wrote :

This bug is a substantial regression from Karmic, so I'm going to SRU this.

It was fixed in http://bazaar.launchpad.net/~ubuntu-virt/vmbuilder/0.12/revision/440 which is included in the new 0.12.4 release upstream.

TEST CASE:
cat <<EOF > /tmp/myfirstbootscript.sh
#!/bin/sh
echo yes, it does > /does_it_work
EOF
sudo vmbuilder kvm ubuntu --firstboot /tmp/myfirstbootscript.sh

Boot the resulting virtual machine. Log in and check that it has a file called /does_it_work and that it says "yes, it does" in it.

l8gravely (john-stoffel) wrote :

>>>>> "Soren" == Soren Hansen <email address hidden> writes:

Soren> Fixed in upstream 0.12.4.

Soren> ** Changed in: vmbuilder
Soren> Status: Fix Committed => Fix Released

Soren> --
Soren> --firstboot option broken in 0.12.2-0ubuntu3
Soren> https://bugs.launchpad.net/bugs/536942
Soren> You received this bug notification because you are a direct subscriber
Soren> of the bug.

Soren> Status in Virtual Machine Builder: Fix Released
Soren> Status in ?vm-builder? package in Ubuntu: Confirmed
Soren> Status in ?vm-builder? source package in Lucid: Confirmed

Soren,

When can we expect this new version in Lucid? Or can you possibly
setup your own testing PPA that we can point to instead so we can give
you bug reports more quickly?

Thanks,
John

Barry Warsaw (barry) wrote :

I guess this still hasn't made it into Lucid yet?

% sudo vmbuilder kvm ubuntu --suite=lucid --flavour=virtual --libvirt=qemu:///system --arch=amd64 --firstboot=boot.sh
Usage: vmbuilder hypervisor distro [options]

vmbuilder: error: no such option: --firstboot

Any word on that SRU?

l8gravely (john-stoffel) wrote :

Barry> I guess this still hasn't made it into Lucid yet?

Nope, not at all. Soren seems to have dropped off the face of the
earth. I've tried pulling down the latest version which supposedly
fixes this, but I haven't had a chance to work on it myself either.

Barry> % sudo vmbuilder kvm ubuntu --suite=lucid --flavour=virtual --libvirt=qemu:///system --arch=amd64 --firstboot=boot.sh
Barry> Usage: vmbuilder hypervisor distro [options]

Barry> vmbuilder: error: no such option: --firstboot

Barry> Any word on that SRU?

Barry> --
Barry> --firstboot option broken in 0.12.2-0ubuntu3
Barry> https://bugs.launchpad.net/bugs/536942
Barry> You received this bug notification because you are a direct subscriber
Barry> of the bug.

Barry> Status in Virtual Machine Builder: Fix Released
Barry> Status in ?vm-builder? package in Ubuntu: Confirmed
Barry> Status in ?vm-builder? source package in Lucid: Confirmed

Barry> Bug description:
Barry> Hi,

Barry> The --firstboot option is now broken in version 0.12.2-0ubuntu3 of python-vm-builder, as shown in the previously working example below:

>> sudo vmbuilder kvm ubuntu --suite=karmic --flavour=virtual --arch=amd64 --mirror=http://192.168.1.3:9999/ubuntu --libvirt=qemu:///system --ip=192.168.1.54 --part=vmbuilder.partition --templates=mytemplates --user=john --name=john --pass=john --addpkg=vim-nox --addpkg=unattended-upgrades --addpkg=acpid --raw=/dev/virtmachs/vm4 --firstboot=boot.sh --mem=256 --hostname=vm4 --bridge=br0
Barry> Usage: vmbuilder hypervisor distro [options]

Barry> vmbuilder: error: no such option: --firstboot

Barry> Thanks,
Barry> John

Barry> To unsubscribe from this bug, go to:
Barry> https://bugs.launchpad.net/vmbuilder/+bug/536942/+subscribe

Barry Warsaw (barry) wrote :

Here's a branch that merges the current Lucid version with the latest upstream:

https://code.edge.launchpad.net/~barry/ubuntu/lucid/vm-builder/firstboot

I tried to do a build from branch, but got bug 589454 so I uploaded a version to my PPA

https://edge.launchpad.net/~barry/+archive/python

Keep an eye on that and please try the package when it builds.

Soren Hansen (soren) wrote :

On Thu, Jun 03, 2010 at 11:59:54PM -0000, Barry Warsaw wrote:
> Here's a branch that merges the current Lucid version with the latest
> upstream:
>
> https://code.edge.launchpad.net/~barry/ubuntu/lucid/vm-builder/firstboot
>
> I tried to do a build from branch, but got bug 589454 so I uploaded a
> version to my PPA
>
> https://edge.launchpad.net/~barry/+archive/python
>
> Keep an eye on that and please try the package when it builds.

I already publish packages of VMBuilder within minutes of committing
anything to trunk.

   https://edge.launchpad.net/~vmbuilder/+archive/daily

--
Soren Hansen
Ubuntu Developer
http://www.ubuntu.com/

Soren Hansen (soren) wrote :

On Thu, Jun 03, 2010 at 09:45:04PM -0000, l8gravely wrote:
>> I guess this still hasn't made it into Lucid yet?
> Nope, not at all. Soren seems to have dropped off the face of the
> earth.

Uh, I'm right here.

I've simply been very, very busy, and haven't had time to go through the
SRU process for the 0.12.4 release.

If anyone else wants to step in and help out, that would be most
appreciated.

It's all about finding the list of bugs that are fixed and writing a
simple test case for each of them. The technical bits are already done.
It's just the paperwork that I've yet to find enough free, consecutive
minutes to sort out.

--
Soren Hansen
Ubuntu Developer
http://www.ubuntu.com/

Barry Warsaw (barry) wrote :

Soren: cool thanks, I've deleted the package from my PPAl.

David Futcher (bobbo) on 2010-06-11
tags: added: patch-forwarded-upstream
Sebastian (seb-sschneider) wrote :

I installed the latest version uploaded by soren, and the problem still exists for me in a different way. I can use --firstboot and --firstlogin and the script runs fine with those commands. The VM does not run those commands, after it has been created and started. It starts up fine, it starts the Ubuntu boot sequence, but does not run firstboot or firstlogin.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vm-builder - 0.12.4-0ubuntu1

---------------
vm-builder (0.12.4-0ubuntu1) maverick; urgency=low

  * New upstream, bugfix release. (LP: #539460, #536942, #535397,
    #550689, #410521, #550691, others)
 -- Soren Hansen <email address hidden> Fri, 09 Jul 2010 22:58:32 +0200

Changed in vm-builder (Ubuntu):
status: Confirmed → Fix Released
Darren Worrall (dazworrall) wrote :

Fwiw, the package in lucid-proposed (0.12.4-0ubuntu0.1) fixes this issue for me. Would love to see it promoted to -updates

Yann Hamon (yannh) wrote :

Can confirm --firstboot works as expected for me using 0.12.4-0ubuntu0 on lucid host.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vm-builder - 0.12.4-0ubuntu0.1

---------------
vm-builder (0.12.4-0ubuntu0.1) lucid-proposed; urgency=low

  * New upstream, bugfix release. (LP: #539460, #536942, #535397,
    #550689, #410521, #550691, others)
 -- Soren Hansen <email address hidden> Fri, 09 Jul 2010 23:03:27 +0200

Changed in vm-builder (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers