-tmpfs=- option broken in 0.12.2-0ubuntu3

Bug #536940 reported by l8gravely
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
VMBuilder
Fix Committed
Undecided
Unassigned
vm-builder (Ubuntu)
Fix Released
Medium
Unassigned
Lucid
Won't Fix
Medium
Unassigned

Bug Description

Hi,

When I try to run python-vm-builder 0.12.2-0ubuntu3 on Lucid, it now complains about the --tmpfs=- option not existing. This used to work in previous versions on Lucid. Here's the error from an example usage:

> sudo vmbuilder kvm ubuntu --suite=karmic --flavour=virtual --arch=amd64 --mirror=http://192.168.1.3:9999/ubuntu --libvirt=qemu:///system --tmpfs=- --ip=192.168.1.54 --part=vmbuilder.partition --templates=mytemplates --user=john --name=john --pass=john --addpkg=vim-nox --addpkg=unattended-upgrades --addpkg=acpid --raw=/dev/virtmachs/vm4 --firstboot=boot.sh --mem=256 --hostname=vm4 --bridge=br0
Usage: vmbuilder hypervisor distro [options]

vmbuilder: error: no such option: --tmpfs

Thanks,
John

Related branches

Soren Hansen (soren)
Changed in vmbuilder:
milestone: none → 0.12.3
Revision history for this message
Soren Hansen (soren) wrote :

This is a funy one, really. :)

As far as I can see, --tmpfs was never actually implemented in the python version of VMBuilder. When porting from bash to Python, the option was added (so that it was accepted on the command line), but it's just silently ignored.

Revision history for this message
l8gravely (john-stoffel) wrote : [Bug 536940] Re: -tmpfs=- option broken in 0.12.2-0ubuntu3

Soren> This is a funy one, really. :) As far as I can see, --tmpfs was
Soren> never actually implemented in the python version of
Soren> VMBuilder. When porting from bash to Python, the option was
Soren> added (so that it was accepted on the command line), but it's
Soren> just silently ignored.

Heh, this should be an easy fix them. Let me know where the test
branch is and I'll see about testing it out if you like.

John

Soren> --
Soren> -tmpfs=- option broken in 0.12.2-0ubuntu3
Soren> https://bugs.launchpad.net/bugs/536940
Soren> You received this bug notification because you are a direct subscriber
Soren> of the bug.

Soren> Status in Virtual Machine Builder: New
Soren> Status in ?vm-builder? package in Ubuntu: New

Soren> Bug description:
Soren> Hi,

Soren> When I try to run python-vm-builder 0.12.2-0ubuntu3 on Lucid, it now complains about the --tmpfs=- option not existing. This used to work in previous versions on Lucid. Here's the error from an example usage:

>> sudo vmbuilder kvm ubuntu --suite=karmic --flavour=virtual --arch=amd64 --mirror=http://192.168.1.3:9999/ubuntu --libvirt=qemu:///system --tmpfs=- --ip=192.168.1.54 --part=vmbuilder.partition --templates=mytemplates --user=john --name=john --pass=john --addpkg=vim-nox --addpkg=unattended-upgrades --addpkg=acpid --raw=/dev/virtmachs/vm4 --firstboot=boot.sh --mem=256 --hostname=vm4 --bridge=br0
Soren> Usage: vmbuilder hypervisor distro [options]

Soren> vmbuilder: error: no such option: --tmpfs

Soren> Thanks,
Soren> John

Soren> To unsubscribe from this bug, go to:
Soren> https://bugs.launchpad.net/vmbuilder/+bug/536940/+subscribe

Chuck Short (zulcss)
Changed in vm-builder (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Soren Hansen (soren)
Changed in vmbuilder:
milestone: 0.12.3 → 0.12.4
Changed in vm-builder (Ubuntu):
milestone: none → ubuntu-10.04
Thierry Carrez (ttx)
Changed in vm-builder (Ubuntu Lucid):
milestone: ubuntu-10.04 → none
Soren Hansen (soren)
Changed in vmbuilder:
milestone: 0.12.4 → none
Revision history for this message
Данило Шеган (danilo) wrote :

I've created a branch which re-introduces --tmp and --tmpfs options for vmbuilder: lp:~danilo/vmbuilder/bug-536940

I also did a few cleanups of the tmpfile and tmpdir methods in the util module (they were doing some very weird stuff). If you like the general approach, let me know and I can make a merge-proposal.

Revision history for this message
Luke Faraone (lfaraone) wrote :

From my cursory reading of the source code, I don't see any problems. I encourage you to create a merge proposal.

Revision history for this message
Soren Hansen (soren) wrote :

On Mon, Jun 07, 2010 at 01:53:19PM -0000, Данило Шеган wrote:
> I've created a branch which re-introduces --tmp and --tmpfs options for
> vmbuilder: lp:~danilo/vmbuilder/bug-536940
>
> I also did a few cleanups of the tmpfile and tmpdir methods in the util
> module (they were doing some very weird stuff). If you like the general
> approach, let me know and I can make a merge-proposal.

Please do. I have some specific comments on the patch, though, but let's
deal with them through the merge proposal thing.

--
Soren Hansen
Ubuntu Developer
http://www.ubuntu.com/

Revision history for this message
Данило Шеган (danilo) wrote :

FWIW, MP is up (in case nobody noticed, though LP should have sent an email about it to appropriate group).

Revision history for this message
Arnaud Soyez (weboide) wrote :

This is also broken in 0.12.4 from the daily ppa (https://edge.launchpad.net/~vmbuilder/+archive/daily/+packages) using Ubuntu Lucid.

Revision history for this message
Arnaud Soyez (weboide) wrote :

In 0.12.4.r453 (from the daily ppa), --tmpfs=- works correctly.

Soren Hansen (soren)
Changed in vmbuilder:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vm-builder - 0.12.4+bzr459-0ubuntu1

---------------
vm-builder (0.12.4+bzr459-0ubuntu1) natty; urgency=low

  * debian/patches/*:
    - dropped, all in vmbuilder bzr trunk now
  * new bzr snapshot
    - fixes tmpfs option (lp: #536940)
    - fixes crash in register_options (lp: #580237)
    - fixes version display (lp: #546536)
 -- Michael Vogt <email address hidden> Thu, 02 Dec 2010 11:19:30 +0100

Changed in vm-builder (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in vm-builder (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers