Bundling UEC image with uec-images-provided kernel/ramdisk results in an EMI that fails to boot

Bug #439415 reported by Thierry Carrez on 2009-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Karmic
High
Tim Gardner
vm-builder (Ubuntu)
High
Scott Moser
Karmic
High
Scott Moser

Bug Description

Using UEC 20090929 beta candidate on UEC cloud.
Bundling the amd64 image with local kernel and ramdisk works.
Bundling it with uec-images-published kernel and ramdisk fails (see get-console-output log).

Thierry Carrez (ttx) wrote :
Thierry Carrez (ttx) wrote :

i386 testing:

Bundling the i386 image with local kernel and ramdisk; PASS
Bundling it with uec-images-published kernel and ramdisk: FAIL (same errors in the log)

Thierry Carrez (ttx) on 2009-10-01
Changed in vm-builder (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Scott Moser (smoser)
description: updated
summary: - Bundling UEC image with provided ramdisk results in an EMI that fails to
- boot
+ Bundling UEC image with uec-images-provided kernel/ramdisk results in an
+ EMI that fails to boot
Scott Moser (smoser) wrote :

I'm sure that we can get this fixed. Theres just some thing different in the initramdisk created in the chroot with the -virtual flavour of the kernel and on with the -server flavour on real hardware. It seems more likely to be the -server/-vritual difference to me.

We'll get this fixed soon, but not for beta.

Scott Moser (smoser) wrote :

It appears that the issue here is that -virtual does not include sym53c8xx.ko
 ('kernel/drivers/scsi/sym53c8xx_2/sym53c8xx.ko).

This is the hardware that kvm presents as scsi if booted with such as:

kvm -drive file=file,if=scsi,bus=0,unit=6

Matt Zimmerman (mdz) on 2009-10-01
Changed in vm-builder (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
Tim Gardner (timg-tpi) wrote :

Needs sym53c8xx.ko in debian.master/sub-flavours/virtual.list, will have a build test shortly.

Changed in linux (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → In Progress
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
Matt Zimmerman (mdz) wrote :

Marking vm-builder task invalid, as per comments the only fix needed was in the kernel

Changed in vm-builder (Ubuntu Karmic):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-11.38

---------------
linux (2.6.31-11.38) karmic; urgency=low

  [ Stefan Bader ]

  * [Upstream] acerhdf: Limit modalias matching to supported boards
    - LP: #435958

  [ Tim Gardner ]

  * [Config] Added sata_via to d-i/modules/sata-modules
    - LP: #434827
  * SAUCE: (drop after 2.6.31) Disable iwl-1000 series wireless adapters
    - LP: #439285
  * [Upstream] i915: Fix i2c init message
    - LP: #409361
  * [Config] Add sym53c8xx.ko to virtual sub-flavour
    - LP: #439415

  [ Upstream Kernel Changes ]

  * sched: Disable NEW_FAIR_SLEEPERS for now
    - LP: #436342

  * ACPI video: ignore buggy _BQC
  * ACPI video: work-around BIOS AML bug in _BQC
    - LP: #428910
  * ALSA: hda - Added quirk to enable sound on Toshiba NB200
    - LP: #438318

 -- Tim Gardner <email address hidden> Thu, 01 Oct 2009 13:52:09 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers