RFE: ubuntu-vm-builder should provide option to specify MAC address of new guest

Bug #261702 reported by Tim 'Shaggy' Bielawa on 2008-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vm-builder (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-vm-builder

I feel that u-v-b should provide an option to specify the MAC address of guest machines it builds.

Example usage:

$ sudo ubuntu-vm-builder --mac-address C0:FF:EE:BA:BE:00 --hostname myCoolVM

and once the build process is complete 'myCoolVM' would have the MAC: C0:FF:EE:BA:BE:00

I've implemented a solution in my work place that provides this functionality in hardy through use of simple external scripts but I think it's an essential enough feature to be included in mainstream Ubuntu as well.

Tim 'Shaggy' Bielawa (tbielawa) wrote :

I am working on implementing this in the intrepid release package.

Nick Barcet (nijaba) wrote :

This is already possible to do by way of modifying the templates and using the --template option. Would that be sufficient?

Changed in ubuntu-vm-builder:
importance: Undecided → Wishlist
status: New → Incomplete
Tim 'Shaggy' Bielawa (tbielawa) wrote :

I agree that what you proposed is a working solution. Though that doesn't seem like the best way to implement the functionality. I don't like to make a comment composed entirely of distention. I still strongly feel that it should be available as a command line option. With the new release of vm-builder out for intrepid I'm going to try to follow up on my first post and work on some implementation.

Tim 'Shaggy' Bielawa (tbielawa) wrote :

This was resolved in the related branch https://code.launchpad.net/~tbielawa/vmbuilder/macdefining which got merged in a while ago. Janitor missed it some how?

Bryan McLellan (btm) wrote :

python-vm-builder=0.9-0ubuntu6 from jstrand [1] on jaunty

This appears to work with libvirt using when you specify --mac with --libvirt on the command line.

This doesn't work with libvirt when using --mac with --libvirt and --bridge

When running vmbuilder without --libvirt but with --mac, the resulting run.sh does not have the macaddr option added to -net. Because the --mac option isn't specifically listed under libvirt in the output of 'vmbuilder kvm ubuntu --help', one would expect this to work as well. And of course, libvirt templates only work if you're using libvirt.

Also, there's no mention of --mac in the man page of vmbuilder.

[1] https://code.launchpad.net/~jdstrand/vmbuilder/vmbuilder-jdstrand

Bryan McLellan (btm) on 2009-04-06
Changed in vm-builder (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vm-builder - 0.12.1-0ubuntu1

---------------
vm-builder (0.12.1-0ubuntu1) lucid; urgency=low

  * New upstream, bugfix-only release. (LP: #303882, #523589, #261702,
    #284620, #527240, #527253)
 -- Soren Hansen <email address hidden> Wed, 24 Feb 2010 23:52:03 +0100

Changed in vm-builder (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers