Add ability to build Debian virtual machines

Bug #235562 reported by Brian Murray on 2008-05-28
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
VMBuilder
Undecided
Unassigned
vm-builder (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-vm-builder

It would be useful if it were possible to build Debian virtual machines with ubuntu-vm-builder. This would allow people to easily build a Debian virtual machine for testing upstream releases of packages and verifying whether or not bugs exist in Debian.

Related branches

Kees Cook (kees) wrote :

I could use this too. In fact, a more difficult feature-request would be totally different distro support like Fedora, SuSE, and Gentoo as well.

Changed in ubuntu-vm-builder:
status: New → Confirmed
Nick Barcet (nijaba) wrote :

python-vm-builder now has a plugin mechanism for distribution handling that would allow that. I guess it would now take a DD to spend the bit of time needed to adapt the ubuntu plugin into a debian plugin.

Marking it invalid for ubuntu-vm-builder and reassigning to python-vm-builder

Changed in ubuntu-vm-builder:
status: Confirmed → Invalid
Changed in vm-builder:
status: New → Confirmed
Changed in vmbuilder:
status: New → Confirmed
Nick Barcet (nijaba) on 2008-10-19
Changed in vm-builder:
importance: Undecided → Wishlist
Bernd Zeimetz (bzed) wrote :

Support for Debian/Etch is available in
lp:~bzed/vmbuilder/debian
Lenny/testing/unstable will be added soon.

Changed in vm-builder (Ubuntu):
status: Confirmed → Triaged
Andreas Moog (ampelbein) wrote :

Unsubscribing the sponsors team, there seems nothing to sponsor here.

Eric Hammond (esh) on 2009-09-05
Changed in vmbuilder:
status: Confirmed → Invalid
William King (quentusrex) wrote :

When will this branch be merged into trunk? I would like to see these features in the general release.

Changed in vm-builder (Ubuntu):
assignee: nobody → Ubuntu Server Team (ubuntu-server)
Mathias Gug (mathiaz) on 2009-11-24
Changed in vm-builder (Ubuntu):
assignee: Ubuntu Server Team (ubuntu-server) → Canonical Server Team (canonical-server)
Matt Zimmerman (mdz) on 2009-11-24
Changed in vm-builder (Ubuntu):
assignee: Canonical Server Team (canonical-server) → Soren Hansen (soren)
Gabriel de Perthuis (g2p) wrote :

http://wiki.debian.org/VMBuilder mentions a debian-compatible fork.
It appears well-maintained enough at a glance.

    git clone git://git.debian.org/git/pkg-escience/vmbuilder.git

Soren Hansen (soren) on 2011-03-15
Changed in vm-builder (Ubuntu):
assignee: Soren Hansen (soren) → nobody
Joseph Bisch (josephbisch) wrote :

I have a fork that intends to add Debian guest support. Right now it is only tested with KVM (because that is just what I need). Also I only tested it with Jessie images, so it might not work with every Debian suite as the guest, particularly with older suites.

It serves my purpose of adding support for Debian guest KVM images to gitian-builder. But it would be nice if my changes were upstreamed. I assume that images other than KVM don't currently work for Debian guests in my fork and that the upstream maintainers would probably want all image types to be supported before merging in any of my changes, but I figured it would be good to start a dialog at this point.

Let me know what it would take to upstream these changes.

https://github.com/josephbisch/vmbuilder

Miron Cuperman (devrandom) wrote :

Hi,

I'm the maintainer of the Gitian project (deterministic build system, used by Bitcoin Core and Tor).

This would be useful to us, so that Gitian works with Debian guests.

Serge Hallyn (serge-hallyn) wrote :

Hi,

made a few comments on the github branch. Overall I'm happy to take this into lp:vmbuilder, and put it into the 16.04 package.

We'd need for the author of the commits to sign the contributor agreement.

Joseph Bisch (josephbisch) wrote :

I just tried filling out the contributor agreement (so far I am the sole author of the changes), but I'm not sure what to put for the project contact and it is required. Do I put you, Serge?

Thanks for the comments on GitHub. I'll address them asap and get the changes into bzr.

Quoting Joseph Bisch (<email address hidden>):
> I just tried filling out the contributor agreement (so far I am the sole
> author of the changes), but I'm not sure what to put for the project
> contact and it is required. Do I put you, Serge?

Uh, I'm really not sure. Putting me down sounds right.

Joseph Bisch (josephbisch) wrote :

I added the Debian guest related commits to https://code.launchpad.net/~josephbisch/vmbuilder/debian. I also added Debian Stretch and tested out creating a KVM image of it.

I notice that my full name doesn't show up in the list of revisions like it does for other people. I guess I don't have my local bzr program configured correctly. If it is significant, I can try fixing it.

Serge Hallyn (serge-hallyn) wrote :

Thanks, I've merged this upstream. I may push a new version to xenial in a few days.

Changed in vmbuilder:
status: Invalid → Fix Released
no longer affects: ubuntu-vm-builder (Ubuntu)
Changed in vm-builder (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers