vm-builder doesn't support ppc64el

Bug #1510720 reported by Stewart Smith on 2015-10-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vm-builder (Ubuntu)
Medium
Unassigned

Bug Description

If trying to use a package that relies on python-vm-builder on ppc64el, it will fail as ppc64el is not in the list of valid architectures supported by vm-builder (even though ppc64el is a supported Ubuntu architecture).

Which package are you trying to use?

We could change this for xenial (although a new attempt to drop
vm-builder fromthe archive would serve us better)

Stewart Smith (stewart-ibm) wrote :

Serge Hallyn <email address hidden> writes:
> Which package are you trying to use?

gitian-builder - an attempt to work on repeatable builds for OpenPower
firmware (and having it all run on ppc64el rather than having to cross
compile).

Serge Hallyn (serge-hallyn) wrote :

Ok, I just built a package on power8 switching Architecture:all to any.
I don't see any reason not to push with that change. There are some
other changes in the bzr tree and one I'm still reviewing, I'll upload
to xenial in a bit.

I assume you'll need this SRU'd - which releases do you need this in?

Serge Hallyn (serge-hallyn) wrote :

Quoting Stewart Smith (<email address hidden>):
> Serge Hallyn <email address hidden> writes:
> > Which package are you trying to use?
>
> gitian-builder - an attempt to work on repeatable builds for OpenPower
> firmware (and having it all run on ppc64el rather than having to cross
> compile).

Is there any way you'd be able to use cloud images for this?

We still may be removing vmbuilder from the archive. For 14.04
we'd planned to remove it, but failed to replace adt's use of it
with uvt-kvm in time.

Stewart Smith (stewart-ibm) wrote :

Serge Hallyn <email address hidden> writes:
> Quoting Stewart Smith (<email address hidden>):
>> Serge Hallyn <email address hidden> writes:
>> > Which package are you trying to use?
>>
>> gitian-builder - an attempt to work on repeatable builds for OpenPower
>> firmware (and having it all run on ppc64el rather than having to cross
>> compile).
>
> Is there any way you'd be able to use cloud images for this?

I'd guess so - I'm just following upstream gitian-builder, which I guess
would switch if vmbuilder goes away.

> We still may be removing vmbuilder from the archive. For 14.04
> we'd planned to remove it, but failed to replace adt's use of it
> with uvt-kvm in time.

ok.

Serge Hallyn (serge-hallyn) wrote :

This appears to be fixed now in xenial. I think a simple no-change rebuild in any release will enable it in power8. Please comment here with any release where you do need it.

Changed in vm-builder (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Stewart Smith (stewart-ibm) wrote :

Wily would be great, thanks!

Serge Hallyn (serge-hallyn) wrote :

Actually, it seems that python-vm-builder *is* available in wily on power8.

ubuntu@diamond:~$ apt-cache show python-vm-builder
Package: python-vm-builder
Priority: extra
Section: universe/utils
Installed-Size: 4248
Maintainer: Serge Hallyn <email address hidden>
Architecture: all
Source: vm-builder
Version: 0.12.4+bzr489-0ubuntu2
Depends: python, python:any (>= 2.7.5-5~), python:any (<< 2.8), qemu-kvm | qemu-kvm-extras, debootstrap (>= 1.0.9), parted, kpartx, ubuntu-keyring, python-cheetah, rsync
Recommends: python-libvirt, devscripts
Filename: pool/universe/v/vm-builder/python-vm-builder_0.12.4+bzr489-0ubuntu2_all.deb
Size: 214556
MD5sum: b675dbd5f36bb0589031d6e8607e04ca
SHA1: d4106eab73dd63ee1937c30aa0f053c87e87d823
SHA256: 274344d13d5380634a558f01a7015afc1e5d330e770f9faa0d010db4e6ab920a
Description: VM builder
Description-md5: baa484f24e5291f34fc047e933b4a62c
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers