mozilla-plugin-vlc: symlinks for Firefox are in the wrong place

Bug #99810 reported by Peter Berry on 2007-04-01
40
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
William Grant

Bug Description

Binary package hint: mozilla-plugin-vlc

The mozilla-plugin-vlc binary package installs symlinks in /usr/lib/mozilla-firefox/plugins, but Firefox has lived in /usr/lib/firefox since Breezy. It also installs a broken symlink at /usr/lib/mozilla-firefox/components/vlcintf.xpt to ../../mozilla/components/vlcintf.xpt.

Related branches

Peter Berry (pwberry) on 2007-04-01
description: updated
olive (olivier.fraysse) wrote :

We have to `sudo ln -s /usr/lib/mozilla-firefox/plugins/libvlcplugin.so /usr/lib/firefox/plugins/`

Changed in vlc:
status: New → Confirmed
Christian Wolf (christianwolf) wrote :

The suggested fix works, I confirm this for 7.10 on AMD64.

The bug should be considered high profile as in Germany, the state TV has expanded its online offerings to Open Source users, using VLC for non-Windows-Users, responding to respective demands from Linux users.

Ubuntu however is the only OS/Linux distro where people can still NOT access the online broadcasts and therefore is damaging Ubuntu reputqation here in Germany badly. In short: This bug really sucks and needs urgently to be fixed for Gutsy release. Otherwise, we risk Gutsy being ripped apart in German computer magazine tests in Oktober/November as it fails this test.

http://www.heute.de/
http://www.heute.de/ZDFmediathek/content/9280?inPopup=true

capricorn (ubuntuuser82) wrote :

It isn't working on either amd64 or i386. Wolfchri is right, it definitely should be fixed for the final gutsy release!

Philipp Kern (pkern) wrote :

`mozilla-mplayer' works fine and it's even nicer than the VLC plugin because it actually supports pause. Yeah, you have to select `Windows media player' then but please consider the fact that they still `broadcast' in the bad WMV format.

But granted, this is a bug that ought to be fixed.

description: updated
Changed in vlc:
importance: Undecided → Medium
capricorn (ubuntuuser82) wrote :

> But granted, this is a bug that ought to be fixed.

right, and the fix is so simple. So please do something until the final release. Those people I give ubuntu to won't understand this. Thanks in advance (I think the devs have hard time at the moment with tons of new bugs coming in every day...)

William Grant (wgrant) on 2007-10-06
Changed in vlc:
assignee: nobody → fujitsu
status: Confirmed → In Progress

I've created a .link file that creates the correct symlinks for iceweasel and firefox. To fix the complete packet remove the old "ln -s" from debian/rules.

William Grant (wgrant) wrote :

vlc (0.8.6.release.c-0ubuntu4) gutsy; urgency=low

  * Move firefox plugin into /usr/lib/firefox. (LP: #99810)
  * Don't attempt to install a symlink for firefox to vlcintf.xpt - it doesn't
    exist any more.

 -- William Grant <email address hidden> Sat, 06 Oct 2007 15:54:55 +1000

Changed in vlc:
status: In Progress → Fix Released
Christian Wolf (christianwolf) wrote :

Great! Thank you a lot for fixing this so quickly!

Jorge Suárez de Lis (ys) wrote :

This bug is present again in Ubuntu 8.10, Intrepid Ibex. That fix release was ignored when a later version was merged from Debian :(

Christian Wolf (christianwolf) wrote :

Hello Jorge,

I can not confirm this regression - on my i386 8.10 setup, my reference site for this issue (links above, Grman state TV) is still working fine. I have not yet tested it on amd64, but I do not expect a difference.

Can you provide a link where you encounter the problem so that I can try?

Jorge Suárez de Lis (ys) wrote :

The link is created in a wrong place. Your setup is still working because the link is still there, but take a look at /var/lib/dpkg/info/mozilla-plugin-vlc.list

As said there, thje link is created on /usr/lib/mozilla-firefox/plugins/libvlcplugin.so that it's the wrong place again.

Arturo Casal (berfenger) wrote :

I confirm this, the link is created on /usr/lib/mozilla-firefox/plugins/libvlcplugin.so and that's the wrong place.
At least this bug is reproduced on a clean installation of Intrepid.

Jorge Suárez de Lis (ys) wrote :

The fix should be commited again on intrepid

Changed in vlc:
status: Fix Released → Confirmed
Peter Berry (pwberry) wrote :

On a related note, it seems xine-plugin also installs a symlink in /usr/lib/mozilla-firefox/plugins in Intrepid.

Leo Iannacone (l3on) wrote :

I've changed the vlc-0.9.4/debian/mozilla-plugin-vlc.links file to solve problem.

Take a quick look to the debdiff attached.

Leo.

Luca Falavigna (dktrkranz) wrote :

This still happens with 0.9.8a-1ubuntu1, mind preparing a new debdiff against that version? Thanks!

Leo Iannacone (l3on) wrote :

Sorry for delay... This is the debdiff for the current vlc:

I confirm for Xubuntu Jaunty. So, is this still a simple problem? If so, why isn't a fix released? Isn't that what these trackers are for. : ( Anyway, to those posting the Greek above, what's a manual way to fix for a lay person? How 'bout a tutorial for us idiots, and then I can link to it from a couple sites and help propagate that info to the wider community. : )

Benjamin Drung (bdrung) wrote :

It is fixed in karmic with vlc 1.0.0-1ubuntu1. The plugin is installed to /usr/lib/mozilla/plugins/libvlcplugin.so and links are created in /usr/lib/mozilla-firefox/plugins/ and /usr/lib/xulrunner-addons/plugins/. vlc is listed on about:plugins.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers