vlc crashed with SIGSEGV in __GI___strdup()

Bug #972615 reported by Александр on 2012-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Rémi Denis-Courmont
vlc (Ubuntu)
Medium
Unassigned

Bug Description

crashed

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: vlc-nox 2.0.1-3
Uname: Linux 3.3.0-030300-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Tue Apr 3 19:32:16 2012
ExecutablePath: /usr/bin/vlc
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120126)
ProcCmdline: /usr/bin/vlc video.mp4
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: vlc
Title: vlc crashed with SIGSEGV in strdup()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Александр (sanek7-7) wrote :
Changed in vlc (Ubuntu):
importance: Undecided → Medium
summary: - vlc crashed with SIGSEGV in strdup()
+ vlc crashed with SIGSEGV in __GI___strdup()
tags: removed: need-amd64-retrace
Benjamin Drung (bdrung) on 2012-05-23
description: updated
visibility: private → public
Benjamin Drung (bdrung) on 2012-05-26
Changed in vlc (Ubuntu):
status: New → Triaged
Changed in vlc:
importance: Unknown → Undecided
status: Unknown → New
assignee: nobody → Rémi Denis-Courmont (rdenis)
status: New → Fix Released
milestone: none → 2.0.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.0.2-1

---------------
vlc (2.0.2-1) unstable; urgency=medium

  [ Edward Wang ]
  * New upstream release (Closes: #679625, #664279, LP: #689122, #936488,
    #942126, #971106, #972615, #973051, #987231, #995003, #998538).
    - Fix Ogg Heap buffer overflow. Thanks to Hugo Beauzée-Luyssen
  * Add the crystalhd plugin to the vlc distribution.
  * libcaca_plugin.so now depends on X11 in this release, so it must
    be installed under vlc (versus vlc-nox).

  [ Reinhard Tartler ]
  * Urgency set to medium because a security issue is fixed in this release

  [ Benjamin Drung ]
  * Add new plugins to vlc-nox:
    - crystalhd (Linux amd64 and i386 only)
    - directfb
    - fbosd (Linux only)
    - omxil (Linux only)
  * Add build dependencies for new plugins.
  * Add new symbols to libvlccore5.
  * Switch to debhelper 8.

 -- Benjamin Drung <email address hidden> Sat, 30 Jun 2012 18:39:41 +0200

Changed in vlc (Ubuntu):
status: Triaged → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.