Ubuntu

display power management utilities turn screen off after 10 minutes even when VLC is playing video

Reported by Jerome Suhard on 2012-03-01
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

When watching a video in fullscreen with VLC, every 10 minutes, the screen go off whatever the value is for 'turn off the screen after' in Brightness and Lock.

Intel graphic card is in use.

$ lspci -v |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series] (rev ff) (prog-if ff)

$ xset -q
Keyboard Control:
  auto repeat: on key click percent: 0 LED mask: 00000002
  XKB indicators:
    00: Caps Lock: off 01: Num Lock: on 02: Scroll Lock: off
    03: Compose: off 04: Kana: off 05: Sleep: off
    06: Suspend: off 07: Mute: off 08: Misc: off
    09: Mail: off 10: Charging: off 11: Shift Lock: off
    12: Group 2: off 13: Mouse Keys: off
  auto repeat delay: 500 repeat rate: 33
  auto repeating keys: 00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
  acceleration: 10/10 threshold: 4
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 600 cycle: 600
Colors:
  default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,built-ins
DPMS (Energy Star):
  Standby: 0 Suspend: 0 Off: 0
  DPMS is Enabled
  Monitor is On

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vlc 2.0.0-4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Thu Mar 1 15:40:31 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: vlc
UpgradeStatus: Upgraded to precise on 2012-02-18 (12 days ago)

Jerome Suhard (suhard) wrote :
Jerome Suhard (suhard) wrote :

works for me now at the date of 07/03/2012

Changed in vlc (Ubuntu):
status: New → Invalid
adam (adam-ciganek) wrote :

This happens to me as well. One thing that might or might not be related: I removed gnome-screensaver and xscreensaver, as I'm not using them. Could it be that VLC somehow needs (one of) them to be able to inhibit the power manager?

mp (m-p) wrote :

same problem here!

Changed in vlc (Ubuntu):
status: Invalid → Confirmed
Bryce Harrington (bryce) wrote :

Given that the OP said they're not seeing the issue, and the description from #3 appears to have a different set of reproduction steps, can someone please open a new bug, and list out the exact steps to reproduce on precise or quantal?

Changed in vlc (Ubuntu):
status: Confirmed → Invalid
Changed in vlc (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Invalid
Angel Aguilera (angel-aguilera) wrote :

I have experienced this behaviour under XFCE (it works fine for me on Unity).
I am using Ubuntu 12.10.

The steps to reproduce the bug:

- Open any video with VLC.
- Press "f" to go full screen.
- Wait 10 minutes.
- The screen goes blank.

Glenn Chugg (livefreedead) wrote :

I have the same problem with VLC 2.04 in Kubuntu 12.10, just follow the above steps and add 25 seconds to the 10 minutes for the PC to have registered your not moving the mouse or pressing the keyboard (system will then start idle mode counter).

I used Dragon Player (Built in to Kubuntu) and the bug never occured so the issue lies in the way VLC stops the system sleeping and as it affects XFCE & KDE and has occured in Ubuntu in the past, it is not a missing package that causes it.

I am not sure why this bug has been marked as invalid as it is a confirmed bug without a fix and as it only affects VLC and not other video players it needs to be fixed within VLC's code.

I will continue to use Dragon in the short term, but I do miss VLC.

Moving the mouse within the 10 minutes will restart the 10 minute countdown, this means the bug is within the OS as well as I disabled screen savers & Power manager in attempts to stop this happening, but it still occurs, so really it's both the OS and VLC that need to be checked for residual problems, at the end of the day if VLC works as intended, I really don't care what OS I am using ;)

G9283 (b8732) wrote :

Same problem here.

Ubuntu 12.10
GNome 3.6

Works fine in unity.

Iain MacLeod (imacleod) wrote :

I was also seeing this issue, Kubuntu 12.10 64bit. I changed the screen saver timer settings in System Settings, to 1 minute to test it, and the issue disappeared...

Serhiy Zahoriya (xintx-ua) wrote :

why open another bug if that one already gathered 12 people (==confirmations) ?

Felipe Braga (fbobraga-gmail) wrote :

it's not an Ubuntu or VLC issue: it happens here, on Fedora 19 (Gnome 3.8) - I use:
$ xset -dpms
$ xset s off
... to avoid it

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.