Ubuntu

vlc crashed with SIGSEGV when opening an .m4v file from iTunes

Reported by Corwin Mcknight on 2012-02-19
66
This bug affects 8 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Rémi Denis-Courmont
vlc (Ubuntu)
Medium
Unassigned

Bug Description

File was an encrypted m4v file

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: vlc-nox 2.0.0-1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic 3.2.3
Uname: Linux 3.2.0-14-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 19 12:00:27 2012
ExecutablePath: /usr/bin/vlc
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/bin/vlc
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f630035de51: movdqu (%rdi),%xmm1
 PC (0x7f630035de51) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: vlc
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/vlc/plugins/demux/libmp4_plugin.so
 ?? () from /usr/lib/vlc/plugins/demux/libmp4_plugin.so
 ?? () from /usr/lib/vlc/plugins/demux/libmp4_plugin.so
 ?? () from /usr/lib/vlc/plugins/demux/libmp4_plugin.so
Title: vlc crashed with SIGSEGV
UpgradeStatus: Upgraded to precise on 2012-02-19 (0 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Corwin Mcknight (lioneltabre) wrote :

StacktraceTop:
 drms_init (_p_drms=0x7f62e00255d0, i_type=<optimized out>, p_info=0x7f62e0026778 "\204D\202o\326\377Y\262\256\b\303\025\322\352\066\\Do\226\062\221\267d\261_\332/\246P\364-\vy\026Z\370\227B\301+>\210\202\215zl>9\030\001\241\276P\305G\311T->b/\312\067\357z0\327\252y\377\360\211\263\252\306\001\071T\356\032\245sm\224O\n\312\a0T\374\327\274\030\307s\302\256\064\177\222b\227\060\362\377\317C<\267\314)\004\345\341\032\307\025\330\033u\203\344#\026\263\016\250\177\262hx4k4\345\232\252\205\004\325\211\266?t{\006\002z\347d\377\345\070\275\230%\276\312F\216\340\066\200\324\017\223\061\245\253J\260\\\227\065a\032\241\263\001\362\316\225\362/E\335++\234\327\227\241\337\321\024\021\t\375\315"..., i_len=<optimized out>) at drms.c:335
 MP4_ReadBox_drms (p_stream=0x7f62e00196a8, p_box=0x7f62e0018720) at libmp4.c:2408
 MP4_ReadBox (p_stream=0x7f62e00196a8, p_father=0x7f62e0018480) at libmp4.c:3109
 MP4_ReadBoxContainerRaw (p_container=<optimized out>, p_stream=<optimized out>) at libmp4.c:301
 MP4_ReadBoxContainerRaw (p_stream=0x7f62e00196a8, p_container=0x7f62e0018480) at libmp4.c:288

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Benjamin Drung (bdrung) on 2012-02-26
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Jack Leigh (leighman) wrote :

Did not happen in Oneiric

tags: added: regression-release
Changed in vlc:
assignee: nobody → Rémi Denis-Courmont (rdenis)
milestone: none → 2.0.2
status: New → Fix Released
tags: added: patch-accepted-upstream
Benjamin Drung (bdrung) on 2012-05-12
Changed in vlc (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.0.2-1

---------------
vlc (2.0.2-1) unstable; urgency=medium

  [ Edward Wang ]
  * New upstream release (Closes: #679625, #664279, LP: #689122, #936488,
    #942126, #971106, #972615, #973051, #987231, #995003, #998538).
    - Fix Ogg Heap buffer overflow. Thanks to Hugo Beauzée-Luyssen
  * Add the crystalhd plugin to the vlc distribution.
  * libcaca_plugin.so now depends on X11 in this release, so it must
    be installed under vlc (versus vlc-nox).

  [ Reinhard Tartler ]
  * Urgency set to medium because a security issue is fixed in this release

  [ Benjamin Drung ]
  * Add new plugins to vlc-nox:
    - crystalhd (Linux amd64 and i386 only)
    - directfb
    - fbosd (Linux only)
    - omxil (Linux only)
  * Add build dependencies for new plugins.
  * Add new symbols to libvlccore5.
  * Switch to debhelper 8.

 -- Benjamin Drung <email address hidden> Sat, 30 Jun 2012 18:39:41 +0200

Changed in vlc (Ubuntu):
status: Triaged → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers