Ubuntu

vlc crashed with SIGSEGV in spu_DisplaySubpicture()

Reported by JG on 2012-02-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
Unassigned

Bug Description

This happened while opening a movie. VLC crashed immediately after opening it.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: vlc-nox 1.1.13-1build2
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sat Feb 4 17:13:35 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/vlc
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: vlc video.mkv
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f212e3509ed <spu_DisplaySubpicture+13>: mov 0x30(%rdi),%r12
 PC (0x7f212e3509ed) ok
 source "0x30(%rdi)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%r12" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: vlc
StacktraceTop:
 spu_DisplaySubpicture () from /usr/lib/libvlccore.so.4
 vout_ShowTextAbsolute () from /usr/lib/libvlccore.so.4
 vout_ShowTextRelative () from /usr/lib/libvlccore.so.4
 vout_OSDMessage () from /usr/lib/libvlccore.so.4
 ?? () from /usr/lib/vlc/plugins/control/libhotkeys_plugin.so
Title: vlc crashed with SIGSEGV in spu_DisplaySubpicture()
UpgradeStatus: Upgraded to precise on 2012-01-28 (7 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

JG (jdogzz-g5) wrote :

StacktraceTop:
 spu_DisplaySubpicture (p_spu=0x0, p_subpic=0x7f21243cc1a0) at video_output/vout_subpictures.c:335
 vout_ShowTextAbsolute (p_vout=0x1239840, i_channel=<optimized out>, psz_string=<optimized out>, p_style=0x0, i_flags=<optimized out>, i_hmargin=30, i_vmargin=20, i_start=7962003645, i_stop=7963003645) at video_output/video_text.c:113
 vout_ShowTextRelative (p_vout=<optimized out>, i_channel=<optimized out>, psz_string=<optimized out>, p_style=<optimized out>, i_flags=<optimized out>, i_hmargin=<optimized out>, i_vmargin=20, i_duration=1000000) at video_output/video_text.c:52
 vout_OSDMessage (p_caller=<optimized out>, i_channel=1, psz_format=0x7f212b604cb7 "Subtitle delay %i ms") at video_output/video_text.c:141
 PutAction (p_intf=0x106e2f0, i_action=49) at hotkeys.c:783

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Benjamin Drung (bdrung) on 2012-02-12
description: updated
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Rémi Denis-Courmont (rdenis) wrote :

This code path does not exist in VLC 2.0 anymore.

Changed in vlc (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers