Ubuntu

Screen goes to sleep when told not to

Reported by Pierre Rudloff on 2011-07-04
52
This bug affects 13 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Won't Fix
High
VLC media player
Unknown
Unknown
Xdg-utils
Fix Released
Medium
gnome-screensaver (Ubuntu)
Undecided
Unassigned
vlc (Ubuntu)
Low
Unassigned
xdg-utils (Ubuntu)
High
Unassigned

Bug Description

I have told VLC to disable the power manager, but my screen still becomes black every 5 minutes.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: vlc 1.1.9-1ubuntu1.2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Mon Jul 4 11:32:46 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Pierre Rudloff (rudloff) wrote :
Rémi Denis-Courmont (rdenis) wrote :

I am looking for a clear technical specification as to how VLC is supposed to inhibit the screensaver. Until then, this is not going to get fixed. See the upstream bug for further discussion.

I would argue this is an xdg-screensaver (xdg-utils) bug anyway.

Changed in vlc (Ubuntu):
status: New → Confirmed
Pierre Rudloff (rudloff) wrote :

Sorry, I forgot to say that I am using Xfce. (I don't know if that changes anything.)

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Rémi Denis-Courmont (rdenis) wrote :

Still waiting for clarification as to what is The One Correct API to suspend the screensaver in Ubuntu and its derivatives... Until then, there will be any resolution from upstream.

James Pursey (jamespursey) wrote :

I encounter this problem in 11.10 using Unity.

Rémi Denis-Courmont (rdenis) wrote :

And still waiting for the requested infos in upstream bug. 5 months and counting.

Th3Pr0ph3t (th3pr0ph3t) wrote :

gnome-screensaver-command --inhibit doesn't work anymore, does VLC depend on this command?

Rémi Denis-Courmont (rdenis) wrote :

VLC currently uses xdg-screensaver (from xdg-utils). At some point, it uses X11 screensaver reset also, but it hit a performance bug in a number of Xorg drivers, so it had to be removed.

I don't know any other FreeDesktop/standard way to inhibit the screensaver and the display blanking.

So my guess is that xdg-utils is buggy in Ubuntu.

Daniel Hahler (blueyed) wrote :

vlc appears to use both "xscreensaver-command -deactivate" and "gnome-screensaver-command --poke".
(Source: modules/misc/inhibit/xscreensaver.c).

Changed in vlc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Daniel Hahler (blueyed) wrote :

The "--poke" option is unknown to gnome-screensaver-command in Oneiric, and xscreensaver-command is not installed.

Daniel Hahler (blueyed) wrote :

From looking at the "strace -f" output for vlc, it appears that xdg-screensaver is being called, but ends with "xscreensaver-command: no screens".
Then gnome-screensaver-command is used next then.

Daniel Hahler (blueyed) wrote :

"--poke" has been removed in gnome-screensaver 2.91.91: "Remove --poke option from the commandline tool (didn't work anyway)"

I assume it broke during the transition to Gnome 3?!

Daniel Hahler (blueyed) wrote :

xdg-utils calls "gnome-screensaver-command --poke", via:
   case "$1" in
          suspend)
          screensaver_suspend_loop gnome-screensaver-command --poke
          result=0
          ;;

Changed in xdg-utils (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in vlc (Ubuntu):
importance: Medium → Low
Daniel Hahler (blueyed) wrote :

There appears to be a fix upstream in xdg-utils already since March:
http://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=666d65cae0f2e66d33ec0dc48c054afbf16c9e3f

affects: gnome-screensaver → xdg-utils
Daniel Hahler (blueyed) wrote :
Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Changed in xdg-utils:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-utils - 1.1.0~rc1-2ubuntu6

---------------
xdg-utils (1.1.0~rc1-2ubuntu6) oneiric; urgency=low

  * Use D-Bus API for GNOME screensaver
    - debian/patches/xdg-screensaver-dbus.patch
    - LP: #805386
 -- Daniel Hahler <email address hidden> Mon, 03 Oct 2011 16:06:10 +0200

Changed in xdg-utils (Ubuntu):
status: Triaged → Fix Released
Daniel Holbach (dholbach) wrote :

It seems like everything that needed sponsoring in this bug was uploaded already, so I'll unsubscribe the sponsors team. Does this still need a separate fix in vlc?

The attachment "xdg-utils_1.1.0~rc1-2ubuntu6.dsc.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Didier Roche (didrocks) wrote :

tested and confirmed that the fix was enough, closing the bug.

Changed in vlc (Ubuntu):
status: Triaged → Invalid

See also bug 497318.

Changed in gnome-screensaver:
importance: Unknown → High
status: Unknown → Confirmed
Changed in vlc:
status: Unknown → New
Changed in vlc:
status: New → Unknown
Forage (forage) wrote :

The issue is also present in my setup:
- Ubuntu 12.10 GNOME remix (x64)
- VLC 2.0.4+git20121117+r431-0~r43~quantal1 (from ppa:videolan/stable-daily)

Changed in gnome-screensaver:
status: Confirmed → Won't Fix
Changed in vlc:
status: Unknown → New
Changed in vlc:
status: New → Unknown
Rémi Denis-Courmont (rdenis) wrote :

The issue should be fixed with GNOME 3.10 according to the VLC bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.