vlc crashed with SIGABRT in raise()

Bug #754497 reported by IKT on 2011-04-08
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Rémi Denis-Courmont
vlc (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: vlc

randomly crashed, I have no idea what to say.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: vlc-nox 1.1.8-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Fri Apr 8 19:36:24 2011
ExecutablePath: /usr/bin/vlc
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: vlc /media/files/backup/7\ Skies\ -\ Caffeine\ (Genix\ Remix).mp4
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: vlc
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 pa_operation_get_state () from /usr/lib/libpulse.so.0
 ?? () from /usr/lib/vlc/plugins/audio_output/libpulse_plugin.so
 module_unneed () from /usr/lib/libvlccore.so.4
Title: vlc crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to natty on 2011-04-01 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

IKT (ikt) wrote :

StacktraceTop:
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 pa_operation_get_state (o=<value optimized out>) at pulse/operation.c:128
 Close (p_this=0x1a1ae80) at pulse.c:360
 module_unneed (p_this=0x1a1ae80, p_module=0x9dacd0) at modules/modules.c:625

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
IKT (ikt) on 2011-04-09
visibility: private → public
Changed in vlc:
assignee: nobody → Rémi Denis-Courmont (rdenis)
status: New → Fix Released
milestone: none → 1.1.10
Changed in vlc (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.1.10-1ubuntu1

---------------
vlc (1.1.10-1ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable, remaining changes:
    - build and install the libx264 plugin

vlc (1.1.10-1) unstable; urgency=high

  [ Benjamin Drung ]
  * New upstream release.
    - Security: Fix XSPF integer overflow (CVE-2011-2194) (LP: #795410)
    - Improve .desktop file:
      - Add smb as supported protocol (Closes: #622879, LP: #737192)
      - add video/webm to supported MIME formats (LP: #769463)
    - Fix libdvdread errors while playing ogg files (Closes: #622935)
    - Support three channels in pulseaudio output plugin (LP: 743478)
    - PulseAudio output re-written due to unstability of the current one
      (LP: #743323)
    - Fix crashes (LP: #754497, #785979)
    - Qt: allow drag and drop of any URL, not just a local file (LP: #664030)
    - Fix libvlcplugin.so: undefined symbol: NPP_Initialize (LP: #722690)
  * Refresh patches.
  * Drop as-needed patch due to autoreconf run.
  * Backport PulseAudio build fix.
  * Add GNOME MIME types for Ogg Vorbis and Ogg Theora (Closes: #629619).
  * Mention potcast support in package description (Closes: #488771).

  [ Reinhard Tartler ]
  * run autoreconf on the buildds
  * Weaken dependencies on libschroedinger
 -- Benjamin Drung <email address hidden> Sat, 11 Jun 2011 19:56:27 +0200

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers