VLC crashed when trying to encode to Theora and FLAC

Bug #73449 reported by OttifantSir on 2006-11-27
10
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Unknown
vlc (Ubuntu)
Low
Unassigned

Bug Description

Was playing with transcoding an MPG file. The codecs are mpgv for video and mpga for audio. (Can`t determine whether it is -1 or -2 as I can`t open my Home Folder at the moment and look at properties, only the Stream and Media Info of VLC) The file is called Heather Brooke - I Deep Throat Hitchiking.mpg.
I downloaded it through Gtk Gnutella and I did not move it from the Complete folder of this program for the transcoding of the file.
I chose Theora for Video with 3027 kb/s sample rate and FLAC with 512 kb/s (or appropriate sample rate. I`m noob) and proceded to stream/save/transcode it to my the folder /home/ottifantsir/VLC-transcoded under the name deephitch.
It started off, being slow, as I suspected, working on a Pentium 300 Mhz, 192 MB RAM, NM2160 [MagicGraph 128XD] graphics with Ubuntu 6.10 Edgy Eft (i386 for machines with less than 192 MB RAM)
I guess I can have superseded the limitations of this computer, but the same settings with the same file when using MP4 codecs for both video and audio worked fine.

Will attach the complete crash file in the next post, as it won`t do so now.

Related branches

OttifantSir (ottifantsir) wrote :

Will uploading the file through Firefox make a difference? It shouln`t take nearly four hours to upload an 8 MB file?

Derk-Jan Hartman (hartman) wrote :
Daniel T Chen (crimsun) on 2006-12-10
Changed in vlc:
importance: Undecided → Low
status: Unconfirmed → Confirmed

Trying to transcode the Gates testimony from wmv. VLC plays the files just fine so it seems to be the encoding it's having trouble with.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in vlc:
status: Confirmed → Incomplete
zcat (zcat) wrote :

I notice in the VLC 'wizzard' it says it's not really suited to transcoding ,more just for capturing network streams. I've been using different tools to encode ogg video so not really bothered any more by vlc's ability or lack thereof..

Would still be nice to get this fixed so I'll fire up VLC on my other box (this one's runing gNewSense now!) and see if there's still a problem with an up to date hardy.

Dimitrios Symeonidis (azimout) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Download full text (4.9 KiB)

2009/2/26 Dimitrios Symeonidis <email address hidden>:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an issue
> for you. Can you try with the latest Ubuntu release? Thanks in advance.
>
> --
> VLC crashed when trying to encode to Theora and FLAC
> https://bugs.launchpad.net/bugs/73449
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Not going to well in Jaunty either; this is an attempt to convert an
FLV (which it has no trouble playing) to ogg theora/vorbis with
otherwise default settings. It seems to get stuck in an endless loop.

zcat@mandela:~$ vlc
VLC media player 0.9.8a Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.8a
Grishenko - (c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure
'--build=x86_64-linux-gnu' '--enable-maintaner-mode'
'--enable-release' '--prefix=/usr' '--enable-libtool'
'--enable-fast-install' '--with-binary-version=1ubuntu3'
'--disable-update-check' '--disable-gnome' '--disable-gtk'
'--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl'
'--enable-esd' '--enable-mad' '--enable-jack' '--enable-pulse'
'--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi'
'--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde'
'--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg'
'--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp'
'--enable-flac' '--disable-skins' '--disable-basic-skins'
'--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex'
'--enable-caca' '--enable-live555' '--enable-libmpeg2'
'--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora'
'--enable-modplug' '--enable-dvdnav' '--enable-gnutls'
'--enable-ffmpeg' '--enable-ncurses' '--enable-smb'
'--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd'
'--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-faad'
'--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings'
'--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca'
'--enable-realrtsp' '--enable-x264' '--enable-alsa' '--enable-dv'
'--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib'
'--enable-dvd' '--without-dvdcss' 'build_alias=x86_64-linux-gnu'
'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g
-O2'
[00000001] main libvlc debug: translation test: code is "C"
[00000397] main interface error: no interface module matched "xosd,none"
[00000397] main interface error: no suitable interface module
[00000001] main libvlc error: interface "xosd,none" initialization failed
[00000001] main libvlc: Running vlc with the default interface. Use
'cvlc' to use vlc without interface.
[00000420] mux_ogg mux: Open
[00000514] vorbis encoder error: CBR mode initialisation failed
[00000411] stream_out_transcode stream out error: cannot find audio
encoder (module:any fourcc:vorb)
[00000411] stream_out_transcode stream out error: cannot create audio chain
[00000512] main packetizer error: cannot create packetizer outpu...

Read more...

Dimitrios Symeonidis (azimout) wrote :

setting back to new...
note that, the proposed upstream ticket is closed since 2006

Changed in vlc:
status: Incomplete → New
Changed in vlc:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.0~rc2-1ubuntu1

---------------
vlc (1.0.0~rc2-1ubuntu1) karmic; urgency=low

  * New upstream version.
  * tighten build-dependencies on libschroedinger-dev, fixes FTBFS.
  * Following bugs have an associated and now closed upstream ticket in
    Launchpad: LP: #281295, #73449, #282567, #117640, #172938, #260918,
    #273685, #275043, #277834, #282394, #290753, #294136, #298925, #304265,
    #309728, #311742, #314038

vlc (1.0.0~rc2-1) experimental; urgency=low

  * New Upstream Release Candidate
    + Closes: #527010, #491441, #508618, #522824
  * Delete patches which were picked from upstream
  * Refresh patches
  * Remove vlc-plugin-esd and vlc-plugin-arts as they have been removed
    by upstream
  * SONAME change for libvlccore
  * Add new symbols for libvlc2
  * Fix static libs compile
  * Use vlc-wrapper manpage from upstream
  * vlc.install: add drawable and screen was renamed x11_screen
  * vlc-nox.install: Add and remove modules added/removed upstream
  * Point out in NEWS the modules renamed or splited
  * Add links to upstream NEWS and co in vlc-nox
  * Version the depedency of libvlcore2 on vlc-data
  * Remove unnecessary "Section:" in debian/control

vlc (0.9.9a-3) unstable; urgency=low

  * Correct typo in 0.9.9a-2 changelog entry
  * Disable more optimization with DEB_BUILD_OPTIONS=noopt
  * Cache the configure test results as we're running configure several
    times
  * Fix building as root
  * Fix the clean target
  * Remove unexistant config options
  * Better check commad line
  * Use all the procs on i386 and amd64
  * Build a version of libvlccore without altivec (Closes: #523035)
  * Fix typo (thanks to Salvatore Bonaccorso)(Closes: #528044)
  * Reword the command line to get full logs in bug/presubj (Closes: #527012)
  * Remove duplicate "extended Settings" entry in context menu
   (Closes: #526603) - thanks to Matt Kraai

 -- Reinhard Tartler <email address hidden> Fri, 05 Jun 2009 12:28:15 +0200

Changed in vlc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.