Fullscreen controller has no background in KDE4

Bug #661020 reported by gordev on 2010-10-15
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

There is no background of main toolbar (panel with playback controls) when plaing fullscreen video in kubuntu and turned on effects.
When effects turned off - backroud is black.

Description: Ubuntu 10.10
Release: 10.10

vlc:
  Установлен: 1.1.4-1ubuntu1
  Кандидат: 1.1.4-1ubuntu1
  Таблица версий:
 *** 1.1.4-1ubuntu1 0
        500 http://ua.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status

Related branches

Rémi Denis-Courmont (rdenis) wrote :

VLC has no control panel to begin with.

Changed in vlc (Ubuntu):
status: New → Invalid
gordev (zaynyatyi) on 2010-10-20
description: updated
Changed in vlc (Ubuntu):
status: Invalid → New
summary: - Control panel has no background in kde4 when plaing video in fullscreen
+ Fullscreen controller has no background in KDE4
Rémi Denis-Courmont (rdenis) wrote :

I cannot reproduce the problem. VLC asks for 80% opacity by default not for full transparency. And it works fine for me (Qt4.6.3 and KDE 4.4.7).

Make sure you have not configured opacity to 0 in the VLC settings.

Changed in vlc (Ubuntu):
status: New → Incomplete
gordev (zaynyatyi) wrote :

Bug appears only on oxygen theme of kde controls. When using bespin, everything is ok.

Peter (peto-milan) wrote :

please can you describe if there is any possibility how to fix this using oxygen?

gordev (zaynyatyi) wrote :

If there is one, i don't know anything about it. I also have no background in other apps when using oxygen, so i totally switched to bespin.

Changed in vlc (Ubuntu):
status: Incomplete → New
Changed in vlc:
status: New → Fix Committed
Changed in vlc:
milestone: none → 1.1.9
Changed in vlc (Ubuntu):
status: New → Confirmed

Bug 686117 (which I filed) has been marked as a duplicate of this bug, but the description here does not mention the chief problem that I have experienced. Specifically, when foreground elements in the fullscreen controller change, they are not "undrawn" from the background. The image https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/686117/+attachment/1757631/+files/vlc.png shows this. As a secondary matter, my desktop environment is not KDE, but rather LXDE.

Is that really the same bug as this?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.1.9-1ubuntu1

---------------
vlc (1.1.9-1ubuntu1) natty; urgency=low

  * Merge from Debian unstable (LP: #760510), remaining changes:
    - build and install the libx264 plugin

vlc (1.1.9-1) unstable; urgency=medium

  * New upstream release.
    - Fix heap corruption in MP4 demuxer (LP: #756368).
    - Fix fullscreen controller has no background in KDE4 (LP: #661020).
  * Refresh patches and drop backported VideoLAN-SA-1103.patch.
  * Adjust the vlc lintian-overrides for the latest lintian version.

vlc (1.1.8-3) unstable; urgency=medium

  * Fix heap corruption in MP4 demuxer
    - VideoLAN-SA-1103
    - Thanks to Rémi Denis-Courmont
  * Set urgency to medium
  * Set policy to 3.9.2 (no change needed)
 -- Benjamin Drung <email address hidden> Thu, 14 Apr 2011 11:51:25 +0200

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Changed in vlc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers