Need ability to extract videos from AVCHD camcorders with metadata

Bug #574870 reported by Kẏra
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Cinecutie
Undecided
Unassigned
Cinelerra
Won't Fix
Undecided
Unassigned
Dmedia
Low
Unassigned
Novacut
Low
Unassigned
OpenShot Video Editor
Wishlist
Unassigned
PiTiVi
Won't Fix
Wishlist
kdenlive (Ubuntu)
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

AVCHD is the standard for high definition video on digital camcorders, and a tool is needed to extract these files while retaining the metadata. Currently, users must copy individual .mts/.m2ts files and combine them together (they are split if larger than 2GB), which does not keep the metadata. Currently, the only tools available are special proprietary tools only available for Mac or Windows.

Revision history for this message
Adam Guthrie (therigu) wrote :

Have you tried VLC?

Revision history for this message
Kẏra (thekyriarchy) wrote :

I'm familiar with VLC but i have no idea how it would be capable of this. AVCHD files are stored on camcorders as video files split into 2GB clips with metadata elsewhere in some complicated folder hierarchy.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

If a software can rip a bluray disc, it should be able to rip the media from an AVCHD camera as well (together with the metadata), since they both use the same format. I'd like to be able to rename the clips to contain the date, since five digits that start from 00000 every time the camera is emptied just doesn't cut it..

Revision history for this message
Kẏra (thekyriarchy) wrote :

Interesting, i'll look into that a bit more. Hopefully if it is indeed capable, it also does so without reencoding the video (so to original video quality is preserved 100%)

summary: - Tool needed to extract AVCHD video files with metadata
+ Need ability to extract videos from AVCHD camcorders with metadata
Revision history for this message
Kẏra (thekyriarchy) wrote :

I just asked in #videolan and apparently vlc isn't able to rip bluray dvds. I was also unable to find anything useful on Google. Can you link me to something about that so i could fiddle with it to see if it would work for an AVCHD camcorder?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Actually, my use case is covered by using this script http://forum.videohelp.com/images/guides/p1953302/canon_analyze_mts.zip . With that I could make a nautilus script which imports and renames the files.

Revision history for this message
Kẏra (thekyriarchy) wrote :

Oh cool, but i'm kind of a newbie, so could you explain how that works and how to use it?

Timo Aaltonen (tjaalton)
Changed in vlc:
status: New → Invalid
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Put that script in $HOME/bin, and the attached nautilus script in .gnome2/nautilus-scripts (make it executable with 'chmod u+x'). Then select a folder where the files are and from the context menu (right button) select the script. It'll move the files to $HOME/Videos (I changed it now to use XDG_VIDEOS_DIR, so that part is untested but should work), and renames them as YYYY-MM-DD_HHMMSS_LENGTHsec.mts. Feel free to change the renaming from the import-avchd script.

Note that this has only been tested on files from my Canon HF200. I'm interested to find out if the metadata parsing works on files from other camcorder vendors.

Revision history for this message
Kẏra (thekyriarchy) wrote :

Does this also combine video files that are split at 2GB?

I just tried your instructions and they didn't appear to do anything. I'm a little confused by "select a folder where the files are"

Here is the directory structure of your camcorder: http://commons.wikimedia.org/wiki/File:AVCHD_actual_file_structure.svg
Mine is a sony so it isn't quite identical, but could the few differences mess it up? Which folder was u supposed to use the script on? I tried all the ones that made sense to

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Check on the terminal if the canon_analyze_mts.pl script says anything on your mts files. I'm not going to hand-hold any further..

And no it doesn't merge files. Don't know if the format allows you to just cat them together like with .ts files.

Revision history for this message
Dave (dentdavi) wrote :

Please make this a high priority as many camcorders are now using this format. I can't get off Windows or Mac until there is a way to import and edit this format with linux.

Changed in ubuntu:
status: New → Invalid
Changed in openshot:
status: New → Triaged
importance: Undecided → Wishlist
Revision history for this message
Olivier Girard (eolinwen) wrote :

Hi all,

>>If a software can rip a bluray disc, it should be able to rip the media from an AVCHD camera as well (together with the metadata), since they both use the same format.

To my knowledges, there are none software under GNU/Linux which can rip a blu-ray disk (without using Wine and derivative GUI).
And more generally, The AVCHD format is not well supported on our system. Saying that, I'm thinking at this problem and another one when you want to create an authoring Blu-ray disk.

I'm wondering me if something could be done to the Kernel side ? =>udev & Cies........ No?
In fact, if the size file was not cutting, it will be more easy for users and ...........developers too.
And the other question which comes is that if his files are not cutting, metadata are they always present ?

 >>Mine is a sony so it isn't quite identical, but could the few differences mess it up? Which folder was u supposed to use the script on? I tried all the ones that made sense to

A good start could be to have a base of all the structure available of all marks Camecorders and like this, see if there are some differences. Another thing could be to have a rush of each structure/camecorders that everybody could use for studying and testing and like this see if something could be implemented.

For sample, I have not (yet) a AVCHD Camecorder (=>I am yet in DV Camecorder) and it will be difficult to implement something if we can even not test them.

We'll study your work and We'll speak soon between us of that and I'll give you more information about this subject soon. So it is the reason what I put it now in our wishlist.

Revision history for this message
Kẏra (thekyriarchy) wrote :

I guess this just needs upstream reporting. Are you willing to do that? Or anyone else?

Revision history for this message
Olivier Girard (eolinwen) wrote : Re: [Openshot.bugs] [Bug 574870] Re: Need ability to extract videos from AVCHD camcorders with metadata

It will be better that you 'll do yourself. Your English is better than
mine,specially when it becomes technical. :-(
By advance, Thanks.

2012/3/28 Danny Piccirillo <email address hidden>

> I guess this just needs upstream reporting. Are you willing to do that?
> Or anyone else?
>
> --
> You received this bug notification because you are a member of OpenShot
> Bugs, which is subscribed to OpenShot Video Editor.
> https://bugs.launchpad.net/bugs/574870
>
> Title:
> Need ability to extract videos from AVCHD camcorders with metadata
>
> Status in Cinecutie Movie Editor:
> New
> Status in Cinelerra: An audio/video authoring tool:
> New
> Status in Dmedia:
> New
> Status in KDE Non-Linear Video Editor:
> New
> Status in Novacut Video Editor:
> New
> Status in OpenShot Video Editor:
> Triaged
> Status in PiTiVi , Non-linear video editor:
> New
> Status in VLC media player:
> Invalid
> Status in Ubuntu:
> Invalid
>
> Bug description:
> AVCHD is the standard for high definition video on digital camcorders,
> and a tool is needed to extract these files while retaining the
> metadata. Currently, users must copy individual .mts/.m2ts files and
> combine them together (they are split if larger than 2GB), which does
> not keep the metadata. Currently, the only tools available are special
> proprietary tools only available for Mac or Windows.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cinecutie/+bug/574870/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~openshot.bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openshot.bugs
> More help : https://help.launchpad.net/ListHelp
>

--
Olivier
Cenwen un elfe sur la banquise/ an elve on the ice
Mon blog perso sur le multimédia, Ubuntu, Linux et OpenShot :
http://linuxevolution.wordpress.com/
Le forum d'Openshot où vous me trouverez : http://openshotusers.com/
http://openshotusers.com/forum/index.php
Nothing is lost until the last second.
The family motto : When we want, we can.
Astuces, Actualités, Logiciels, bref sur tout ce que je ne fais d'articles
dessus Google+ <https://plus.google.com/u/0/111472725110173916234/posts>

Revision history for this message
Kẏra (thekyriarchy) wrote :

I can't seem to get this tracked here-- http://trac.videolan.org/vlmc/ticket/416

Changed in pitivi:
importance: Undecided → Unknown
status: New → Unknown
Revision history for this message
Kẏra (thekyriarchy) wrote :

Huh. Now it works.

Changed in vlc:
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in pitivi:
importance: Unknown → Wishlist
status: Unknown → New
James Raymond (jamesmr)
Changed in novacut:
status: New → Invalid
importance: Undecided → Low
Changed in dmedia:
status: New → Invalid
importance: Undecided → Low
Andy Finch (fincha)
Changed in openshot:
status: Triaged → Won't Fix
Changed in vlc:
status: Unknown → New
Changed in pitivi:
status: New → Incomplete
Changed in pitivi:
status: Incomplete → Won't Fix
Changed in cinelerra-cv:
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
affects: vlc → vlc (Ubuntu)
Changed in vlc (Ubuntu):
importance: Unknown → Undecided
no longer affects: ubuntu
Changed in vlc (Ubuntu):
status: New → Invalid
Changed in cinecutie:
status: New → Invalid
Changed in kdenlive (Ubuntu):
status: New → Confirmed
affects: kdenlive → kdenlive (Ubuntu)
Changed in kdenlive (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.