VLC .desktop file lacks of Spanish translations

Bug #534312 reported by Ricardo Pérez López on 2010-03-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
VLC media player
Fix Released
Low
Rémi Denis-Courmont
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

VLC is one of the most popular media player in Ubuntu. However, the /usr/share/applications/vlc.desktop file doesn't have Spanish translations, so VLC name shows untranslated (in English ) in the GNOME Applications main menu.

VLC is in Universe, so we can't translate it using Launchpad. We need to only add the following two lines inside the vlc.desktop file:

Name[es]=Reproductor multimedia VLC
Comment[es]=Lea, capture y emita sus contenidos multimedia

I attach a patch against the /usr/share/applications/vlc.desktop in order to add the above two lines. Please, anyone who have the necessary rights, apply the patch in order to get the VLC menu entry translated.

Thanks in advance.

Related branches

Changed in vlc:
assignee: nobody → Rémi Denis-Courmont (rdenis)
importance: Undecided → Low
status: New → Confirmed
status: Confirmed → Fix Committed
milestone: none → 1.0.6
tags: added: patch
Changed in vlc (Ubuntu):
status: New → Confirmed
tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Emmet Hikory (persia) on 2010-03-21
tags: added: patcb-accepted-upstream
tags: added: patch-accepted-upstream
removed: patcb-accepted-upstream
Nigel Babu (nigelbabu) wrote :

Thank for your patch. I'll work on getting this to a debdiff.

Changed in vlc (Ubuntu):
assignee: nobody → Nigel Babu (nigelbabu)
status: Confirmed → In Progress
Ricardo Pérez López (ricardo) wrote :

Thank you very much, Nigel. Hope it will be released soon.

David Planella (dpm) wrote :

I'm marking the Ubuntu Translations task as invalid, since the change must be done in the package and translations cannot be neither included in language packs nor added through Launchpad Translations.

Even if the patch is added, ideally the translation should be done upstream (if upstream provides the .desktop file, that is)

Changed in ubuntu-translations:
status: New → Invalid
Nigel Babu (nigelbabu) wrote :

Just a status update, fixing this bug is being blocked by another xulrunner bug. I'm trying to fix that along with this too.

Nigel Babu (nigelbabu) wrote :
Benjamin Drung (bdrung) wrote :

Can you give me the for this bug as standalone? I want to commit it into the git repo.

bdrug, for the spanish translation or the xulruner bug?

Benjamin Drung (bdrung) wrote :

translation

My name has nothing to do with "drug" :D

Benjamin Drung (bdrung) on 2010-04-15
Changed in vlc (Ubuntu):
assignee: Nigel Babu (nigelbabu) → nobody
Benjamin Drung (bdrung) on 2010-04-15
Changed in vlc (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.5-2ubuntu3

---------------
vlc (1.0.5-2ubuntu3) lucid; urgency=low

  * debian/patches/527-spanish-desktop.patch: Add Spanish translation,
    thanks Ricardo Pérez López (LP: #534312).
  * Add apport hook to include more vlc dependencies in bug reports;
    thanks to Brian Murray for it (LP: #538719).
  * Drop --sourcedir=debian/tmp from dh_install to install apport hook.
 -- Benjamin Drung <email address hidden> Thu, 15 Apr 2010 12:32:03 +0200

Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released
Changed in vlc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers