Ubuntu

Please support theming the VLC systray icon

Reported by Adam Westerman on 2010-03-02
156
This bug affects 36 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Unknown
ubuntu-mono (Ubuntu)
Wishlist
Unassigned
vlc (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: vlc

With the new monochrome icons, the VLC icon looks misplaced in the upper right part of the gnome-panel, please release a monochrome icon for VLC, so it better fits into the new desktop experience.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: d3c978739687c8ad4172386830d879af
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Tue Mar 2 17:29:28 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
Package: vlc 1.0.5-1ubuntu1
ProcEnviron:
 LANGUAGE=nb_NO.utf8
 PATH=(custom, user)
 LANG=nb_NO.utf8
 SHELL=/bin/bash
SourcePackage: vlc
Uname: Linux 2.6.33-020633-generic x86_64

Adam Westerman (hackedbyusb) wrote :
description: updated
Vish (vish) wrote :

The main problem here is that the tray icon is hardcoded in the player , vlc doesnt use an icon.

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream.
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

affects: human-icon-theme → vlc
Changed in vlc (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Vish (vish) wrote :

Once it is fixed in vlc ,only then can the theme really work on adding a monochrome icon.

Using an icon name of "vlc-panel" would allow the icon to be included in the theme.

Changed in ubuntu-mono (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
JB VideoLAN (jb-videolan) wrote :

I don't believe this is an upstream "bug". It is a upstream "enhancement request".
And unfortunately, I doubt it will be fixed for the version of VLC in Lucid, since upstream is working on 1.1.

Changed in vlc:
importance: Undecided → Wishlist
Vish (vish) wrote :

Setting back to incomplete , since we have to wait for this to be done in vlc first.

Changed in ubuntu-mono (Ubuntu):
status: Triaged → Incomplete
Rémi Denis-Courmont (rdenis) wrote :

As upstream, I really could not care to provide such a useless thing as a monochrome icon. Unless Ubuntu wants to contribute the feature, this is WONTFIX.

Changed in ubuntu-mono (Ubuntu):
status: Incomplete → Invalid
Changed in vlc:
status: New → Won't Fix
Rémi Denis-Courmont (rdenis) wrote :

Someone on Ubuntu side, please update the status to Triaged or Wontfix or whatever.

Hanine HAMZIOUI (hanynowsky) wrote :

Can someone give a shortcut on where VLC indicator icon is hard coded in the source code!? Thanks.
Alternatively, is there any possibility of disabling VLC indicator menu?

Hanine HAMZIOUI (hanynowsky) wrote :

Systray menu indicator can be disabled through interface settings. (Tools / Preferences / Look & Feel).

Rémi Denis-Courmont (rdenis) wrote :

@hanynowsky: MainInterface::createSystray() function in modules/gui/qt4/main_interface.cpp.

vexorian (vexorian) wrote :

Dear upstream reading this. Please, could you interpret this wishlist request not as "Add a monochrome icon" but as "allow to change the status icon" ? I am sure that if it was possible to change it, a choice for a monochrome icon would be available online within seconds.

Benjamin Drung (bdrung) on 2013-04-06
summary: - VLC needs monochrome icon
+ Please support theming the VLC systray icon
Benjamin Drung (bdrung) wrote :

If someone wants to add support theming the VLC systray icon, here is what needs to be done: MainInterface::createSystray() function in modules/gui/qt4/main_interface.cpp should be tweaked to query an icon called "vlc-panel" from the theme. If "vlc-panel" does not exist, "vlc" should be queried (or "vlc-xmas" on some days in the year).

Changed in vlc:
milestone: none → 2.1.0
status: Won't Fix → Fix Released
importance: Wishlist → Unknown
status: Fix Released → Unknown
Changed in vlc:
status: Unknown → Fix Released
Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.1.1-1

---------------
vlc (2.1.1-1) unstable; urgency=low

  * New upstream release.
  * Drop altivec patch (fixed upstream).
  * Remove obsolete conffiles (Closes: #703750).

 -- Benjamin Drung <email address hidden> Mon, 18 Nov 2013 21:46:53 +0100

Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.