Ubuntu

Ubuntu VLC package license violation

Reported by Rémi Denis-Courmont on 2009-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

The VLC binary packages in Ubuntu claim to be licensed under GPL version 2. From /usr/share/doc/*vlc*/copyright:
"On Debian GNU/Linux systems, the complete text of the GNU General
Public License can be found in `/usr/share/common-licenses/GPL-2'."

However, the vlc-nox packages has a linking dependency against libsmbclient, which is under LGPL version 3 (in the version that Ubuntu ships).

Please either drop SaMBa support, or use an old (L)GPLv2 version of libsmbclient or switch the VLC package license to GPLv3. In the later case, you will need to check that there is no (L)GPLv2 only dependencies though.

Related branches

Rémi Denis-Courmont (rdenis) wrote :

This is actually worse. The same vlc-nox package links against a version of taglib which is LGPL v2.1 only.

Hence, I believe the package is not legally redistributable as is in most jurisdiction.

Rémi Denis-Courmont (rdenis) wrote :

I take back the previous comment. LGPLv2.1 is compatible with GPLv3.

Still anyway, the Ubuntu VLC should be licensed under GPLv3, not GPLv2 unless libsmbclient is dropped.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.4-1ubuntu1

---------------
vlc (1.0.4-1ubuntu1) lucid; urgency=low

  * merge from debian. Remaining changes:
    - build and install the libx264 plugin
    - add Xb-Npp header to vlc package

vlc (1.0.4-1) unstable; urgency=low

  * New upstream release
    + According to upstream, no longer overlaps kde and xfce panels in
      fullscreen mode, Closes: #562601, LP: #453173

  [ Christophe Mutricy ]
  * libavutil50 seems to be troublesome. Add it to bugs/control
  * Add a vlc-plugin-svg package (Closes: #560009)
  * Switch to xulrunner-dev (Closes: #555915)
  * Activate the global hotkey module (Closes: #548916)
  * Mention other maintainers and that the binaries are GPL v3 as we
    link with LGPL v3 libraries (LP: #489093)
  * Build-depend on a recent enough live555 to avoid comma vs. decimal
    point problem (Closes: #539946)

  [ Benjamin Drung ]
  * Recommend vlc-plugin-pulse for vlc, so that pulse can be used as
    default output.

  [ Whoopie ]
  * Enable CDDB in the CDDA module (LP: #439131)
  * Enable DV support (LP: #392115)

  [ Benjamin Drung ]
  * Fix typos, that are reported by lintian.
  * Sort confflags in debian/rules
  * Split normal configure flags from feature configure flags
 -- Reinhard Tartler <email address hidden> Wed, 30 Dec 2009 18:23:36 +0100

Changed in vlc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers