WVP2 Video/Image Codec not supported by gstreamer plugins or ffmpeg

Bug #488948 reported by komputes on 2009-11-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
Invalid
Wishlist
Unassigned
gst-plugins-bad
Unknown
Wishlist
ffmpeg (Ubuntu)
Wishlist
Unassigned
gstreamer0.10-ffmpeg (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

WVP2 Video/Image Codec not supported by gstreamer plugins or ffmpeg. Windows Media Video 9.1 Image V2 is a DMO-based codec. Optimized for encoding video from sequential bitmap images. Used, for instance, by Photo Story.

There is no codec pack or application that is able to view these files.

Also see (similar bug, different codec):
Online media streams that use WMA2 WMAS audio codec do not play - Bug #418984

$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

$ dpkg -l vlc totem gstreamer0.10-ffmpeg
||/ Name Version Description
+++-===================================-===================================-======================================================================================
ii gstreamer0.10-ffmpeg 0.10.9-1 FFmpeg plugin for GStreamer
ii totem 2.28.2-0ubuntu3 A simple media player for the GNOME desktop based on GStreamer
ii vlc 1.0.3-1~ppa1 multimedia player and streamer

Linux karmic 2.6.31-12-generic #41-Ubuntu SMP Wed Oct 7 18:42:46 UTC 2009 i686 GNU/Linux

Example Media: http://d.yimg.com/kq/groups/15523565/1322781786/name/TeaPartyCommercial.wmv

Alex Wardle (awardle) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Are you asking for WVP2 to be supported by gstreamer?

Changed in vlc (Ubuntu):
status: New → Incomplete
komputes (komputes) on 2009-11-27
description: updated
komputes (komputes) wrote :

Hello Alex, and thank you for taking a look at this bug.

I am in fact asking for WVP2, WMA2 & WMAS to be supported by gstreamer and ffmpeg. If this is not possible due to legal issues or other roadblocks, please definewhat the issue is with supporting these codecs.

This bug is only for WVP2
The request for WMA2 & WMAS support can be found on Bug #418984

Cheers!

Changed in vlc (Ubuntu):
status: Incomplete → New
komputes (komputes) on 2009-11-27
description: updated
Alex Wardle (awardle) on 2009-11-27
Changed in totem (Ubuntu):
status: New → Invalid
Alex Wardle (awardle) wrote :

Please could you report this to https://bugs.freedesktop.org/ because this is where gstreamer bugs are handled. Once again thank you for reporting this bug.

Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Confirmed
komputes (komputes) wrote :

Hello Alex, and thank you for triaging this bug.
I have reported the bug upstream for both codecs.
http://bugs.freedesktop.org/show_bug.cgi?id=25323

Changed in vlc:
status: Unknown → Confirmed
Changed in vlc:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Won't Fix
status: Won't Fix → Confirmed
komputes (komputes) wrote :

Alex, just FYI, I think freedesktop.org was not the correct place to report gstreamer bugs upstream.

The site says: gstreamer: This product is ONLY for account requests for GStreamer. Any bug report on GStreamer should go to http://bugzilla.gnome.org/ Streaming Multimedia framework.

The developer who replied to the bug said:
------- Comment #1 From Thomas Vander Stichele 2009-11-28 01:29:53 PST [reply] -------
This is the freedesktop bugzilla, not the GStreamer bugzilla.
Please go to http://bugzilla.gnome.org and file there.

komputes (komputes) wrote :

Upstream bug report corrected. Reported upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=603283

tags: added: codec
komputes (komputes) wrote :

Alex, to confuse people even more, Launchpad has https://core.fluendo.com/gstreamer/trac/ registered as the upstream for these bugs. I will start a thead on the mailing list that will hopefully clear this up.

Changed in ffmpeg (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in vlc (Ubuntu):
status: New → Invalid
llogan (loul) wrote :

WVP2 decoding is not yet supported by current FFmpeg:

Issue 485: Can't play an WMV file with 4CC: WVP2
https://roundup.ffmpeg.org/roundup/ffmpeg/issue485

llogan (loul) on 2010-01-10
Changed in ffmpeg (Ubuntu):
status: Confirmed → Invalid
komputes (komputes) wrote :

Hi LouL, If this is not possible for FFmpeg to support this codec, please define the issue or roadblock to achieving this (manpower, code, legal, other roadbloack?). Looking at the upstream bug tracker I do not see an adequate answer to why this codec is unsupported.

llogan (loul) wrote :

WVP2 is not currently supported by FFmpeg because nobody has reversed engineered this proprietary codec yet, so if I were to pick one of your choices: manpower. I marked this as "Invalid" because being unable to decode WVP2 is the current normal behavior of FFmpeg.

Changed in vlc:
assignee: nobody → bonethugz (paulo-de-carvalho)
Changed in vlc:
importance: Undecided → Wishlist
Changed in gst-plugins-bad:
importance: Unknown → Wishlist
Changed in vlc:
status: Confirmed → Invalid
assignee: bonethugz (paulo-de-carvalho) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.