Ubuntu

vlc crashed with SIGSEGV in QAccessible::updateAccessibility()

Reported by dust on 2009-10-31
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Rémi Denis-Courmont
vlc (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: vlc

stuttering playback and then it crashed

ProblemType: Crash
Architecture: i386
Date: Sat Oct 31 12:06:55 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/vlc
Package: vlc-nox 1.0.2-1ubuntu2
ProcCmdline: vlc /home/hostname/downloads/215166_Meridian_fetish_4.flv
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x3ec3330 <_ZN11QAccessible19updateAccessibilityEP7QObjectiNS_5EventE+96>: mov (%eax),%eax
 PC (0x03ec3330) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: vlc
StacktraceTop:
 QAccessible::updateAccessibility(QObject*, int, QAccessible::Event) () from /usr/lib/libQtGui.so.4
 QAbstractSlider::setValue(int) ()
 InputSlider::setPosition(float, int, int) ()
 InputSlider::qt_metacall(QMetaObject::Call, int, void**) ()
 QMetaObject::activate(QObject*, int, int, void**) ()
Title: vlc crashed with SIGSEGV in QAccessible::updateAccessibility()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

dust (hannes-b) wrote :

StacktraceTop:QAccessible::updateAccessibility (o=0x8a78c80, who=0,
QAbstractSlider::setValue (this=0x8a78c80, value=6)
InputSlider::setPosition (this=0x8a78c80,
InputSlider::qt_metacall (this=0x8a78c80,
QMetaObject::activate (sender=0x8a61200,

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Rémi Denis-Courmont (rdenis) wrote :

Xlib error handling bug. This should be fixed in VLC 1.1.x.

visibility: private → public
Changed in vlc (Ubuntu):
status: New → Confirmed
Changed in vlc:
status: New → Fix Committed
milestone: none → 1.1.0
assignee: nobody → Rémi Denis-Courmont (rdenis)
dust (hannes-b) wrote :

hope they give you once a vlc t-shirt for free. ;)

Changed in vlc:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package vlc - 1.1.0-1ubuntu1

---------------
vlc (1.1.0-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - build and install the libx264 plugin
    - add Xb-Npp header to vlc package
    - Add apport hook to include more vlc dependencies in bug reports
  * Drop xulrunner patches.
  * Drop 502_xulrunner_191.diff.

vlc (1.1.0-1) unstable; urgency=low

  [ Christophe Mutricy ]
  * New upstream version 1.1.0 (Closes: #586760, LP: #597108)
    * Fixes many bugs (Closes: #572151, #578917, #526088, #572914, #503377;
      LP: #206152, #261001, #281478, #282215, #282966, #283379, #283855,
      #285681, #287263, #328064, #328861, #346631, #356006, #356908, #357595,
      #358461, #362793, #368599, #375854, #380077, #383443, #403135, #403657,
      #403802, #414069, #415396, #416294, #419915, #422797, #425975, #427247,
      #435225, #439271, #442038, #444795, #453928, #459515, #461443, #465687,
      #466418, #476478, #482440, #491151, #491601, #514915, #517329, #517496,
      #537627, #539406, #542293, #549029, #549902, #550468, #550485, #550599,
      #551482, #553503, #554277, #556440, #560167, #564964, #566347, #568750,
      #570666, #582785, #584009, #586692, #587528)
    * SONAME changes
    * Update symbols files
    * Refresh patches and remove the ones merged upstream
  * rules:
    * Disable projectm and sqlite
    * Upstream Makefile install icons at the good place, simplify debian/rules
    * Specify where to install solids files
    * Install the optim only if present
    * Make sure we have useful build log
  * *.install: reflect new modules path and add new files
  * Add a trigger to generate the modules' cache as root.
  * Update the doc which get installed
  * control:
    * Prefer a recent libdvbpsi
    * add lua5.1 to have luac
    * Add more build-dep: xcb*, dirac, dc1394
  * Patch to allow compilation with xul 1.9.1
  * Remove unneeded -V for dh_makeshlibs
  * Use configure option instead of patching
  * Use dh_bugfiles and update the bug control file
  * Don't advertise deprecated package in vlc's manpage
  * Add some news about lua and zvbi
  * Move the luahttp's .hosts to /etc/vlc

  [ Benjamin Drung ]
  * Switch to dpkg-source 3.0 (quilt) format.
  * Disable portaudio module.
  * Update symbols files.
  * Cleanup clean rule and other parts of debian/rules.
  * Remove default values from git-buildpackage config.
  * Change installation of man pages.
  * Remove unused ${shlibs:Depends}.
  * Sort Build-Depends and Depends.
  * Remove unused libhal-dev from Build-Depends (Closes: #580407).
  * Remove unused --enable-release configure flag.
  * Remove unused Build-Depends libid3tag0-dev, libsysfs-dev, and libxv-dev.
  * Provide VBI teletext plugin (Closes: #563873) - thanks to László
    Benedek <email address hidden> for the patch.
  * Enable atmo, fluidsynth (separate package), libproxy (Closes: #532110),
    kate (Closes: #563464), and mtp plugin.
  * Comment disabled features.
  * Explicitly enable or disable features.
  * Vcs-Browser link to summary page.
  * Convert patch header to DEP-3 and add DEP-3 to 502_xulrunner_191.diff.
  * Add myself to Uploaders.
  * ...

Read more...

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers