Ubuntu

Multimedia keys not working by default in vlc

Reported by szczym on 2009-08-27
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: vlc

Vlc is not controlled by multimedia keys found on modern keyboards. All other multimedia players in ubuntu respect the special keys.

Tags: vlc Edit Tag help
Benjamin Drung (bdrung) on 2009-08-27
Changed in vlc (Ubuntu):
importance: Undecided → Wishlist
Annie Mack (lunargirl32) wrote :

I have confirmed this.
Ubuntu 9.04, installed vlc from repositories via synaptic. Multimedia keys work fine in Totem 2.26.1

szczym (szczym) on 2009-08-27
Changed in vlc (Ubuntu):
status: New → Confirmed
szczym (szczym) wrote :

i posted to vlc forums and mailing list, no response...
http://forum.videolan.org/viewtopic.php?f=13&t=64189

any one have idea how to kick it forward ?

szczym (szczym) wrote :

Its called global hotkeys and its feature requested many times for 3 years all ready on vlc forums:
http://forum.videolan.org/viewtopic.php?f=7&t=18350

zorblek (zorblek) wrote :

I have this same problem in Ubuntu Jaunty with VLC 1.01. I even tried manually entering the key code in vlcrc, but it didn't work (it got changed back automatically).

Rémi Denis-Courmont (rdenis) wrote :

VLC supports global hotkeys since 1.0.0. YOu need to configure them in the preferences dialog.

If nothing happens there, it simply means another application uses the same hotkey. You cannot have two applications use the same global hotkeys at a time: this is a design decision in X11.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Jerome Fisher (kingguppy) wrote :

This is not fixed, if only because media keys are not configured by default, as mentioned in the bug title.

Also, you say "If nothing happens there, it simply means another application uses the same hotkey" - the problem is that this "other application" is generally GNOME, which by default captures media keys and broadcasts media key events via dbus. Stopping it from doing so would break other media players that have better GNOME integration. The correct fix, presumably, is to make vlc listen for these media key events via dbus.

Rémi Denis-Courmont (rdenis) wrote :

VLC is not going to implement proprietary GNOME extensions.

Jerome Fisher (kingguppy) wrote :

Nevertheless, "Fix Released" is misleading, surely? Sounds like a "Won't Fix" to me.

Rémi Denis-Courmont (rdenis) wrote :

If you consider the timeline, this bug was filed against some old VLC versions without global hotkeys...

And anyway, I don't have the power to mark bugs as Wontfix.

Jerome Fisher (kingguppy) wrote :

I do see that, but still disagree that global hotkeys are a fix to this bug/feature request - although since neither of us seem able to change the bug status, it's a moot point.

Just to clarify, VLC developers (such as yourself) wouldn't accept a patch to support GNOME's media-keys-via-dbus messages? I do understand the objections to GNOME's approach to introducing things like this - it seems to have been unannounced, undocumented and unstandardised and broke pretty much all applications using media keys - but I'd like to make the best of the current situation.

Rémi Denis-Courmont (rdenis) wrote :

I just doubt it can be patched that easily. Besides, Ubuntu has never make any real VLC development; VLC is not even "supported".

Eric Nemchik (eric-nemchik) wrote :

I know its been a while but has there been any consideration for fixing this? With Linux growing as fast as it is among various platforms like android, and Ubuntu being the (currently) most popular Linux district for home users, it seems a poor decision to cast this issue aside.

Rémi Denis-Courmont (rdenis) wrote :

Nobody proposed a patch upstream. To answer your question, I guess this means 'no'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers