vlc doesn't read DVD

Bug #367323 reported by meuns on 2009-04-26

This bug report was converted into a question: question #77524: vlc doesn't read DVD.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

vlc doesn't read DVD. However it reads iso, avi, mp3...

Printed error message (in French sorry):

Votre média d'entrée ne peut être ouvert:
VLC ne peut pas ouvrir « dvd:///dev/sr0 ». Vérifiez les messages pour plus de détails.

I use Ubuntu 9.04 amd64 and vlc 0.9.9a-2ubuntu1.

++

Isak Frants (isakfrants) wrote :

My VLC plays just fine.

Maybe your DVD device is not /dev/sr0 but instead /dev/cdrom0 or similar.
Try to explore the DVD and drag and drop VIDEO_TS onto VLC. Does it play?

meuns (sylvainmeunier26) wrote :

No, it changes nothing.

I try with vlc 0.9.8a under windows and it plays.

Isak Frants (isakfrants) wrote :

Did you get the same message or didn't anything just happen when dropping VIDEO_TS onto VLC?
Does it play in Totem? Explore DVD and click play with totem.

meuns (sylvainmeunier26) wrote :

For totem (in French again) :

Une erreur est survenue
Impossible d'ouvrir l'emplacement ; vous n'avez peut-être pas la permission d'ouvrir le fichier.

For VLC dropping VIDEO_TS :

La lecture du fichier a échoué :
VLC n'a pas pu lire le fichier
La lecture du fichier a échoué :
VLC n'a pas pu lire le fichier
La lecture du fichier a échoué :
VLC n'a pas pu lire le fichier
La lecture du fichier a échoué :
VLC n'a pas pu lire le fichier
La lecture du fichier a échoué :
VLC n'a pas pu lire le fichier

Then VLC crashes.

Isak Frants (isakfrants) wrote :

Are you still affected by this issue?

If you are, and you upgrade through https://launchpad.net/~c-korn/+archive/vlc to latest 1.0.0 version. Do you still have this issue?

meuns (sylvainmeunier26) wrote :

Now, it seems ok.

Isak Frants (isakfrants) wrote :

Great. Did it work with VLC version 0.9.9a-2ubuntu1 or with VLC 1.0 from the PPA ?

meuns (sylvainmeunier26) wrote :

It works with VLC 1.0 from the PPA.

Isak Frants (isakfrants) wrote :

Since VLC 0.9.8a worked in Windows, but version 0.9.9a did not work in Ubuntu while 1.0 did, I guess maybe playing around with settings would have made the 0.9.9a work as well in Ubuntu. Closed.

Changed in vlc (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions