vlc crashes in jaunty with segmentation fault when changing songs on playlists

Bug #365638 reported by thebestofall007 on 2009-04-23
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

i just upgraded to jaunty from intrepid and i am having a problem with vlc 0.9.9a crashing with segmentation fault when i am listening to a multi song playlist (like from a .xspf file) when i change to another song. the terminal output is here:

lou@lou-laptop:~$ vlc
VLC media player 0.9.9a Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.9a Grishenko - (c) 1996-2009 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=i486-linux-gnu' '--enable-maintainer-mode' '--enable-release' '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-binary-version=2ubuntu1' '--disable-update-check' '--disable-gnome' '--disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl' '--enable-esd' '--enable-mad' '--enable-jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-faad' '--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca' '--enable-realrtsp' '--disable-dv' '--enable-x264' '--enable-alsa' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=i486-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[00000001] main libvlc debug: translation test: code is "C"
Segmentation fault
lou@lou-laptop:~$

Related branches

thebestofall007 (lou1) wrote :
thebestofall007 (lou1) wrote :

this problem also surfaces when i play dvds. the player will play thru the dvd menu, but when you hit play, vlc crashes.

Marenzio (marenzio) wrote :

i've got the same issue even listening mp3s. if i press pause on the context menu in the systray vlc crashes with a "Segmentation fault"

dozerl (bpowell29a) wrote :

I can confirm this. VLC crashes when playing the next song/video in a play-list. I'm using version VLC version 0.9.9a Grishenko. This versions gives an error of "illegal instruction." I then tried VLC version 1.0.0-pre1 Goldeneye compiled from nightly builds my self. This time I get the "Segmentation fault."

kit (kitrule) wrote :
bobloblian (bob-computerisms) wrote :

I can confirm this bug as well.
Pressing the stop button while playing any media causes a segmentation fault.
Playing a DVD movie will cause the segmentation fault either at the beginning of the menu or immediately after the menu, depending on the DVD.
When started from the command line and told to play mp3/avi/mpeg/etc.., output as follows:
VLC media player 0.9.9a Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.9a Grishenko - (c) 1996-2009 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=x86_64-linux-gnu' '--enable-maintainer-mode' '--enable-release' '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-binary-version=2ubuntu1' '--disable-update-check' '--disable-gnome' '--disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl' '--enable-esd' '--enable-mad' '--enable-jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-faad' '--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca' '--enable-realrtsp' '--disable-dv' '--enable-x264' '--enable-alsa' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
Segmentation fault

playing dvd results in similar output, however, it lists trying the various keys it needs.

The catalyst to this issue was upgrading from 8.10 to 9.04.
I tried installing libavutil49 and libavcodec52 as suggested about the possible solution. this un-installed the stripped versions, as mentioned, but did not solve the problem.
Also tried purging and re-installing vlc.
I am attaching the output of 'strace vlc', I don't find anything helpful in there, but hopefully someone else might.

Alejandro Vidal (mancvso) wrote :

for me, worked installing vlc-pulse and updating libvlc2 from

https://launchpad.net/~c-korn/+archive/vlc

now, i'm happy.

bobloblian (bob-computerisms) wrote :

I didn't find a package called vlc-pulse, but I did find a package called vlc-plugin-pulse, installing that and libvlc2 and all the stuff that came with it seems (at first testing) to have worked...
Thank you much for figuring and posting :)

bobloblian (bob-computerisms) wrote :

For the next person reading this post, in case it helps:
After the first disc, I had problems again, but switching the video output to opengl fixed it. Since then, I have twice had to go and change it from opengl to something else, and back to opengl again to successfully play dvds.

The problem could be related to pulseaudio. I noticed that removing the pulseaudio package and installing esound resolved this issue for me.

Chuck Smith (smith.chuck) wrote :

Confirming that I've experienced this bug and that installing the package vlc-plugin-pulse has resolved the issue in evidently all media contexts (e.g., DVD, audio files, video files) where it was segfaulting before. Whooo thanks Launchpad! :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.1-1ubuntu1

---------------
vlc (1.0.1-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable (LP: #406602, #407570), remaining changes:
    - build against xulrunner-dev instead of iceape-dev
    - build against libass-dev and libx264-dev
    - build against and install libx264 plugin
    - add Xb-Npp header to vlc package

vlc (1.0.1-1) unstable; urgency=low

  * New upstream bugfix version
    + Fix interger underflow in Real RTSP (DZC-2009-001, CVE pending)
    + Fix crashes in xspf files handler (LP: #365638)

  [ Reinhard Tartler ]
  * Add versioned build dependency on libschroedinger-dev

  [ Christophe Mutricy ]
  * Really build altivec-free libvlccore (Closes: #523035)
  * Depends on libdvbpsi5-dev and protect against future renaming of
    libdvbpsi development package
  * Remove patches applied upstream

 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden> Sat, 01 Aug 2009 05:54:24 +0300

Changed in vlc (Ubuntu):
status: New → Fix Released
Tampoffel (tampoffel) wrote :

I don't want to be rude, but i had the same problem in 1.0.2 (okay, not from the ubuntu repo's). The vlc-plugin-pulse fix still applied.

Benjamin Drung (bdrung) wrote :

Can you test it with the version in Ubuntu?

Tampoffel (tampoffel) wrote :

Absolutely, because i was in error, the bug was still there. I now have 0.9.9a-2ubuntu1 installed, including the pulse-lib, but it still crashes when it jumps to the next playlist-item. In terminal it just says:"Segmentation fault" and it's gone.

Tampoffel (tampoffel) wrote :

Oh, and it did work before, it happened after i installed(compiled) video-editing software like cinderella and kdenlive, i blame them for this.

Tampoffel (tampoffel) wrote :

Oosp, i had the wrong pulse thing installed, it now seems stable.

Tampoffel (tampoffel) wrote :

I'm at a loss, now it randomly happens, even with streams i listen:
tampoffel@tampoffel:~$ vlc
VLC media player 0.9.9a Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.9a Grishenko - (c) 1996-2009 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=x86_64-linux-gnu' '--enable-maintainer-mode' '--enable-release' '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-binary-version=2ubuntu1' '--disable-update-check' '--disable-gnome' '--disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl' '--enable-esd' '--enable-mad' '--enable-jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-faad' '--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca' '--enable-realrtsp' '--disable-dv' '--enable-x264' '--enable-alsa' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00000449] access_http access: Raw-audio server found, mp3 demuxer selected
Segmentation fault
tampoffel@tampoffel:~$

Tampoffel (tampoffel) wrote :

Upgraded again, bug still there. The vlc-plugin-pulse is also conflicting with sound in the webbrowser's flashplayer so it seems.

On Thu, Oct 1, 2009 at 10:42 AM, Tampoffel <email address hidden> wrote:
> Upgraded again, bug still there. The vlc-plugin-pulse is also
> conflicting with sound in the webbrowser's flashplayer so it seems.

That's the flashplayer's fault, not VLC's (if using pulse) nor pulse's.

Tampoffel (tampoffel) wrote :

Yes, off course, but i thought it would be helpful for someone applying this patch.
And thanks for so subtly pointing out my email-address was in danger of being spammed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers