crash when trying to watch matroska encoded videofiles

Bug #29644 reported by Stephan Ruegamer on 2006-01-25
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
MOTU Media Team

Bug Description

With dappers version (I only tested dappers version) watching matroska encoded videofiles (*.mkv) is not possible.

It crashes with:

VLC media player 0.8.4 Janus
*** glibc detected *** free(): invalid pointer: 0x084eac88 ***
Aborted

I'll attach a backtrace just now

Stephan Ruegamer (sadig) wrote :

Backtrace:

[New Thread -1296659536 (LWP 8439)]
*** glibc detected *** free(): invalid pointer: 0x08783760 ***

Program received signal SIGABRT, Aborted.
[Switching to Thread -1296659536 (LWP 8439)]
0xffffe410 in __kernel_vsyscall ()
(gdb) backtrace
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7d0d9a1 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7d0f2b9 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0xb7d4187a in __fsetlocking () from /lib/tls/i686/cmov/libc.so.6
#4 0xb7d47fd4 in malloc_usable_size () from /lib/tls/i686/cmov/libc.so.6
#5 0xb7d4834a in free () from /lib/tls/i686/cmov/libc.so.6
#6 0xb73608b1 in operator delete () from /usr/lib/libstdc++.so.6
#7 0xb5efdee5 in libebml::EbmlMaster::~EbmlMaster () from /usr/lib/vlc/demux/libmkv_plugin.so
#8 0xb5efc681 in libebml::EbmlHead::~EbmlHead () from /usr/lib/vlc/demux/libmkv_plugin.so
#9 0xb5eabb3c in demux_sys_t::AnalyseAllSegmentsFound () from /usr/lib/vlc/demux/libmkv_plugin.so
#10 0xb5eb0259 in demux_sys_t::PreloadLinked () from /usr/lib/vlc/demux/libmkv_plugin.so
#11 0x08087478 in ?? ()
#12 0x0872fdf8 in ?? ()
#13 0x00000003 in ?? ()
#14 0x0815ca93 in _IO_stdin_used ()
#15 0x0816e814 in _IO_stdin_used ()
#16 0x0815dd03 in _IO_stdin_used ()
#17 0x00000028 in ?? ()
#18 0x0816e4d8 in _IO_stdin_used ()
#19 0x086e4690 in ?? ()
#20 0x00000008 in ?? ()
#21 0x0872e880 in ?? ()
#22 0xb2b68108 in ?? ()
#23 0xb7d4f006 in strdup () from /lib/tls/i686/cmov/libc.so.6
Previous frame inner to this frame (corrupt stack?)

Changed in vlc:
assignee: nobody → motu
Daniel T Chen (crimsun) on 2006-03-21
Changed in vlc:
assignee: motu → motumedia
Daniel Robitaille (robitaille) wrote :

I get the same error in the latest Dapper, with a very similar backtrace.

Changed in vlc:
status: Unconfirmed → Confirmed
Reinhard Tartler (siretart) wrote :

could you please provide a sample video for testing?

Daniel Robitaille (robitaille) wrote :

The one I tried was this one:
http://www.bunkus.org/videotools/mkvtoolnix/samples/vsshort-aac.mkv

That directory on that web site contains a very sample mkv files

Daniel T Chen (crimsun) wrote :

I've temporarily placed test packages for dapper/i386 at http://sh.nu/~crimsun/vlc/ ; please verify that they fix your mkv crashes.

Daniel Robitaille (robitaille) wrote :

The crash on that mkv file still occured after I upgraded to your test packages. The only 3 packages installed on my laptop that had upgrade available in your test directory were:

vlc_0.8.4.debian-1ubuntu6_i386.deb
vlc-plugin-alsa_0.8.4.debian-1ubuntu6_i386.deb
wxvlc_0.8.4.debian-1ubuntu6_i386.deb

Daniel T Chen (crimsun) wrote :

Thanks for testing. Is the crash with mkvs reproducible with the debs here [0]?

[0] http://nightlies.videolan.org/build/breezy-i386/vlc/

Changed in vlc:
status: Confirmed → Needs Info
Daniel Robitaille (robitaille) wrote :

They don't install in Dapper:
dpkg: dependency problems prevent configuration of vlc:
 vlc depends on libcdio3; however:
  Package libcdio3 is not installed.
 vlc depends on libdbus-1-1 (>= 0.36.2); however:
  Package libdbus-1-1 is not installed.
 vlc depends on libiso9660-3; however:
  Package libiso9660-3 is not installed.
 vlc depends on libsysfs1; however:
  Package libsysfs1 is not installed.

If you force the install, then it complain at runtime about:
vlc: error while loading shared libraries: libdbus-1.so.1: cannot open shared object file: No such file or directory

Interestingly, they don't install in Breezy either: it needs libgcrypt11 > 1.2.2 while Breezy's version is 1.2.1-3

Terry Callan (tcallan) wrote :

I can confirm that the nightlies version is uninstallable under dapper. However, adding the vlc nightlies repository for breezy:
deb http://nightlies.videolan.org/build/breezy-i386 /
allows installation. (It contains libgcrypt11_1.2.2)
Under breezy this updade removes the problem.

Daniel T Chen (crimsun) on 2006-04-15
Changed in vlc:
status: Needs Info → In Progress
Daniel T Chen (crimsun) wrote :

Can those of you using current Dapper please test the debs at http://nightlies.videolan.org/build/dapper-i386/vlc/0.8.5-test2/ against a mkv file? I've built and tested up through 0.8.5-test4, and they all crash in the mkv demuxer, leading me to believe that one of the libraries we use is outdated and needs an UVFe req.

Daniel Robitaille (robitaille) wrote :

I installed that 0.8.5-test2 version in Dapper (Flight 7), and it still crashes on that vsshort-aac.mkv file (url in a previous comment). The error is:

VLC media player 0.8.5-test2 Janus
*** glibc detected *** free(): invalid pointer: 0x085f2be8 ***
Aborted

Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 23 May 2006 03:42:19 -0400
Source: vlc
Binary: wxvlc vlc-plugin-sdl kvlc vlc-plugin-ggi gvlc vlc-plugin-alsa qvlc vlc-plugin-glide vlc-plugin-esd gnome-vlc mozilla-plugin-vlc vlc vlc-plugin-arts vlc-plugin-svgalib libvlc0-dev
Architecture: source
Version: 0.8.4.debian-1ubuntu6
Distribution: dapper
Urgency: low
Maintainer: Sam Hocevar (Debian packages) <email address hidden>
Changed-By: Daniel T Chen <email address hidden>
Description:
 gnome-vlc - GNOME frontend for VLC (dummy legacy package)
 gvlc - GTK+ frontend for VLC (dummy legacy package)
 kvlc - KDE frontend for VLC (dummy legacy package)
 libvlc0-dev - development files for VLC
 mozilla-plugin-vlc - multimedia plugin for Mozilla based on VLC
 qvlc - Qt frontend for VLC (dummy legacy package)
 vlc - multimedia player for all audio and video formats
 vlc-plugin-alsa - ALSA audio output plugin for VLC
 vlc-plugin-arts - aRts audio output plugin for VLC
 vlc-plugin-esd - Esound audio output plugin for VLC
 vlc-plugin-ggi - GGI video output plugin for VLC
 vlc-plugin-glide - Glide video output plugin for VLC
 vlc-plugin-sdl - SDL video and audio output plugin for VLC
 vlc-plugin-svgalib - SVGAlib video output plugin for VLC
 wxvlc - wxWidgets frontend for VLC
Changes:
 vlc (0.8.4.debian-1ubuntu6) dapper; urgency=low
 .
   "'Time to race', she said, 'Race the downhill'."
 .
   * Add debian/patches/24_prefs_stacking_fix, fixing stacking in
     Preferences dialog. Taken from upstream svn changeset 13795, thanks
     to Bruce Cowan (Closes: Malone #31891).
   * Demote ttf-freefont, ttf-thryomanes to Suggests as the former
     provides bad metrics for Thai. See Debian #362071 for additional
     information.
   * Don't use gcc-snapshot as the compiler. See Debian #361729 for more
     information.
   * Make vlc.desktop HIG-compliant.
   * Rebuild against new libebml-dev and libmatroska-dev, fixing crashes
     with Matroska files (Closes: Malone #29644).
   * Use our own faad2 and x264, fixing garbled graphics (Closes: Malone
     #28539). Please see Debian #365389 if the inclusion of these
     libraries stirs your ire.
Files:
 c4a7389b8e5d6667b8ffc1fb7a5ec890 1947 graphics optional vlc_0.8.4.debian-1ubuntu6.dsc
 94c860811b831e6ec3996a88cd1d49e5 562960 graphics optional vlc_0.8.4.debian-1ubuntu6.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFEcsyde9GwFciKvaMRAtQGAJ9SOBZTgjXcL/telIJa4C++JyfenwCfSjIv
/tg+j46+YoQ61UTq2R3f9QQ=
=FavO
-----END PGP SIGNATURE-----

Changed in vlc:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.