Ubuntu

[feisty] vlc key shortcuts doesnt work

Reported by Digis on 2005-10-02
20
Affects Status Importance Assigned to Milestone
VLC media player
Won't Fix
Unknown
vlc (Ubuntu)
Low
MOTU Media Team
Nominated for Intrepid by Martin Olsson

Bug Description

vlc media player key shortcuts doesnt work in breezy. Then I choose from menu video->fullscreen, then key shortcuts are working.

Changed in vlc:
assignee: nobody → motu
Chris Peterman (kyral) wrote :

I can confirm that shortcut keys only seem to work in Fullscreen .

Chris Peterman (kyral) wrote :

Upstream Fix requested

Clément Stenac (zorglub) wrote :

The bug only happens when the video output is docked in the WX interface (default behaviour, use --no-wx-embed to override).

Atm, no solution has been found for this bug

Daniel T Chen (crimsun) on 2006-03-21
Changed in vlc:
assignee: motu → motumedia
Martin Bergner (martin-bergner) wrote :

Hi, is this still a problem with Dapper/Edgy?

Changed in vlc:
status: Unconfirmed → Needs Info
snafu109 (snafu109) wrote :

Just tried it. Still seems to be a problem; behavior is not as it is in Windows.

Jacob Winski (winski) wrote :

Confirmed as of Oct 17th in Edgy unstable.With vlc --no-wx-embed shortcuts work fine.

vlc --version
VLC media player 0.8.6 Janus
VLC version 0.8.6 Janus
Compiled by <email address hidden>
Compiler: gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu4)

Jacob Winski (winski) wrote :

For those that would like to make --no-wx-embed the default for vlc, start vlc -> settings -> preferences -> expand "Interfaces" -> expand "Main interfaces" -> WxWidgets -> uncheck "Embed video in interface".

Daniel T Chen (crimsun) wrote :

Lowering Importance - known workaround exists.

Changed in vlc:
importance: Medium → Low
status: Needs Info → Confirmed
Mildred (mildred) wrote :

Just after trying --no-wx-embed, I started vlc back with the normal behaviour and the shortcut worked fine ...
In the past I also found that changing some hotkeys settings may resolve tempoarily this problem.

Isriya Paireepairit (markpeak) wrote :

Confirmed on Edgy

Tom Vetterlein (smbm) wrote :

This bug is still present in the Feisty version

Steven Harms (sharms) wrote :

Confirmed on Feisty. The menu shortcuts do work, but shortcuts defined under the "Hotkeys" settings under "Interface" work only occassionally depending on the situation. Full screen default shortcut is "f", but only works if video is already fullscreen.

Fab (fabian-wyss) wrote :

Hi

Same here!

I think this could be fixed by adding the latest version of VLC to the Ubuntu Repositories.

Angelic579 (angelic579) wrote :

I'm experiencing the same thing on Gutsy, with the latest build of VLC.

LimCore (limcore) wrote :

On ubuntu 7.10 amd64

vlc --no-wx-embed work around do not work - it starts with video image just floating around (no way to move it by mouse etc)
and still keys (like arrow keys to skip / seek) do not work.

muzzamo (murray-waters) wrote :

Still occuring on hardy.

upstream bug is https://trac.videolan.org/vlc/ticket/1396 .

I had a conversation with a developer in their IRC channel, they said that this bug is not going to be fixed because no more work is being done on the wxwidgets interface. I then asked why wxwidgets interface is the default, and they said that in the next version of VLC it will not be.

Martin Olsson (mnemo) wrote :

The next VLC version has been in the making for a very long time, I don't see it as particularly likely that this VLC branch will stabilize and ship properly before Inteprid Ibex. And even when it does ship there might be people who wants to stay with the old version for just a little while longer until the odd bugs in the new version in ironed out. All in all, it sounds like a good idea to branch the current stable VLC into a special Ubuntu version which has the modified keys only. On the next release VLC can be synced anyway (not merged) because the new branch will have the keys fixed already. Also, it should be extremely easy to add the most common shortcut keys (like "F" and "SPACE" etc), probably a couple of lines of code at most.

Being able to press "F" and "SPACE" would really contribute to the "polished feel" of my Ubuntu desktop. It's one of the few bugs that I actually run into on a regular basis (the other one being bug #21202 ).

muzzamo (murray-waters) wrote :

@mnemo : if you are going to fix it yourself wouldn't you be better off just fixing it upstream?

I think they still accept patches, its just that they are no longer interested in doing any work on it themselves.

Changed in vlc:
status: New → Unknown
Changed in vlc:
status: Unknown → Won't Fix
JB VideoLAN (jb-videolan) wrote :

This is fixed in Qt interface.

Changed in vlc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.