Ubuntu

[Hardy] skipping sound in vlc

Reported by Jan Frybort on 2008-04-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

Since Hardy installation, I experience skipping sound in VLC every few seconds.

UKLooney (tonydoc) wrote :

I am experiencing the same issue. My on-board sound card is an Intel HDA

Jan Frybort (jan.frybort) wrote :

Mine is also Intel HDA. I was able to somewhat eliminate the issue by setting all the sound outputs to ALSA and by installing VLC ALSA plugin.

UKLooney (tonydoc) wrote :

This seemed to improve things (not perfect though), but once I switch visualizations on, skipping is atrocious. Got an nVidia 8600gts 512m.

Kasey Erickson (kasey-erickson) wrote :

I just installed Hardy today, 64 bit from DVD. I can confirm that skipping is present and it happens regardless of the audio file format or system load. Installing vlc-plugin-alsa doesn't seem to do much (for me) nor does setting all sound outputs to ALSA. I get one noticeable skip every 2-6 seconds.

None of the other players have any problems.

While writing this I've been listening and can't take it any more. Hello totem and mplayer (since totem can't handle m4a).

~/$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

bitsent (bitsent) wrote :

Same here. Totem works fine. I really hate to leave VLC. Ubuntu 8.04 32-bit.

Forcing audio output module of "Pulseaudio audio output" doesn't seem to help. Skips randomly every few seconds on at least .mp3, .wma, .ogg

~/$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

UKLooney (tonydoc) wrote :

Seems to have fixed itself...?

~$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

Nope. Still happens. None of the other players have this issue:
Audacious, banshee, totem or mplayer.

VLC played a movie from DVD just fine the other day though. No skipped audio.

On Mon, Aug 4, 2008 at 2:58 AM, UKLooney <email address hidden> wrote:
> Seems to have fixed itself...?
>
> ~$ lspci |grep -i audio
> 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
>
> --
> [Hardy] skipping sound in vlc
> https://bugs.launchpad.net/bugs/222597
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ghosty (ghosty.be) wrote :

I put everything in the sound panel to alsa, that makes most stuff work (flash was still a bit strange from time to time)
I installed vlc-plugin-alsa (i think without it it still uses) and also put vlc to alsa output (preferences -> select the advanced box -> go to audio - filters and select also output)
Then I was able to kill pulseaudio (sudo pkill pulseaudio), when I started vlc then it does not start pulseaudio anymore and it does not skip ...
Googling a bit furter: some people suggest (see: http://ubuntuforums.org/showthread.php?t=766860&highlight=sound+skips )

If the above worked (the killing pulseaudio improves things), then this next part will allow you to use PulseAudio without annoying skips:

Make a backup and then edit /etc/pulse/daemon.conf, and replace the lines at the end of your config with the following in red:

Code:

; default-sample-format = s16le
default-sample-rate = 48000
; default-sample-channels = 2

default-fragments = 8
default-fragment-size-msec = 10

I just added this to the config but did not test it yet, just letting anyone know about my progress so far ...

Ghosty (ghosty.be) wrote :

Ok after some more testing: I still got problems with pulseaudio, my fix in the end:
-put anything to alsa (everything in your audio settings and also some software like vlc, amarok and probably others needs to be set to alsa
-sudo apt-get remove pulseaudio
-gone are my sound skip problems in vlc and everything still works (just tried vlc, amarok, totem, flash in firefox ...
So my suggestion to Ubuntu all together: get rid of pulseaudio, there are more complaints of pulseaudio then benefits my idea ...

Ghosty (ghosty.be) wrote :

For completeness:
$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Running "sudo apt-get remove pulseaudio" gets me:
"The following packages will be REMOVED:
  pulseaudio ubuntu-desktop"

I don't think I want to remove ubuntu-desktop. How did you remove
pulseaudio without removing ubuntu-desktop?

On Thu, Aug 14, 2008 at 6:21 PM, Ghosty <email address hidden> wrote:
> For completeness:
> $ lspci |grep -i audio
> 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
>
> --
> [Hardy] skipping sound in vlc
> https://bugs.launchpad.net/bugs/222597
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ghosty (ghosty.be) wrote :

lol ubuntu-desktop is just the meta package, removing ubuntu-desktop does nothing ... (it's not like you're going to end up with an empty system)

Magnus S (magnuss) wrote :

Hi all, is this still a problem with latest version in Hardy? Or Intrepid?
//magnus

Changed in vlc:
status: New → Incomplete

Problem is gone in 8.10, 64 bit (vlc version 0.9.4). Tested both mp3
and m4a while compiling a huge pile of code at -j4.

Kasey

On Wed, Nov 26, 2008 at 5:01 AM, Magnus S <email address hidden> wrote:
> Hi all, is this still a problem with latest version in Hardy? Or Intrepid?
> //magnus
>
> ** Changed in: vlc (Ubuntu)
> Status: New => Incomplete
>
> --
> [Hardy] skipping sound in vlc
> https://bugs.launchpad.net/bugs/222597
> You received this bug notification because you are a direct subscriber
> of the bug.
>

bitinerant (bitinerant) wrote :

In my tests (two or three files for each file type), .mp3 and .avi still skip, while .ogg and .wma do not skip. Strange. VLC media player 0.9.4 Grishenko on Ubuntu 8.10 (32bit version).

Magnus S (magnuss) wrote :

Ok...

Please run vlc in verbose mode, run "vlc -v2" in a maximized terminal and reproduce, copy->paste the output to a text file and attach to this report.

Also, play around with the sound output options in preferences, and see if you can isolate the bug to a special output type.

This is probably related to hardware, so please also attach the resulting file from this command:
* sudo lspci -vvnn >> ~/222597_lspci-vvnn.txt

Thanks in advance.
//magnus

Attached lspci output for my system. It should provide a good
baseline (since my system doesn't skip anymore) to compare against
systems that still suffer from skipping.

Kasey

On Mon, Dec 1, 2008 at 2:36 PM, Magnus S <email address hidden> wrote:
> Ok...
>
> Please run vlc in verbose mode, run "vlc -v2" in a maximized terminal
> and reproduce, copy->paste the output to a text file and attach to this
> report.
>
> Also, play around with the sound output options in preferences, and see
> if you can isolate the bug to a special output type.
>
> This is probably related to hardware, so please also attach the resulting file from this command:
> * sudo lspci -vvnn >> ~/222597_lspci-vvnn.txt
>
> Thanks in advance.
> //magnus
>
> --
> [Hardy] skipping sound in vlc
> https://bugs.launchpad.net/bugs/222597
> You received this bug notification because you are a direct subscriber
> of the bug.
>

bitinerant (bitinerant) wrote :

My `sudo lspci -vvnn` is also attached (system where .mp3 and .avi still skip). I'll try to do the other testing soon.

Changed in vlc:
status: Incomplete → New
MyR (myr-jedi) wrote :

I changed the output module in vlc to alsa and now the video skips instead of audio. I must admit, it's slightly less irritating. thanks!

frunze (rbmk1000) wrote :

Setting "Audio Output" to ALSA seems to resolve this problem.

Technical Information:

$ lspci |grep -i audio
02:06.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value

VLC media player 0.8.6e Janus (wxWidgets interface)

Ubuntu 8.04 (LTS) Hardy Heron

Changed in vlc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers