sound chirps and dropouts during playback MP3 shoutcast stream

Bug #209637 reported by Simon IJskes on 2008-03-31
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gst-plugins-base0.10 (Ubuntu)
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Low
Ubuntu Desktop Bugs
vlc (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: vlc

when playing streaming mp3's like:

vlc 'http://www.shoutcast.org/sbin/shoutcast-playlist.pls?rn=333&file=filename.pls'

the sound chirps and dropsout while logging:

mdb:319, lastbuf:257 skiping granule 0
mdb:319, lastbuf:257 skiping granule 0
mdb:470, lastbuf:410 skiping granule 0
bits_left=-1
bits_left=-1
mdb:134, lastbuf:60 skiping granule 0
mdb:134, lastbuf:60 skiping granule 0
mdb:416, lastbuf:392 skiping granule 0
bits_left=-3
mdb:455, lastbuf:431 skiping granule 0

These messages originate from ffmpeg imho.

No problems with audio when playing movies (not shure they use ffmpeg).

gxine 'http://www.shoutcast.org/sbin/shoutcast-playlist.pls?rn=333&file=filename.pls'
also produces same audio.

It looks like the chirps are also visible in the 'visualisation' modes of vlc and totem-gstreamer.

The problem also occurs with libmad.

When a stream is captured with mplayer -streamdump and later the stream is played, the chirps are also present.

When i capture the stream with curl, and play the stream the problem does not occur.

So the most likely cause is the Icy-Metadata in the stream:

http://www.smackfu.com/stuff/programming/shoutcast.html

Very dirty fix:
After manually corrupting the 'Icy-MetaData: 1' string in /usr/bin/mplayer the sound is as expected.

Simon IJskes (sim-nyx) wrote :

on hardy.

Simon IJskes (sim-nyx) wrote :

totem-gstreamer produces same audio, but no logging output.

description: updated
Simon IJskes (sim-nyx) on 2008-03-31
description: updated
Simon IJskes (sim-nyx) on 2008-03-31
description: updated
Simon IJskes (sim-nyx) on 2008-03-31
description: updated
Simon IJskes (sim-nyx) on 2008-03-31
description: updated
Simon IJskes (sim-nyx) on 2008-03-31
description: updated
Simon IJskes (sim-nyx) wrote :

fix available at:

http://linux.qcg.nl/node/45

Nick Demou (ndemou) wrote :

in my case the fix doesn't help vlc (allthough all 3 files are present and contain icy-metadata wich is altered by sed to Xcy-metadata).

I've never had any problem with mplayer or totem-audio-preview (mouse over) or with gst-launch

I came here from bug #223650 which seems as a dupe

Simon IJskes (sim-nyx) wrote :

Nick, are you sure you have a problem with streaming audio? The fix is only for streaming audio, not for playing from disk.

Nick Demou (ndemou) wrote :

Sorry everyone -- this is not my bug, my problem is with mp3's from the disk

Andreas Moog (ampelbein) wrote :

Fixed for totem in Intrepid.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Fix Released
Andreas Moog (ampelbein) wrote :

Fixed with vlc in intrepid.

Changed in vlc:
importance: Undecided → Low
status: New → Fix Released
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in mplayer:
status: New → Incomplete
Andreas Moog (ampelbein) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in mplayer (Ubuntu):
status: Incomplete → Invalid
Changed in gst-plugins-base0.10 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers