[SRU] Update to bugfix release 3.0.2 in Bionic

Bug #1771259 reported by Simon Quigley on 2018-05-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
Unassigned
Bionic
Medium
Simon Quigley

Bug Description

[Impact]

VLC has received a bugfix update on the 3.0.x release path, which was recommended to us by Debian for additional stability in the Long Term Support release.

[Test Case]

Install vlc from bionic-proposed and test it for a decent amount of time. Play different video formats to catch any regressions, and use it as you normally would.

[Regression Potential]

The 3.0.x branch receives only bug fixes, which are cherry-picked from the master branch where the main development takes place. So, I think the regression potential is low.

[Other Info]

Here is the upstream Git repository: http://git.videolan.org/?p=vlc/vlc-3.0.git;a=summary

Changes between 3.0.1 and 3.0.2:
--------------------------------

Core:
 * Fix snapshotting with subtitles when using hardware acceleration
 * Fix green/missing line/column when the picture dimensions are odd

Decoders:
 * Important improvements in hardware decoding for macOS, notably faster,
   supporting more samples and removing crashes/deadlocks
 * Improve compatibility for DxVA2 and D3D11 decoding, fix crashes when seeking
   and fix blacklisting of broken drivers
 * Fix SSA subtitles forced alignment
 * Fix E-AC-3 stuttering
 * Fix MIDI playback on macOS
 * Add playback support for ProRes 4444 XQ

Demux:
 * Fix wrong colors in some AVI files
 * Fix IFO files playback to start DVDs
 * Fix a crash with missing/invalid MPEG SDT
 * Update VP8/9/10 ISOBMFF bindings and improve HDR for those cases
 * Fix TTML inside MP4
 * Improve MP4 read of color information
 * Fix flac seeking and improve flac parsing
 * Improve mkv opening & seeking speed
 * Fix display of chapters with no name defined
 * Miscellaneous MKV crash fixes
 * Fix crash with multi-region DVDs
 * Fix audio being muted on DVD chapter change
 * Fix audio being muted when seeking in a BluRay disc

Access:
 * Avoid a crash/assert in FTP after seeking

Audio output:
 * Fix mmdevice default audio device handling
 * Fix "reset audio volume" being forcefully deactivated
 * Allow a default device to be used by VLC
 * Only warn once about misconfiguration for AUhal devices on macOS
 * Improve resampling and latency computation for CoreAudio
 * Passthrough is now disabled by default

Audio filters:
 * Fix audio stutter after unpausing with headphones
 * Fix silence when dolby-surround was mis-selected in preferences

Video output:
 * Fix OpenGL crashes or bad display with semi-planar chromas
 * Fix OpenGL interop (zero-copy) disabled for tvOS
 * Major rewrite of the iOS video output to fix numerous crashes
 * Important improvements of the D3D11 video output to use less memory
   and less GPU for HDR tone-mapping
 * Fix crop on vertical videos with Direct3D11
 * Fix Direct3D9 filters settings not being applied properly
 * Fix transform filters with hardware decoding
 * Fix snapshot and filters with HEVC hardware decoding
 * Fix a buffer overrun during GPU/CPU image copy
 * Fix glitches on DVD menus with Direct3D11
 * Fix non-HDR content playback on HDR screens with Direct3D11
 * Fix YUV full range displayed incorrectly in Direct3D11
 * Fix miscellaneous crashes in Direct3D11
 * Fix potential black screen with 10bits videos on Direct3D11

macOS:
 * Fix Growl notifications on recent macOS versions
 * Fix conversion output file name encoding
 * Fix crash reporting on macOS 10.7 and 10.8
 * Fix crash on exit
 * Fix remember playback position
 * Fix Blu-ray disc Java menu
 * Fix swiping on time slider to change position
 * Fix problems with restoring user name from keychain
 * Fix localization issues

Qt:
 * Fix last folder used in open dialogs
 * Allow to customize the seek jump when using the mousewheel
 * Fix fullscreen controller positionment on multiscreen setups
 * Fix pasted URLs not being trimmed
 * Fix jump size not being configurable
 * Fix missing time labels updates
 * Fix playback speed slider not accepting 1.0x value
 * Fix raw input dump
 * Fix window size after a fullscreen playback

Misc:
 * Fix lua rc & oldrc interfaces host specification
 * Fix crashes when searching for renderers
 * Relocate localedir for Linux (improves snap i18n support)
 * Fix VDPAU GLX usage on Linux
 * Improve support for NetBSD
 * Fix MSI script for Windows
 * Fix libvlc_media_list not going to next media
 * Fix character encoding on win32 consoles
 * Miscellaneous chromecast improvements
 * Fix missing OSD navigation feedback
 * Various VLSub improvements
 * lua: Fix scripts not being loaded on some filesystems
 * lua: Add vlc.io APIs to handle UTF-8 paths

Simon Quigley (tsimonq2) on 2018-05-15
Changed in vlc (Ubuntu):
importance: Undecided → Medium
Changed in vlc (Ubuntu Bionic):
importance: Undecided → Medium
Changed in vlc (Ubuntu):
status: New → Fix Released
Changed in vlc (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

Attached is the full upstream diff.

Simon Quigley (tsimonq2) wrote :

Uploaded to the Bionic queue.

For packaging changes, I just had to drop the only quilt patch, which was applied upstream. Other than that and running `update-maintainer`, there were no packaging changes.

summary: - [SRU] Update to bug-fix release 3.0.2 in Bionic
+ [SRU] Update to bugfix release 3.0.2 in Bionic

Hello Simon, or anyone else affected,

Accepted vlc into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vlc/3.0.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vlc (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Since this is a new upstream release for an LTS series, I would appreciate if this got some wider testing before getting released into -updates. Some call for testing perhaps to get more people using the -proposed version?

Simon Quigley (tsimonq2) wrote :

Sure, I'd be happy to do that later today.

Darin Miller (darinmiller) wrote :

Limited testing on a local mp4 file and Big Buck Bunny (1080p H264video). Jump speed configurations worked as expected. Playback and time slider moves were very smooth. Minimal CPU usage with all tests.

Sound work without stutter with pause/resume using BT and standard headphones.

Fullscreen/restore window size also worked in QT.

No issues found in short testing completed.

Rik Mills (rikmills) wrote :

I'm not a big user of VLC any more, but a quick run through playing a reasonable sample of media files and playing scenarios (full screen/subs etc) did not flag up any noticeable regressions for me.

Marco Parillo (marco-parillo) wrote :

Enabling Proposed (Pre-released Updates) on Kubuntu 18.04 got me KDE Plasma 5.12.5 as well as VLC 3.0.2, so I re-booted.

I successfully added a Pocast via an RSS link, and played it.

Marco Parillo (marco-parillo) wrote :

I also successfully played from the Jamendo Selections and the Icecast Radio Directory

Simon Quigley (tsimonq2) wrote :

While further testing would be appreciated, the three reports signify that no regressions are apparent.

I can personally confirm that this update works correctly after about an hour of testing different files in a fresh Lubuntu 18.04 VM that is fully updated. So make that four people. :)

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

I think we're good with this one then. Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 3.0.2-0ubuntu0.1

---------------
vlc (3.0.2-0ubuntu0.1) bionic; urgency=medium

  * New upstream bugfix release (LP: #1771259).

 -- Simon Quigley <email address hidden> Mon, 14 May 2018 23:26:56 -0500

Changed in vlc (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vlc has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers