VLC should include upnp support

Bug #172938 reported by Patrik Pira on 2007-11-29
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Unknown
vlc (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Buzz
Nominated for Lucid by Buzz

Bug Description

Binary package hint: vlc

VLC should be compiled with upnp support, --enable-upnp=yes, libupnp2 is in Gutsy universe so should should not be a big problem?

Sven Hoffmeister (schaumkeks) wrote :

This is still an issue in the latest release in hardy. I rebuilt the packages with UPnP support using my PPA to check this feature:

https://launchpad.net/~schaumkeks/+archive

Unfortunately UPnP seems to be broken. Having the Media Server of my FRITZ!Box Fon WLAN 7270 enabled leads to the following debug output with no success:

upnp_intel debug: UPnP discovery started
upnp_intel debug: upnp_intel.cpp:486: DEBUG: UNHANDLED EVENT ( TYPE=7 )

After starting Rhythmbox with DLNA/UPnP plugin enabled I get this debugging output:

upnp_intel debug: Adding server 'Rhythmbox on 127.0.1.1'
upnp_intel debug: upnp_intel.cpp:746: ERROR: UPNP_E_OUTOF_BOUNDS
upnp_intel debug: upnp_intel.cpp:795: ERROR!
upnp_intel debug: upnp_intel.cpp:746: ERROR: UPNP_E_OUTOF_BOUNDS
upnp_intel debug: upnp_intel.cpp:795: ERROR!
upnp_intel debug: upnp_intel.cpp:746: ERROR: UPNP_E_OUTOF_BOUNDS
upnp_intel debug: upnp_intel.cpp:795: ERROR!

Some playlist category entries appear but no media.

If I enable UPnP *after* Rhythmbox's UPnP server is started, the playlist is eventually (!) filled with the media tree of the FRITZ!Box.
This is strange behavior and needs fixing, don't know if in libupnp or vlc or both. No wonder why this isn't enabled at the moment. I've just seen that libupnp3 is coming for intrepid, maybe this feature could be pushed for the next release.

Whoopie (whoopie79) wrote :

There's a project for Google SoC 2008. You can follow the progress in the blog at http://mirsal.ennaime.free.fr/

Changed in vlc:
status: New → Confirmed
Changed in vlc:
status: Unknown → New
Changed in vlc:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.0~rc2-1ubuntu1

---------------
vlc (1.0.0~rc2-1ubuntu1) karmic; urgency=low

  * New upstream version.
  * tighten build-dependencies on libschroedinger-dev, fixes FTBFS.
  * Following bugs have an associated and now closed upstream ticket in
    Launchpad: LP: #281295, #73449, #282567, #117640, #172938, #260918,
    #273685, #275043, #277834, #282394, #290753, #294136, #298925, #304265,
    #309728, #311742, #314038

vlc (1.0.0~rc2-1) experimental; urgency=low

  * New Upstream Release Candidate
    + Closes: #527010, #491441, #508618, #522824
  * Delete patches which were picked from upstream
  * Refresh patches
  * Remove vlc-plugin-esd and vlc-plugin-arts as they have been removed
    by upstream
  * SONAME change for libvlccore
  * Add new symbols for libvlc2
  * Fix static libs compile
  * Use vlc-wrapper manpage from upstream
  * vlc.install: add drawable and screen was renamed x11_screen
  * vlc-nox.install: Add and remove modules added/removed upstream
  * Point out in NEWS the modules renamed or splited
  * Add links to upstream NEWS and co in vlc-nox
  * Version the depedency of libvlcore2 on vlc-data
  * Remove unnecessary "Section:" in debian/control

vlc (0.9.9a-3) unstable; urgency=low

  * Correct typo in 0.9.9a-2 changelog entry
  * Disable more optimization with DEB_BUILD_OPTIONS=noopt
  * Cache the configure test results as we're running configure several
    times
  * Fix building as root
  * Fix the clean target
  * Remove unexistant config options
  * Better check commad line
  * Use all the procs on i386 and amd64
  * Build a version of libvlccore without altivec (Closes: #523035)
  * Fix typo (thanks to Salvatore Bonaccorso)(Closes: #528044)
  * Reword the command line to get full logs in bug/presubj (Closes: #527012)
  * Remove duplicate "extended Settings" entry in context menu
   (Closes: #526603) - thanks to Matt Kraai

 -- Reinhard Tartler <email address hidden> Fri, 05 Jun 2009 12:28:15 +0200

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Anders (andersja+launchpad-net) wrote :

Sorry to suggest reopening this bug, but on a fully updated Karmic RC install, there is no UPnP support in VLC...?

I even installed libupnp4 manually, to no avail?

Followed the instructions here:
http://wiki.videolan.org/Documentation:Modules/upnp_intel

output:
$ vlc --services-discovery upnp_intel
VLC media player 1.0.2 Goldeneye
[0x9a64358] main playlist error: No such module: upnp_intel
[0x9a6ac40] main interface error: no interface module matched "globalhotkeys,none"
[0x9a6ac40] main interface error: no suitable interface module
[0x99ce140] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x99ce140] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

Paul Rensing (prensing) wrote :

Similar results for Karmic full release. UPnP does not appear to be turned on in the build.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.