VLC under Wayland causes system freezes in fullscreen mode

Bug #1720901 reported by Simon P. on 2017-10-02
106
This bug affects 21 people
Affects Status Importance Assigned to Milestone
VLC media player
New
Undecided
Unassigned
vlc (Debian)
Fix Released
Unknown
vlc (Ubuntu)
High
Unassigned

Bug Description

Ubuntu version: 17.10 (most recent updates as of October 3rd)
vlc version: 2.2.6-6

Whan I expect to happen: When playing a video in vlc and switching to fullscreen mode everything should work fine. Also when changing to a different position of a movie in fullscreen I expect the player to just switch to that position.

What actually happens: It seems to depend a little on the file type of the video, mostly I get problems when going to fullscreen mode and then switching to a different position with the playback position bar. With some videos it was even enough to just open the fullscreen mode. The video freezes just displaying a frame while the audio keeps playing. The computer does not react any more to mouse or keyboard input, I have to perform a hard reboot.

This problem only appears under the Wayland session, in the Xorg session everything works fine as expected.
---
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 17.10
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-09-30 (2 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
Package: vlc 2.2.6-6
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Tags: artful wayland-session
Uname: Linux 4.13.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
_MarkForUpload: True

apport information

tags: added: apport-collected artful wayland-session
description: updated

apport information

apport information

apport information

apport information

Changed in vlc (Debian):
status: Unknown → Fix Committed
affects: wayland (Ubuntu) → gnome-shell (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in vlc (Ubuntu):
importance: Undecided → High
status: New → In Progress
Sebastien Bacher (seb128) wrote :

vlc is being ported to wayland but whatever a client is doing gnome-shell shouldn't lock

Simon P. (simpre) wrote :

Created an upstream bug report for the gnome-shell: https://bugzilla.gnome.org/show_bug.cgi?id=789563

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
PTra (ptram1) wrote :

Affects me a swell, Ubuntu 17.10.

Hovering mouse over slider under VLC video Window -> 1-3 Minute freeze.

See Bug report on Gnome:

https://bugzilla.gnome.org/show_bug.cgi?id=777289

"Gnome wayland session freezes on mouse hovering over slider in VLC"

Possible Fix (confirmed by one of the gnome devs here??? -> https://bugzilla.gnome.org/show_bug.cgi?id=777428 )

See commit for VLC here:

https://git.videolan.org/gitweb.cgi/vlc.git/?a=commit;h=ea9923794767e5e65b0cfb3b9b51a2e593c3d75b

(remove X11BypassWindowManagerHint from time tooltip)

Please backport it to current stable VLC packaged in Ubuntu

PTra (ptram1) wrote :

Temporary workaround:

Go to VLC -> Tools -> Customize Interface -> Time toolbar

and remove the toolbar (just click on the bar items in the upper section of the dialogue until it's gone).

This will remove the timeline slider and avoids possible lockups.

Sebastien Bacher (seb128) wrote :

upstream seems to consider it's not a gnome-shell bug that it doesn't deal with the case better and vlc just needs to be fixed

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Low
Changed in vlc (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 3.0.0~rc1-1ubuntu1

---------------
vlc (3.0.0~rc1-1ubuntu1) bionic; urgency=medium

  * Apply patch from LocutusOfBorg to fix the FTBFS.

 -- Simon Quigley <email address hidden> Sat, 16 Dec 2017 16:18:42 -0600

Changed in vlc (Ubuntu):
status: In Progress → Fix Released
Simon P. (simpre) wrote :

I can still reproduce those system freezes with VLC 3.0.0 installed as a snap.

connor (kahnor) wrote :

This bug is driving me nuts, I've lost my data countless times because I always forget to *avoid* using VLC in fullscreen mode and to leave the damn position cursor alone. Sometimes I can kill vlc and save, other times it just freezes and I have to say goodbye to whatever I was working on.

Daniel van Vugt (vanvugt) wrote :

This bug has been marked as closed (Fix Released), rightly or wrong, already. So if you have any continuing problems it would be most helpful to open a new bug using this command:

  ubuntu-bug vlc

P.S. We recommend using either mpv or totem to play videos because those are the only players that seem to be capable of adequate hardware acceleration right now. For more information please see https://wiki.ubuntu.com/IntelQuickSyncVideo

Simon P. (simpre) wrote :

I don't understand why that bug was marked as fixed when the standard vlc package in Ubuntu is obviously not fixed and still causing those crashes and bothering users. And I really don't see the point for opening a new bug report for the same old problem, so I just changed the status of this bug.

Side note: In the current snap package of vlc 3.0.0-rc7 those crashes are not happening any more. As there are other minor issues in that snap (like no disabling of screen timeout while video playback), that is not a perfect workaround yet for users who prefer vlc.

Changed in vlc (Ubuntu):
status: Fix Released → Confirmed
Daniel van Vugt (vanvugt) wrote :

Certainly as the original reporter you have the right to reopen this bug if you say it's not fixed.

Just to clarify, are you saying:

3.0.0-rc7 snap = FIXED
3.0.0~rc4-1ubuntu1 deb = not fixed?

Simon P. (simpre) wrote :

To clarify:

The bug was originally filed for vlc stable. It is still existent in that stable version 2.2.6, which can be installed via apt-get.

In the current 3.0.0-rc7 snap it is fixed.

Daniel van Vugt (vanvugt) wrote :

Please try the current deb version in Ubuntu 18.04 ( 3.0.0~rc4-1ubuntu1).

If that works then the correct approach is for us to mark this as Fix Released, but also nominate older versions of Ubuntu to receive a fix later.

Marking as incomplete until Simon tested vlc 3.0.0 as provided by Ubuntu. FWIW, vlc 2.2.x won't see any Wayland fixes. If you use Wayland and vlc, you'll need to use 3.0.0.

Changed in vlc (Ubuntu):
status: Confirmed → Incomplete
Simon P. (simpre) wrote :

I just tested vlc 3.0.0-rc4 in a Ubuntu 18.04 live session and I can confirm that the problem is fixed there.

So will 17.10 see the fixed vlc package? It is still three more months till the release of the lts...

Thanks, marking as fixed again. Regarding vlc 3.0.0 in 17.10, you'll need someone who's familiar with the Ubuntu's policy on that.

Changed in vlc (Ubuntu):
status: Incomplete → Fix Released
Daniel van Vugt (vanvugt) wrote :

Wait, isn't the live session Xorg, not Wayland?

Spam Trash (spam-trash) wrote :

I have Ubuntu 18.04 and VLC 3.0.3 and I am affected by this bug.
I also think that no matter what GUI API is called, the system should allow quitting the app at worst. But not even Ctrl+Alt+Fx functions work to switch to terminal.

Spam Trash (spam-trash) wrote :

So should I just duplicate this to a new bug?

Daniel van Vugt (vanvugt) wrote :

This bug is closed (the status is Fix Released). So yes you will need to open a new bug...

Simon P. (simpre) wrote :

I can confirm that I am experiencing the same bug again since the vlc update to 3.0.3

Brix Fortuna (brixlinux02) wrote :

VLC media player 3.0.3 Vetinari
It freezes on fullscreen. I'm new to ubuntu so i don't really understand the threads. Can someone enlighten me. Thanks!

Daniel van Vugt (vanvugt) wrote :

Since the original reporter confirms the bug was fixed for a while prior to version 3.0.3, it would be best to open a new bug and mention there what version the regression occurred in.

To open that new bug, please just run:

  ubuntu-bug vlc

Ryan Fugger (rfugger) wrote :

New bug (same issue, on VLC 3.0.3/Ubuntu 18.04) is here:

https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1785434

no longer affects: gnome-shell (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.