libgles1-mesa is being removed, don't depend on it

Bug #1676845 reported by Timo Aaltonen on 2017-03-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
opentk (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

[Impact]
Mesa in zesty has dropped libgles1-mesa, slightly ahead of upstream. Backporting mesa to xenial & yakkety requires packages that depend on it to stop doing that.

Nothing really should depend on OpenGL ES v1 (GLESv1), which was meant for fixed-function GPU's, and we don't support those anyway. For a reference, Fedora never enabled support for it in Mesa.

[Test case]
Check that vlc / libopentk1.1-cil are installable together with Mesa 17.0.x

[Regression potential]
GLESv1 is not needed by anything really, so there shouldn't be a risk of regressing any use case.

Timo Aaltonen (tjaalton) wrote :

fixed in zesty

Changed in vlc (Ubuntu):
status: New → Fix Released
Timo Aaltonen (tjaalton) wrote :

opentk fixed in zesty

Changed in opentk (Ubuntu):
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2017-03-28
description: updated

Hello Timo, or anyone else affected,

Accepted vlc into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vlc/2.2.2-5ubuntu0.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vlc (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

For the yakkety upload I see an ffmpeg-2-8-10 directory was added, can you fix and reupload?

Changed in opentk (Ubuntu Xenial):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Timo, or anyone else affected,

Accepted opentk into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/opentk/1.1.4c+dfsg-2ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in opentk (Ubuntu Yakkety):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Timo, or anyone else affected,

Accepted opentk into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/opentk/1.1.4c+dfsg-2ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Timo Aaltonen (tjaalton) wrote :

vlc and libopentk1.1-cil can now be installed with ppa:ubuntu-x-swat/updates enabled, thanks

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Flipped the tag back to v-needed since its not clear what release was tested.

tags: added: verification-needed
removed: verification-done
Timo Aaltonen (tjaalton) wrote :

xenial was

Brian Murray (brian-murray) wrote :

Hello Timo, or anyone else affected,

Accepted vlc into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vlc/2.2.4-4ubuntu0.16.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done-xenial
removed: verification-needed
Changed in vlc (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Robie Basak (racb) wrote :

16:13 <rbasak> tjaalton: for bug 1676845, wouldn't it be appropriate to check that vlc still actually works?
16:13 <rbasak> Similarly opentk.
16:14 <rbasak> arges, bdmurray: ^

Robie Basak (racb) wrote :

16:16 <tjaalton> rbasak: it works

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.2.2-5ubuntu0.16.04.2

---------------
vlc (2.2.2-5ubuntu0.16.04.2) xenial; urgency=medium

  * Don't enable GLESv1 support. (LP: #1676845)

 -- Timo Aaltonen <email address hidden> Tue, 28 Mar 2017 14:23:57 +0300

Changed in vlc (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package opentk - 1.1.4c+dfsg-2ubuntu0.16.04.1

---------------
opentk (1.1.4c+dfsg-2ubuntu0.16.04.1) xenial; urgency=medium

  * Don't enable GLESv1. (LP: #1676845)

 -- Timo Aaltonen <email address hidden> Tue, 28 Mar 2017 14:46:11 +0300

Changed in opentk (Ubuntu Xenial):
status: Fix Committed → Fix Released

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers