vlc can't play httplive streams with external subtitles

Bug #1654459 reported by Ian Turner on 2017-01-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Consider the attachments. If you run 'vlc playlist.m3u8', it plays fine. But if you run 'vlc playlist.m3u8 --sub-file subtitles.vtt' then nothing plays and you get '' on the console.

Console output without subs:

[00000000008b4148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007f83a4c014e8] httplive stream: HTTP Live Streaming (/tmp/playlist.m3u8)
[00007f83a4c21e98] ts demux: MPEG-4 descriptor not found for pid 0x102 type 0xf
[00007f83a4de1278] packetizer_mpeg4audio packetizer: AAC channels: 2 samplerate: 44100
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
[00007f83a4c018f8] avcodec decoder: Using Intel i965 driver for Intel(R) Sandybridge Mobile - 1.7.0 for hardware decoding.

Console output with subs:
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[00000000016bb148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007fe05cc014e8] httplive stream: HTTP Live Streaming (/tmp/playlist.m3u8)
[00007fe05cc21ce8] ts demux: MPEG-4 descriptor not found for pid 0x102 type 0xf
[00007fe05cc020b8] core demux error: option sub-original-fps does not exist

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: vlc 2.2.2-5
ProcVersionSignature: Ubuntu 4.4.0-57.78-generic 4.4.35
Uname: Linux 4.4.0-57-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
Date: Thu Jan 5 21:04:09 2017
InstallationDate: Installed on 2012-10-07 (1551 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120822.4)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc
UpgradeStatus: Upgraded to xenial on 2016-04-09 (271 days ago)

Ian Turner (vectro) wrote :
Ian Turner (vectro) wrote :
madbiologist (me-again) wrote :

Does this still occur on Ubuntu 17.04 "Zesty Zapus" with vlc 2.2.4-14ubuntu2.1 ? If you are able to test on Ubuntu 17.10 "Artful Aardvark" with vlc 2.2.6-3build1 that would be even better.

Changed in vlc (Ubuntu):
status: New → Incomplete
Ian Turner (vectro) wrote :

Tested with vlc 2.2.6-3build2 (from artful) and got the same behavior as originally reported.

madbiologist (me-again) on 2017-08-20
Changed in vlc (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers