Video playback is garbled / choppy / stuttering with ALSA audio output

Bug #1639479 reported by Forest on 2016-11-05
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
vlc (Debian)
Fix Released
vlc (Ubuntu)

Bug Description

VLC 2.x fails to play many videos smoothly when ALSA audio output is selected. Every 10-30 seconds, the picture gets badly garbled, as if there were packet loss in the video stream. I see the problem most often with high def content.

The problem has been identified upstream, and reportedly fixed in vlc 3.0, but they are dismissive of users wanting a fix for 2.x. Given that this bug exists in the current LTS release and we're likely to be stuck with vlc 2.x for years to come, this is kind of a problem.

I have a pair of patches that apply to both vlc 2.2.2 and vlc 2.2.4. I have been using them with no problems for the past couple of months. Anyone else who wants to test them is most welcome, of course. Patched builds are available for xenial on my PPA:

Forest (foresto) wrote :
Forest (foresto) wrote :
summary: - Video playback is choppy / stuttering with ALSA audio output
+ Video playback is garbled / choppy / stuttering with ALSA audio output

The attachment "patch 1/2" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in vlc (Debian):
status: Unknown → Confirmed
Changed in vlc (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 3.0.0~rc1-1ubuntu1

vlc (3.0.0~rc1-1ubuntu1) bionic; urgency=medium

  * Apply patch from LocutusOfBorg to fix the FTBFS.

 -- Simon Quigley <email address hidden> Sat, 16 Dec 2017 16:18:42 -0600

Changed in vlc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.