Possible freeze and crash if loop for nonexisting file

Bug #1443864 reported by Misaki on 2015-04-14
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

If vlc is trying to load a file, or multiple files that don't exist, CPU usage will increase while many error messages announcing this problem will appear. This can lead to a freeze and crash, and pressing 'hide future errors' might not help since CPU usage will still be high. Sometimes it's possible to fix this by quickly pressing the stop button, but this doesn't always work.

Desired result: if a full loop of a playlist, or always if set to loop a single item, results in no items being found, VLC should wait for a bit before trying again. Pressing spacebar or any other key that normally pauses the video (as opposed to stopping it) should also cause it to stop trying to load more items.

It doesn't seem to be easy to cause VLC to actually lock up... ok in fact, what just happened was that by trying to play a file that didn't exist several times, after I stopped trying my CPU usage was high despite that VLC was supposedly not trying to open anything as no error messages were showing up. Pressing the stop button repeatedly did not change this, despite that pressing it caused it to change to the 'button pressed' animation.

Then after playing a video and then stopping it, CPU usage was back to 0.

Locking up might only seem to happen when VLC has been trying to open non-existent files for a few seconds too long; the 'non-responsive' test in Compiz that causes unresponsive windows to darken can activate. Just now, with vlc running at 100% of a CPU despite that no error messages were turning up, I tried starting it (to play a non-existent file) and then immediately stopping it, yet despite continually trying to click on the stop button, it took probably 12 seconds to stop.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: vlc 2.2.0-0ubuntu0.14.10.1
ProcVersionSignature: Ubuntu 3.16.0-30.40-generic 3.16.7-ckt3
Uname: Linux 3.16.0-30-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 14 02:46:27 2015
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Misaki (myjunkmail311006) wrote :
Misaki (myjunkmail311006) wrote :

If VLC is actively trying to open a new file, it can use all available CPUs, or at the very least two of them. After that, if it has an anomalously high CPU usage, it will only use 100% of one CPU. However, it seems that after a while this will stop even if no other videos are played; and in fact, playing an existing video does not actually cause the high CPU usage to stop; only after enough time has passed will it stop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Sebastian Ramacher (s-ramacher) wrote :

Workaround included in 3.0.7-1.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers