Sounds stops working when I change position in a video (seek)

Bug #1435085 reported by Nick Dowson on 2015-03-22
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
High
Unassigned

Bug Description

Hi,

When I am using vlc, if I change my position in the video - e.g. to skip ahead or to go back and watch something again - the sound stops working. Otherwise the video continues working as usual.

This is the case 95% of the time or more. Sometimes if I keep on changing the track position, I will be lucky and the sound will come back. Mostly I just have to reopen vlc ( and have no choice but to keep watching the video from the position.

- -

What I expect to happen: vlc should play from wherever I click on the track slider, with no problems and audio and video working fine.

What happens instead: vlc continues playing video from new position, but without playing any sound.

Steps to reproduce: open a video in vlc. Then click on the bar which shows at what point you are in the video to change it to a different position. Audio will disappear.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: vlc-nox 2.2.0~pre2-4build1
ProcVersionSignature: Ubuntu 3.16.0-31.43-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Mar 22 22:05:44 2015
ExecutablePath: /usr/bin/vlc
InstallationDate: Installed on 2014-05-02 (324 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc
UpgradeStatus: Upgraded to utopic on 2015-02-17 (33 days ago)

Nick Dowson (nickmdowson) wrote :

I am having the same issue on my VLC. Ubuntu 14.10 with most videos that I try to watch.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Changed in vlc (Ubuntu):
importance: Undecided → High

Can confirm I'm also getting this in Debian Jessie (KDE desktop) - although
I think not as regularly - I know this is the Ubuntu bug tracker but
thought that was also relevant.

On 13 April 2015 at 18:47, Alberto Salvia Novella <email address hidden>
wrote:

> ** Changed in: vlc (Ubuntu)
> Importance: Undecided => High
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1435085
>
> Title:
> Sounds stops working when I change position in a video (seek)
>
> Status in vlc package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi,
>
> When I am using vlc, if I change my position in the video - e.g. to
> skip ahead or to go back and watch something again - the sound stops
> working. Otherwise the video continues working as usual.
>
> This is the case 95% of the time or more. Sometimes if I keep on
> changing the track position, I will be lucky and the sound will come
> back. Mostly I just have to reopen vlc ( and have no choice but to
> keep watching the video from the position.
>
>
> - -
>
> What I expect to happen: vlc should play from wherever I click on the
> track slider, with no problems and audio and video working fine.
>
> What happens instead: vlc continues playing video from new position,
> but without playing any sound.
>
> Steps to reproduce: open a video in vlc. Then click on the bar which
> shows at what point you are in the video to change it to a different
> position. Audio will disappear.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.10
> Package: vlc-nox 2.2.0~pre2-4build1
> ProcVersionSignature: Ubuntu 3.16.0-31.43-generic 3.16.7-ckt5
> Uname: Linux 3.16.0-31-generic x86_64
> ApportVersion: 2.14.7-0ubuntu8.2
> Architecture: amd64
> CurrentDesktop: KDE
> Date: Sun Mar 22 22:05:44 2015
> ExecutablePath: /usr/bin/vlc
> InstallationDate: Installed on 2014-05-02 (324 days ago)
> InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140416.1)
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SourcePackage: vlc
> UpgradeStatus: Upgraded to utopic on 2015-02-17 (33 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1435085/+subscriptions
>

This bug happened to me many times before when watching 1080p and 720p videos on older PCs. I have tried on many PC and it is due to the CPU power. The audio will not play if the frame to which you seeked takes to much time to decode. Pausing VLC then seeking, waiting a bit, the pressing play will give enough time for VLC to decode the frame and the audio will play. This bug has less chances to occur if you skip to a key frame of the video because it takes less time to decode.

Rémi Denis-Courmont (rdenis) wrote :
Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed
Nick Dowson (nickmdowson) wrote :

Great,thanks
On Wednesday 12 Aug 2015 07:33:02 you wrote:
> This was fixed upstream some time ago:
> https://mailman.videolan.org/pipermail/vlc-> commits/2015-April/030064.html
>
> ** Changed in: vlc (Ubuntu)
> Status: Confirmed => Fix Committed

Don't change the status unless the package provided by Ubuntu software archive is also fixed.

Changed in vlc (Ubuntu):
status: Fix Committed → Confirmed
Rémi Denis-Courmont (rdenis) wrote :

This Fix Committed procedure is as agreed between VLC developers and the Debian/Ubuntu multimedia team.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed

The commit is included in 2.2.2, so marking as fixed.

Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers