VLC cannot open videos (smb:// URL) in Lubuntu 14.04 (using PCmanFM)

Bug #1320479 reported by Jens on 2014-05-17
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

When using PCmanFM in Lubuntu 14.04 to open a file with VLC (via right click + "VLC Media Player"), I get

     Ihre Eingabe konnte nicht geöffnet werden:
     VLC kann die MRL 'smb://mybooklive/gemeinsames/Fotos/EVENTS/2014/2014.05.04f%20H%C3%A4nde.......
     nicht öffnen. Sehen Sie für Details im Fehlerprotokoll nach.

(Translation: Cannot open your input file: VLC cannot open MRL (...). View the error log for details.)

This - opening files on SMB shares - used to work fine in Ubuntu 12.04 (using the default Unity desktop though). Using the default players "Gnome Player" and "Videos" works fine.

The installation in question is fresh, I installed Ubuntu 14.04 and then used `apt install lubuntu-desktop` to install Lubuntu, and am using it on a fresh user account that was never booted into Unity.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: vlc 2.1.2-2build2
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: LXDE
Date: Sat May 17 14:17:46 2014
InstallationDate: Installed on 2014-05-16 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64+mac (20140417)
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Jens (jens-launchpad-net) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed

This bug is present on other distros as well so it seems to be a PCManFM bug. Maybe it needs to be pushed upstream? Seems like PCManFM messes up the path so that most players, not only VLC, can't play the content. The only two players I have found that is usable is GNOME-Mplayer and barebones mplayer.

Agent.Logic_ (scr1pt-k33p3r) wrote :

I had this problem after I upgraded from Ubuntu 13.10 to 14.04. After messing around with the settings, I got it to work again. What I did was to go to Tools -> Preferences -> Show all settings (at the bottom left) -> Input / Codecs -> Access Modules -> SMB, and then input your Samba credentials there.

Changed in vlc (Ubuntu):
status: Confirmed → Invalid
Jens (jens-launchpad-net) wrote :

This bug is not "invalid". The comment #4 is not a solution, since "your SMB credentials" vary depending on the server that one wants to connect to. The SMB credentials of the respective shares are saved in my keyring and PCmanFM uses them to mount SMB shares.

Also: Opening videos on SMB shares with VLC using Nautilus or Nemo as file managers works perfectly. So it is neither a VLC issue nor a SMB authentication issue. See also http://sourceforge.net/p/pcmanfm/bugs/497/.

Please reopen.

Rémi Denis-Courmont (rdenis) wrote :

If it is not "a VLC issue", then it is "Invalid" for VLC... Feel free to add a different affected package/project as you see fit.

Jens (jens-launchpad-net) wrote :

It is a VLC issue since the same thing also happens when using VLC's "file open" dialog - completely without a file manager. At least in Ubuntu's VLC build.

In the file open dialog, I select a file on a SMB share and get the same error message. The share was mounted using Nemo and Nautilus file managers - so this also does not depend on the exact file manager (PCmanFM doesn't work either). At first I thought the real problem was how parameter (URLs) are passed from file manager to the application, but this doesn't seem to be the problem.

I am reporting this bug against VLC because *only* VLC seems to ever have had an issue with accessing shared SMB folders (regardless of the file manager or opening method used). Neither Totem nor any other player has this issue. So there must be something that VLC does differently than the others, right?

TenLeftFingers (tenleftfingers) wrote :

Testing with nautilus shows the shares are available. Testing with Audacious shows that the files stream properly. Issue lies with VLC and installing the vlc-samba module and adding authentication information didn't help.

Changed in vlc (Ubuntu):
status: Invalid → Confirmed
Jens (jens-launchpad-net) wrote :

Actually adding authentication information in VLC helps in my case - but only for one SMB server (if the information differs per server).

AFAIconcerned, the problem is here that VLC tries to reinvent the wheel (samba module) while there already is a GVFS mount point that is ready for use by any application when using Nautilus or similar apps.

VLC should just use the existing GVFS mounts (or KIO slaves) when available, not create its own solution. This is what other apps seem to be doing and it works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers